Realtime Application (R&S FSW-K160R)
Contents
  • Welcome to the R&S FSW Realtime Extension
  • Typical Applications
  • Applications and Operating Modes
  • Measurements and Result Displays
  • Realtime Basics
  • Configuring the Realtime Spectrum Application
  • Configuring and Performing Measurements in MSRT Mode
  • Analysis
  • How to Perform Realtime Measurements
  • Optimizing and Troubleshooting the Measurement
  • Remote Commands to Perform Realtime Measurements
  • List of Commands
Top


Welcome to the R&S FSW Realtime Extension

Realtime Application (R&S FSW-K160R) > Welcome to the R&S FSW Realtime Extension
Welcome to the R&S FSW Realtime Extension

The R&S FSW Realtime Extension option K160R provides both an application and an operating mode to display HF spectra in realtime and gapless, allowing for quick and simple error analysis and signal characterization. While the Realtime Spectrum application can perform basic realtime spectrum analysis on RF input data, the Multi-Standard Realtime (MSRT) operating mode can capture data in realtime and then analyze this data in various applications, similar to the Multi-Standard Radio Analysis (MSRA) operating mode.

Realtime measurements and B500 bandwidth extension

If the R&S FSW-B500 bandwidth extension option is installed, neither realtime measurements nor MSRT mode are available! For details see the R&S FSW-B500 data sheet.

The Realtime Spectrum application features:
  • Seamless data acquisition over a bandwidth of up to 160 GHz
  • Spectrum analysis in realtime with 60% time overlap
  • Spectrogram function for gapless spectrum display in the time domain in realtime
  • Frequency mask trigger (FMT) to trigger the measurement by sporadic or transient events in the spectrum
  • Persistence mode to visualize how frequently signals occur
  • Power versus time display to analyze the length/time variance of signals
  • Variable coupling ratio and variable FFT windows
The Multi-Standard Realtime (MSRT) operating mode features:
  • Realtime analysis of the same RF data in more than one application
  • Analysis of correlated effects captured without gaps
  • Configuration of data acquisition settings only required once for all realtime applications
  • Overview of all results in one screen in addition to large display of individual results
  • Common analysis line (time marker) across all applications

This user manual contains a description of the functionality specific to the Realtime Spectrum application and the MSRT operating mode, including remote control operation.

All functions not discussed in this manual are the same as in Signal and Spectrum Analyzer mode and are described in the R&S FSW User Manual. The latest version is available for download at the product homepage.

For background information on realtime measurements and the MSRT operating mode concept see "Realtime Basics".

Installation

You can find detailed installation instructions in the R&S FSW Getting Started manual or in the Release Notes.

Contents
  • Starting the Realtime Spectrum Application
  • Starting the Multi-Standard Realtime (MSRT) Operating Mode
  • Understanding the Display Information


Starting the Realtime Spectrum Application

Realtime Application (R&S FSW-K160R) > Welcome to the R&S FSW Realtime Extension > Starting the Realtime Spectrum Application
Starting the Realtime Spectrum Application

The Realtime Spectrum application adds realtime measurement analysis to the R&S FSW. It is only available if the Realtime Extension option R&S FSW-K160R is installed.

To activate the Realtime Spectrum application

  1. Press the MODE key on the front panel of the R&S FSW.

    A dialog box opens that contains all operating modes and applications currently available on your R&S FSW.

  2. Select the "Realtime Spectrum" item.

    The R&S FSW opens a new measurement channel for the Realtime Spectrum application.

    For details see "Applications and Operating Modes".

The measurement is started immediately with the default settings. It can be configured in the Realtime Spectrum "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu (see "Configuration Overview").


Starting the Multi-Standard Realtime (MSRT) Operating Mode

Realtime Application (R&S FSW-K160R) > Welcome to the R&S FSW Realtime Extension > Starting the Multi-Standard Realtime (MSRT) Operating Mode
Starting the Multi-Standard Realtime (MSRT) Operating Mode

Multi-Standard Realtime (MSRT) is a new operating mode on the R&S FSW. It is only available if the Realtime Extension option R&S FSW-K160R is installed.

To activate the MSRT operating mode

  1. Press the MODE key on the front panel of the R&S FSW.

    A dialog box opens that contains all operating modes and applications currently available on your R&S FSW.

  2. Select the "Multi-Standard Realtime" tab.

  3. Confirm the message informing you that you are changing operating modes.

    The R&S FSW closes all active measurement channels in the current operating mode, then opens a new measurement channel for the MSRT operating mode.

    In addition to the "MSRT View" (the "Multiview" tab in Realtime mode), a "MSRT Master" tab is displayed.

    For details see "Applications and Operating Modes".

    The Sequencer is automatically activated in continuous mode (see "Using the Sequencer in MSRT Mode"), starting a Realtime data acquisition with the default settings. It can be configured in the Realtime "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu (see "Configuration Overview").

Remote command:

INST:MODE RTMStandard, see INSTrument:​MODE


Understanding the Display Information

Realtime Application (R&S FSW-K160R) > Welcome to the R&S FSW Realtime Extension > Understanding the Display Information
Understanding the Display Information
Contents
  • Realtime Spectrum Application
  • MSRT Operating Mode


Realtime Spectrum Application

Realtime Application (R&S FSW-K160R) > Welcome to the R&S FSW Realtime Extension > Understanding the Display Information > Realtime Spectrum Application
Realtime Spectrum Application

The following figure shows a measurement diagram in the Realtime Spectrum application. All different information areas are labeled. They are explained in more detail in the following sections.

1 = Channel bar for firmware and measurement settings
2 = Window title bar with diagram-specific (trace) information
3 = Spectrum and Spectrogram displays
5 = Diagram footer with diagram-specific information, depending on evaluation
6 = Instrument status bar with error messages, progress bar and date/time display
Channel bar information

In the Realtime Spectrum application, the R&S FSW shows the following settings:

Information displayed in the channel bar in the Realtime Spectrum application
Ref Level | Reference level
m.+el.Att | Mechanical and electronic RF attenuation
Offset | Reference level offset
SWT | Measurement time for data acquisition in frequency domain
PVT SWT | Measurement time for data acquisition in time domain
RBW | Resolution bandwidth
TRG | Trigger source
PreTrigger/PostTrigger | Data acquisition time before / after the trigger event
Meas | Measurement mode: High Resolution or Multidomain
SGL | The measurement is set to single sweep mode.

In addition, the channel bar also displays information on instrument settings that affect the measurement results even though this is not immediately apparent from the display of the measured values (e.g. transducer settings). This information is displayed only when applicable for the current measurement. For details see the R&S FSW Getting Started manual.

Window title bar information

For each diagram, the header provides the following information:

Window title bar information in the Realtime Spectrum application
1 = Window number
2 = Window type
3 = Trace color
4 = Trace number
5 = Detector
6 = Trace mode
7 = Color map legend
Diagram footer information
The diagram footer (beneath the diagram) contains the following information, depending on the evaluation:
  • Center frequency (CF)
  • Displayed span/ PVT sweep time
  • Displayed span/ PVT sweep time per division
Status bar information

Global instrument settings, the instrument status and any irregularities are indicated in the status bar beneath the diagram. Furthermore, the progress of the current operation is displayed in the status bar.


MSRT Operating Mode

Realtime Application (R&S FSW-K160R) > Welcome to the R&S FSW Realtime Extension > Understanding the Display Information > MSRT Operating Mode
MSRT Operating Mode

The following figure shows a screen display in MSRT operating mode. All different information areas are labeled. They are explained in more detail in the following sections.

  • The blue background of the screen behind the measurement channel tabs indicates that you are in MSRT operating mode.
  • The [image] icon on the tab label indicates that the displayed trace (e.g. in a realtime application) no longer matches the currently captured data. This may be the case, for example, if a data acquisition was performed in another application. As soon as the result display is refreshed, the icon disappears.
  • The [image] icon indicates that an error or warning is available for that measurement channel. This is particularly useful if the MSRT View tab is displayed.

An orange "IQ" indicates that the results displayed in the MSRT application(s) no longer match the data captured by the MSRT Master. The "IQ" disappears after the results in the application(s) are refreshed.

1 = MSRT View (overview of all active channels in MSRT mode)
2 = MSRT Master (data acquisition channel with global configuration settings)
3 = Measurement channel tabs for individual MSRT applications
4 = Channel bar for firmware and measurement settings of current channel
5+6 = Window title bar with diagram-specific (trace) information and analysis interval (applications)
7 = Spectrum display
8 = Diagram footer with diagram-specific information, depending on evaluation
9 = Instrument status bar with error messages, progress bar and date/time display

The diagram area varies depending on the type of measurement channel, as described in detail in the following topics.

Window title bar information

For each diagram, the header provides the following information:

Window title bar information in MSRT mode
1 = Window number
2 = Window type
3 = Trace color
4 = Trace number
5 = Detector
6 = Trace mode
7 = Analysis interval
8 = Analysis line indication
Diagram footer information

The information in the diagram footer (beneath the diagram) depends on the evaluation:

  • Center frequency
  • Number of sweep points
  • Range per division (x-axis)
  • Span (Spectrum)
Status bar information

Global instrument settings, the instrument status and any irregularities are indicated in the status bar beneath the diagram. Furthermore, the progress of the current operation is displayed in the status bar.

If an error or warning is available for a measurement channel, the [image] icon is displayed next to the tab label in the channel bar.

Contents
  • MSRT View
  • MSRT Master
  • MSRT Applications


MSRT View

Realtime Application (R&S FSW-K160R) > Welcome to the R&S FSW Realtime Extension > Understanding the Display Information > MSRT Operating Mode > MSRT View
MSRT View

The MSRT View is an overview of all active channels in MSRT mode, similar to the MultiView tab in Signal and Spectrum Analyzer mode. At the top of the screen the MSRT Master is displayed, i.e. the application that captures data. Beneath the MSRT Master, all active applications are displayed in individual windows. Each application has its own channel bar with the current settings as well as a button in order to switch to that application tab directly.

The MSRT View displays the following basic elements:

1 = Channel information bar for the MSRT Master
2 = Application data coverage for each active application
3 = Spectrum and Spectrogram displays for MSRT Master (for entire capture buffer)
4 = Channel information bar for application with button to switch to application tab
5 = Result displays for application (for analysis interval)


MSRT Master

Realtime Application (R&S FSW-K160R) > Welcome to the R&S FSW Realtime Extension > Understanding the Display Information > MSRT Operating Mode > MSRT Master
MSRT Master

The MSRT Master is the only channel that captures data. It also controls global configuration settings for all applications. The MSRT Master channel itself is implemented as a Realtime Spectrum application. The MSRT Master measurement channel cannot be deleted or replaced.

The following figure shows the screen elements specific to the MSRT Master.

1 = Channel information bar for the MSRT Master
2 = Data coverage for each active application
3 = Frequency mask (trigger)
4 = Spectrum display for MSRT Master (for entire capture buffer)
Data coverage for each active application

Each application obtains an extract of the data captured by the MSRT Master (see also "Multi-Standard Realtime Analysis"). Thus, it is of interest to know which application is analyzing which part of the captured data, or more precisely, which data channel. The MSRT Master display indicates the data covered by each application by vertical blue lines labeled with the application name.


MSRT Applications

Realtime Application (R&S FSW-K160R) > Welcome to the R&S FSW Realtime Extension > Understanding the Display Information > MSRT Operating Mode > MSRT Applications
MSRT Applications

The data captured by the MSRT Master measurement (or only parts of it) can be evaluated by various applications. The measurement channel for each application contains the settings and results for the application data extract from the capture buffer.

The following figure shows the screen elements specific to the MSRT application tabs.

1 = Channel information bar for applications
2 = Analysis interval for current evaluation
3 = Result displays for analysis intervals
4 = Analysis line

The display for the individual MSRT applications is identical to the display in Signal and Spectrum Analyzer mode except for the following differences:

  • The analysis interval indicates which part of the capture buffer is being evaluated and displayed in each window.
  • The acquisition time indicated in the channel bar (Meas Time) indicates the analyzed measurement time, not the captured time.
  • Any bandwidth or sample rate values refer to the application data, not to the actual data acquisition from the input signal.
  • The analysis line for time-based displays is only available in MSRT mode. It represents a common time marker in all applications whose analysis interval includes that time (see "Analysis line").

For details on the individual application displays see the "Measurements and Results" topic for those applications.


Typical Applications

Realtime Application (R&S FSW-K160R) > Typical Applications
Typical Applications

A common challenge when developing HF applications are sporadic and transient interferences. In order to keep the time for development short, it is essential that such interferences are detected quickly and that the exact cause is determined. Possible causes may be interference from digital circuits or short-term effects from frequency hopping techniques in sending devices. Thus, a seamless data acquisition and a frequency mask trigger are required.

A further application for realtime measurement is various standards working in the same frequency range, for example Bluetooth and WLAN. Frequent collisions reduce the data rates. To develop effective algorithms that elude collisions, the spectrum must be analyzed seamlessly.

Precise analysis of frequency-variant senders (hoppers) is not only indispensible for wireless data transfer, but also for radar applications or satellite communication. Administrative or regulatory authorities also depend on seamless spectrum analysis to supervise the frequency bands.


Applications and Operating Modes

Realtime Application (R&S FSW-K160R) > Applications and Operating Modes
Applications and Operating Modes

The R&S FSW provides several applications for different analysis tasks and different types of signals, e.g. vector signal analysis, I/Q analysis or basic spectrum analysis. When you activate an application, a new measurement channel is created which determines the measurement settings for that application. The same application can be activated with different measurement settings by creating several channels for the same application. Each channel is displayed in a separate tab on the screen.

The maximum number may be limited further by the available memory on the instrument.

independent vs correlating measurements

With the conventional R&S FSW Signal and Spectrum Analyzer you can perform several different measurements almost simultaneously. However, the individual measurements are independent of each other - each application captures and evaluates its own set of data, regardless of what the other applications do.

In some cases it may be useful to analyze the exact same input data using different applications. For example, imagine capturing data from a base station and analyzing the RF spectrum in the Analog Demodulation application. If a spur or an unexpected peak occurs, you may want to analyze the same data in the I/Q Analyzer to see the real and imaginary components of the signal and thus detect the reason for the irregular signal. Normally when you switch to a different application, evaluation is performed on the data that was captured by that application, and not the previous one. In our example that would mean the irregular signal would be lost. Therefore, a second operating mode is available in the R&S FSW: Multi-Standard Radio Analyzer (MSRA) mode.

Multi-Standard Radio Analyzer mode

In Multi-Standard Radio Analyzer (MSRA) mode, data acquisition is performed once as an I/Q measurement, and the captured data is then evaluated by any number of applications for different radio standards. Data acquisition and global configuration settings are controlled globally, while the evaluation and display settings can be configured individually for each application. Using the Multi-Standard Radio Analyzer, unwanted correlations between different signal components using different transmission standards can be detected. Thus, for example, an irregularity in a GSM burst can be examined closer in the R&S FSW 3G FDD BTS (W-CDMA) application to reveal dependencies like a change in the EVM value.

Multi-Standard Realtime mode

In order to combine the advantages of the MSRA mode with its correlated measurements and the gapless results provided by realtime measurements, a third operating mode has been introduced: the Multi-Standard Realtime (MSRT) mode. This operating mode is only available if the realtime option (R&S FSW-K160R) is installed.

In this operating mode, data acquisition is performed once as a realtime measurement, and the captured data is then evaluated by any number of applications. Thus, a realtime measurement triggered with a frequency mask can be performed, and the results can be evaluated in the VSA application, for example, to detect the cause of a frequency exception.

Distinct operating modes

Although the applications themselves are identical in all operating modes, the handling of the data between applications is not. Thus, the operating mode determines which applications are available and active. Whenever you change the operating mode, the currently active measurement channels are closed. The default operating mode is Signal and Spectrum Analyzer mode; however, the presetting can be changed.

Remote command:

INST:MODE RTMS, see INSTrument:​MODE

Switching between applications
When you switch to a new application, a set of parameters is passed on from the current application to the new one:
  • center frequency and frequency offset
  • reference level and reference level offset
  • attenuation

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

Contents
  • Available Applications
  • Selecting the Operating Mode and Application
  • Multiple Measurement Channels and Sequencer Function


Available Applications

Realtime Application (R&S FSW-K160R) > Applications and Operating Modes > Available Applications
Available Applications

The R&S FSW provides some applications in the base unit while others are available only if the corresponding firmware options are installed.

└ I/Q Analyzer
└ Analog Demodulation
└ Pulse Measurements
└ Transient Analysis
└ Vector Signal Analysis (VSA)


I/Q Analyzer

Realtime Application (R&S FSW-K160R) > Applications and Operating Modes > Available Applications > I/Q Analyzer
I/Q Analyzer

The I/Q Analyzer application provides measurement and display functions for digital I/Q signals. Evaluation of the captured I/Q data in the frequency and time domain is also possible.

For details refer to "Welcome to the I/Q Analyzer Application" .

Remote command:

INST:SEL IQ, see INSTrument[:​SELect]


Analog Demodulation

Realtime Application (R&S FSW-K160R) > Applications and Operating Modes > Available Applications > Analog Demodulation
Analog Demodulation

The Analog Demodulation application requires an instrument equipped with the corresponding optional software. This application provides measurement functions for demodulating AM, FM, or PM signals.

For details refer to "Welcome to the Analog Demodulation Application" .

Remote command:

INST:SEL ADEM, see INSTrument[:​SELect]


Pulse Measurements

Realtime Application (R&S FSW-K160R) > Applications and Operating Modes > Available Applications > Pulse Measurements
Pulse Measurements

The Pulse application requires an instrument equipped with the Pulse Measurements option, R&S FSW-K6. This application provides measurement functions for pulsed signals.

For details refer to "Welcome to the Pulse Measurements Application" .

Remote command:

INST:SEL PULSE, see INSTrument[:​SELect]


Transient Analysis

Realtime Application (R&S FSW-K160R) > Applications and Operating Modes > Available Applications > Transient Analysis
Transient Analysis

The Transient Analysis application requires an instrument equipped with the Transient Analysis option, R&S FSW-K60. This application provides measurements and evaluations for Transient Analysis.

For details refer to "Welcome to the Transient Analysis Application" .

Remote command:

INST:SEL TA, see INSTrument[:​SELect]


Vector Signal Analysis (VSA)

Realtime Application (R&S FSW-K160R) > Applications and Operating Modes > Available Applications > Vector Signal Analysis (VSA)
Vector Signal Analysis (VSA)

The VSA application requires an instrument equipped with the Vector Signal Analysis option, R&S FSW-K70. This application provides measurements and evaluations for Vector Signal Analysis.

For details refer to "Welcome to the Vector Signal Analysis Application" .

Remote command:

INST:SEL DDEM, see INSTrument[:​SELect]


Selecting the Operating Mode and Application

Realtime Application (R&S FSW-K160R) > Applications and Operating Modes > Selecting the Operating Mode and Application
Selecting the Operating Mode and Application

The default operating mode is Signal and Spectrum Analyzer mode, however, the presetting can be changed.

(See "General Configuration Settings" ).

Both the operating mode and the application can be selected in the "Mode" dialog box which is displayed when you press the MODE key.

To switch the operating mode, select the corresponding tab (see "Starting the Multi-Standard Realtime (MSRT) Operating Mode").

To select a Realtime Spectrum application, select the corresponding button (see "Starting the Realtime Spectrum Application").

The available applications are described in "Available Applications".

To close an application, simply close the corresponding tab.

The remote commands required to perform these tasks are described in "Activating Realtime Measurements in MSRT Mode".

└ New Channel
└ Replace Current Channel


New Channel

Realtime Application (R&S FSW-K160R) > Applications and Operating Modes > Selecting the Operating Mode and Application > New Channel
New Channel

The applications selected on this tab are started in a new channel, i.e. a new tab in the display.

For a list of available applications see "Available Applications".

Remote command:

INSTrument:​CREate[:​NEW]

INSTrument[:​SELect]


Replace Current Channel

Realtime Application (R&S FSW-K160R) > Applications and Operating Modes > Selecting the Operating Mode and Application > Replace Current Channel
Replace Current Channel

The applications selected on this tab are started in the currently displayed channel, replacing the current application.

For a list of available applications see "Available Applications".

Remote command:

INSTrument:​CREate:​REPLace


Multiple Measurement Channels and Sequencer Function

Realtime Application (R&S FSW-K160R) > Applications and Operating Modes > Multiple Measurement Channels and Sequencer Function
Multiple Measurement Channels and Sequencer Function

When you activate an application, a new measurement channel is created which determines the measurement settings for that application. The same application can be activated with different measurement settings by creating several channels for the same application.

The number of channels that can be configured at the same time depends on the available memory on the instrument.

Only one measurement can be performed at any time, namely the one in the currently active channel. However, in order to perform the configured measurements consecutively, a Sequencer function is provided.

If activated, the measurements configured in the currently active channels are performed one after the other in the order of the tabs. The currently active measurement is indicated by a [image] symbol in the tab label. The result displays of the individual channels are updated in the tabs (as well as the "MultiView") as the measurements are performed. Sequential operation itself is independent of the currently displayed tab.

For details on the Sequencer function see "Running a Sequence of Measurements" .

Using the Sequencer in MSRT mode

For information on using the Sequencer in MSRT mode see "Using the Sequencer in MSRT Mode".

Specifics of using the Sequencer in Realtime measurements

As opposed to other R&S FSW applications, a realtime measurement that is performed without a trigger ("Free Run" mode) in continuous mode never stops by itself (in order to provide gapless results). Thus, if such a realtime measurement is included in a continuous Sequencer process, the sequence will never continue once it has started the realtime measurement.

If a trigger is configured, the behavior of the Sequencer depends on the trigger settings.

Sequencer behavior for a Realtime Spectrum application
Sequencer mode | Trigger setting | Measurement behavior
Single sequence | No trigger (Free run) | Realtime application performs a single sweep (1 frame), then subsequent applications perform single sweep
 | Trigger + "Auto Rearm" | After trigger, Realtime application performs single sweep, trigger is rearmed; subsequent applications perform single sweep
 | Trigger + "Stop on trigger" | After trigger, Realtime application performs single sweep, trigger is not rearmed; subsequent applications perform single sweep
Continuous sequence | No trigger (Free run) | Realtime application performs continuous sweep; subsequent applications cannot perform any sweeps
 | Trigger + "Auto Rearm" | After trigger, Realtime application performs single sweep, trigger is rearmed; subsequent applications perform sweeps as configured; sequence is repeated with next trigger
 | Trigger + "Stop on trigger" | After trigger, Realtime application sweeps until trigger is received; trigger is not rearmed; subsequent applications perform sweeps as configured; Realtime application does not perform any more sweeps due to unarmed trigger
Channel defined sequence | No trigger (Free run) | Initial sequence as for single sequence mode. If Realtime application is in continuous sweep, subsequent applications cannot perform any sweeps after initial sequence.
 | Trigger + "Auto Rearm" | Initial sequence as for single sequence mode. After trigger, Realtime application performs single sweep, trigger is rearmed; subsequent applications perform sweeps as configured; sequence is repeated with next trigger
 | Trigger + "Stop on trigger" | Initial sequence as for single sequence mode. Subsequent applications perform sweeps as configured; Realtime application does not perform any more sweeps due to unarmed trigger

For details on realtime trigger settings see "Trigger Configuration".


Measurements and Result Displays

Realtime Application (R&S FSW-K160R) > Measurements and Result Displays
Measurements and Result Displays

In order to accomodate for different requirements, various measurement types and result displays are provided for realtime measurements.

Contents
  • Realtime Measurement Types
  • Realtime Result Displays


Realtime Measurement Types

Realtime Application (R&S FSW-K160R) > Measurements and Result Displays > Realtime Measurement Types
Realtime Measurement Types

The R&S FSW-K160R application provides different measurement types to allow for realtime measurements either optimized for high resolution or providing additional evaluation in the time domain.

Contents
  • High Resolution Realtime Measurement
  • Multi Domain Realtime Measurement


High Resolution Realtime Measurement

Realtime Application (R&S FSW-K160R) > Measurements and Result Displays > Realtime Measurement Types > High Resolution Realtime Measurement
High Resolution Realtime Measurement

High Resolution realtime measurements are performed with an exceptionally large bandwidth of 160 MHz, allowing for very precise results in the frequency domain.

Additional Span/RBW couplings are available for precise frequency results.

Result displays
For High Resolution measurements, the following result displays are available:
  • "Realtime Spectrum"
  • "Spectrogram"
  • "Persistence Spectrum"
  • "Marker Table"
SCPI command:

CONF:REAL:MEAS FPM, see CONFigure:​REALtime:​MEASurement


Multi Domain Realtime Measurement

Realtime Application (R&S FSW-K160R) > Measurements and Result Displays > Realtime Measurement Types > Multi Domain Realtime Measurement
Multi Domain Realtime Measurement

Multi Domain realtime measurements allow for results both in the frequency and time domains, however with a restriced bandwidth of 100 MHz.

Result displays
For Multi Domain measurements, the following result displays are available:
  • "Realtime Spectrum"
  • "Spectrogram"
  • "Persistence Spectrum"
  • "Power vs Time"
  • "PVT Waterfall"
  • "Marker Table"
SCPI command:

CONF:REAL:MEAS MDOM, see CONFigure:​REALtime:​MEASurement


Realtime Result Displays

Realtime Application (R&S FSW-K160R) > Measurements and Result Displays > Realtime Result Displays
Realtime Result Displays

The R&S FSW Realtime measurements not only process data in realtime, but also offer several result displays that help you analyze the data as it is displayed. The human eye has a limited capability of detecting changes – therefore realtime displays visualize the time axis, i.e. the changes of as signal over time. Display modes with information on past and present spectra at the same time allow for a quick analysis of changes for human eyes.

For Realtime measurements, up to 6 result displays can be displayed simultaneously in separate windows.

└ Realtime Spectrum
└ Spectrogram
└ Persistence Spectrum
└ Power vs Time
└ PVT Waterfall
└ Marker Table


Realtime Spectrum

Realtime Application (R&S FSW-K160R) > Measurements and Result Displays > Realtime Result Displays > Realtime Spectrum
Realtime Spectrum

The Realtime Spectrum diagram displays the measured power levels for a frequency span of 160 MHz (High Resolution measurement) or 100 MHz (Multi Domain measurement) around the selected center frequency. The displayed data corresponds to one particular frame in the spectrogram. During a running measurement, the most recently captured frame is always displayed. During analysis, which frame is displayed depends on the selected frame in the spectrogram configuration (see "Selecting a frame to display") or the marker position in the spectrogram (see "Frame").

Realtime Spectrum result display

Thus, the Realtime Spectrum is useful to analyze the input signal measured at a specific time in more detail.

Remote command:

LAY:ADD? '1',RIGH, 'XFRequency', see LAYout:​ADD[:​WINDow]?


Spectrogram

Realtime Application (R&S FSW-K160R) > Measurements and Result Displays > Realtime Result Displays > Spectrogram
Spectrogram

The spectrogram is a way of displaying multiple consecutive spectra over time. The power, or more exactly the power level, which is usually displayed over frequency is displayed over frequency and time. Graphically, time and frequency represent the vertical and horizontal axes of the diagram. Each coordinate (frequency f, time t) of the diagram is filled with a color representing the level for the respective frequency and time.

At the beginning of a measurement, the diagram is empty. As the measurement advances, the graph is filled line by line from top to bottom. Lines in the spectrogram are called frames, as each frame represents one spectrum.

As the graph fills from top to bottom, the latest spectrum is always the topmost line, whereas older frames move towards the bottom.

Frequency hopper exhibiting a transition with significant RF level from lowest to intermediate frequency

The spectrogram is a powerful tool to analyze time variant spectra. Typical applications are the transient oscillation of a VCO and the analysis of frequency hopping signals. figure "Frequency hopper exhibiting a transition with significant RF level from lowest to intermediate frequency" shows a frequency hopper, regularly hopping between 3 frequencies. It is clearly visible that the signal is not completely off during the first hop (lowest frequency to middle frequency), whereas no significant RF level can be observed during the second hop.

Realtime spectrograms are highly configurable. In particular, the number of frames and the colors used to display the power levels can be defined by the user.

Spectrograms are particularly useful in combination with a spectrum display. In this case, the spectogram provides an overview of events over time, whereas the spectrum provides details for a specific frame.

For more information on working with spectrograms see "Working with Spectrograms and Waterfall Diagrams".

Remote command:

LAY:ADD? '1',RIGH, 'XFRequency:SGRam', see LAYout:​ADD[:​WINDow]?


Persistence Spectrum

Realtime Application (R&S FSW-K160R) > Measurements and Result Displays > Realtime Result Displays > Persistence Spectrum
Persistence Spectrum

In addition to the Realtime Spectrum, a Persistence Spectrum is provided. This result is also referred to as a spectral histogram. Both indicate the main features of this result display: persistence and histogram information. Persistence helps you view even very short events that the human eye could not capture otherwise. Moreover, it also allows for comparison between two events that are separated in time, but which share a time frame called persistence granularity. This time frame specifies the amount of time it takes for a singular event to fade completely.

Histogram information

Histogram information is basically a counter that sums up the appearance of a certain frequency/level pair within a certain amount of time. Instead of displaying the total of a counter, the persistence spectrum displays the counter result normalized to the maximum achievable count, which yields a probability of appearance for each frequency/level pair.

The persistence spectrum is made up of a horizontal frequency axis and a vertical level axis just as a normal spectrum display. The color of each dot in the persistence spectrum contains the histogram information, i.e. the probability information.

A typical application for the persistence spectrum is the analysis of signals that vary over time. It is an especially powerful tool to give the user a first idea of a signal, before it can be analyzed in detail.

Persistence

Using a persistence spectrum, fast frequency hops can be distinguished clearly from amplitude drops, whereas conventional analyzers may mislead the user. As opposed to the spectrogram display, the persistence spectrum offers a higher level resolution, as it does not employ color coding for the power. In addition, the persistence spectrum achieves a higher time resolution as the realtime spectrogram, as it does not use detectors.

Tip: In order to analyze the duration of an event found in the persistence spectrum, use the "Power vs Time" display.

Another application for the persistence spectrum is the separation of superimposed signals if they can be distinguished in terms of probability distribution of frequency/level pairs.

The figure "Wideband noise-like signal covering a GSM signal" shows a persistence spectrum of a noise-like signal resulting from a motor with brushes. A weak GSM signal is clearly visible in the center of the span. A standard spectrum analyzer cannot resolve the two different signals, as it does not display probabilities for each signal point.

Wideband noise-like signal covering a GSM signal

Maxhold trace

An optional maxhold trace indicates the maximum probabilities ever measured during the entire measurement for each point in the diagram. The intensity of the maxhold trace is configurable so that it can be distinguished from the current trace, but it is not time-dependant (indefinite persistence).

Finally, the standard current spectrum trace is displayed for reference.

For more information on how the histogram and persistence are evaluated see "Understanding Persistence".

Remote command:

LAY:ADD? '1',RIGH, 'XFRequency:PSPectrum', see LAYout:​ADD[:​WINDow]?


Power vs Time

Realtime Application (R&S FSW-K160R) > Measurements and Result Displays > Realtime Result Displays > Power vs Time
Power vs Time

The Power vs Time result display shows the power levels of a signal over a particular time period as a power vs time diagram. The horizontal axis represents the (current sweep) time. The vertical axis shows the power levels. The sweep time for the PVT diagram is configurable, independently of the sweep time in the frequency domain.

Note: Unlike other result displays in MSRT mode, a PVT diagram for an MSRT Master is not based on the analysis interval, but the specified PVT sweep time. Thus, the analysis interval is not indicated in the window title bar.

This result display is only available for "Multi Domain Realtime Measurement".

Power vs Time result display

This result display is particularly useful in combination with a "PVT Waterfall" display. Thus, you can determine irregular events in the waterfall, and analyze a specific frame in detail in the Power vs Time display.

During a running measurement, the most recently captured frame is always displayed in the PVT diagram. During analysis, which frame is displayed depends on the selected frame in the waterfall configuration (see "Selecting a frame to display") or on the marker position in the waterfall (see "Frame"). A separate frame number can be selected for measurements in the time domain, so that the displayed frame may differ from the Realtime Spectrum display.

The Power vs Time result display is also useful in combination with a "Persistence Spectrum" display. Thus, you can determine time information for events which are detected in the persistence spectrum, for example pulses.

Remote command:

LAY:ADD? '1',RIGH, 'XTIMe', see LAYout:​ADD[:​WINDow]?


PVT Waterfall

Realtime Application (R&S FSW-K160R) > Measurements and Result Displays > Realtime Result Displays > PVT Waterfall
PVT Waterfall

Similar to a spectrogram in the frequency domain, a waterfall diagram displays the measured power levels of the input signal over time for repeated measurements, thus showing the history of the measurement results.

This result display is only available for "Multi Domain Realtime Measurement".

PVT waterfalls are highly configurable. In particular, the number of frames and the colors used to display the power levels can be defined by the user. A separate sweep time is available for measurements in the time domain, so that the number of displayed "frames" may differ from the spectrogram display.

As the name "waterfall" implies, this diagram is filled from top to bottom; thus, the latest frame is always the topmost line, whereas older frames move towards the bottom.

Power vs Time Waterfall result display

To analyze a specific frame in the PVT waterfall in detail, use the "Power vs Time" diagram.

Remote command:

LAY:ADD? '1',RIGH, 'XTIMe:SGRam', see LAYout:​ADD[:​WINDow]?


Marker Table

Realtime Application (R&S FSW-K160R) > Measurements and Result Displays > Realtime Result Displays > Marker Table
Marker Table

Displays a table with the current marker values for the active markers.

Remote command:

LAY:ADD? '1',RIGH, MTAB, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Realtime Basics

Realtime Application (R&S FSW-K160R) > Realtime Basics
Realtime Basics

Some background knowledge on basic terms and principles used in realtime measurements (such as the mechanisms behind data capturing without blind times and triggering on frequency masks) is provided here for a better understanding of the required configuration settings.

Contents
  • Data Acquisition and Processing in Realtime
  • Defining the Resolution Bandwidth
  • Sweep Time and Detector
  • Triggering Realtime Measurements
  • Working with Spectrograms and Waterfall Diagrams
  • Understanding Persistence
  • Multi-Standard Realtime Analysis


Data Acquisition and Processing in Realtime

Realtime Application (R&S FSW-K160R) > Realtime Basics > Data Acquisition and Processing in Realtime
Data Acquisition and Processing in Realtime

This chapter shows the way the R&S FSW acquires and processes the data compared to a conventional spectrum analyzer.

For more background information on realtime spectrum analysis see the White Paper from Rohde & Schwarz in the Internet: http://cdn.rohde-schwarz.com/dl_downloads/dl_application/application_notes/1ef77/1EF77_2e.pdf.

A conventional spectrum analyzer typically loses information after it has captured the signal ('blind time'). This is because the LO has to return to the start frequency after a sweep of the selected frequency range (LO flyback). Blind time therefore occurs after the data capture and signal processing and before the next data capture can begin.

Conventional spectrum analyzer measurement principle
1 = Signals are captured by the sweep
2 = Signal is missed by the sweep because of LO flyback (blind time; extended for clarity)
A realtime analyzer does not lose any information for the following reasons:
  • There is no LO flyback because the LO is set to a fixed frequency in the realtime analyzer.
  • It performs overlapping Fast Fourier Transformations (FFT) instead of sweeping the spectrum or performing one FFT after another.
  • The R&S FSW captures data and performs FFTs at the same time instead of sequentially.
To get the results, the R&S FSW simultaneously performs several processing stages:
  • Acquiring the data
  • Processing the data
  • Displaying the data
Block diagram of the R&S FSW
Acquiring the data

The data acquisition process is the same as in a conventional spectrum analyzer. First, the R&S FSW either attenuates the signal that you have applied to the RF input to get a signal level that the R&S FSW can handle or, if you have a weak signal, preamplifies the signal and then down-converts the RF signal to an intermediary frequency (IF), usually in several stages.

After the down-conversion, the R&S FSW samples the signal into a digital data stream that is the basis for the Fast Fourier Transformation (FFT). The sampling rate the R&S FSW uses for sampling is variable, but depends on the span you have set. The maximum span is 160 MHz.

Continuous data stream

At the same time, the A/D data is captured in the I/Q memory.

Processing the data

The R&S FSW then splits the data stream stored in the I/Q memory into data blocks whose length is between 1024 and 16384 samples each to prepare it for the FFT.

Then the R&S FSW performs the FFT on all data blocks it has acquired. The FFT processing rate of the R&S FSW is variable with a maximum of approximately 600.000 FFTs per second.

The distinctive feature of a realtime analyzer is that it uses a particular amount of data more than once to get the measurement results. It takes the first data block of 1024 samples, for example, and performs the FFT on it. The second and all subsequent data blocks, however, do not start at the next sample (in the case of the second block, the 1025th), but at an earlier one. In fact, all data, except the first few samples, is processed more than once and overlapped to get the results.

At full span (160 MHz) this overlap of the FFTs is 67%. That means the second data block the R&S FSW performs the FFT on covers the last 67% of the data of the first FFT with only 33% new data. The third data block still covers 33% of the first data block and 67% of the second data block and so on.

Overlapping FFTs

The percentage of the overlap depends on the sampling rate and therefore on the span that you have set. With a span of 100 MHz, the overlap is 67%. If you reduce the span, the FFT calculator tries to keep the FFT processing rate and increases the overlap accordingly. Thus, the overlap can increase up to a value of 1023 overlapping samples out of 1024 samples, for example.

After the FFT is done and the spectrums have been calculated, the result is a stream of spectrums without information loss.


Defining the Resolution Bandwidth

Realtime Application (R&S FSW-K160R) > Realtime Basics > Defining the Resolution Bandwidth
Defining the Resolution Bandwidth

The resolution bandwidth has an effect on how the spectrum is measured and displayed. It determines the frequency resolution of the measured spectrum and is directly coupled to the span of the R&S FSW. If you increase the span, the resolution bandwidth is also increased, and vice versa. The R&S FSW provides several coupling ratios, depending on the selected FFT window.

A small resolution bandwidth has several advantages. The smaller the resolution bandwidth, the better you can observe signals whose frequencies are close together and the less noise is displayed. However, a small resolution bandwidth also increases the time required to ensure that all possible signal distortions are detected and the level is measured accurately. This requirement is also referred to as 100% probability of intercept (POI). The R&S FSW has resolution bandwidths from 160 mHz to 51.2 MHz, depending on the span and FFT window.

The resolution bandwidth parameters can be defined in the bandwidth configuration, see "Bandwidth and Sweep Settings".


Sweep Time and Detector

Realtime Application (R&S FSW-K160R) > Realtime Basics > Sweep Time and Detector
Sweep Time and Detector

The "Sweep Time" parameter determines the amount of time used to sample data for one spectrum. One spectrum is defined by a number of FFTs calculated from the sampled data. In conventional spectrum analysis, the sweep time parameter describes the amount of time needed to sweep over the selected frequency range. As the effect is the same, i.e. it takes the sweep time to complete one spectrum, the realtime parameter is also called sweep time.

Combining several FFTs into one spectrum during the selected sweep time offers several possibilities of weighting the FFT results: determining the maximum level is an obvious one. Other possibilities of combining several FFTs are selecting the minimum for each frequency point, determining the average result, or selecting an arbitrary FFT result to represent the entire sweeptime. The combination of FFTs is done by detectors; a detector is available for each of the mentioned methods: Positive Peak, Negative Peak, Average, and Sample. Positive Peak is the default selection to make sure that even the shortest events can be analyzed.

Thus, the detector and sweep time parameters describe the data reduction from multiple FFTs to a single spectrum. A detector is not required for the "Persistence Spectrogram" display, which evaluates the individual FFTs (see "Understanding Persistence").


Triggering Realtime Measurements

Realtime Application (R&S FSW-K160R) > Realtime Basics > Triggering Realtime Measurements
Triggering Realtime Measurements

Realtime measurements pose some specific challenges to triggering, which require special trigger functions and options.

Contents
  • Frequency Mask Trigger
  • Using Pretrigger and Posttrigger Settings
  • Rearming the Trigger and Stopping on Trigger


Frequency Mask Trigger

Realtime Application (R&S FSW-K160R) > Realtime Basics > Triggering Realtime Measurements > Frequency Mask Trigger
Frequency Mask Trigger

One way to analyze rare events in a given frequency range is to capture realtime data over a very long time. This method requires large amounts of fast memory. As a consequence, post-processing the bulk of stored data to find the event may be extremely time consuming.

Another way is to trigger on the event in the frequency spectrum and to acquire exactly the data of interest. This method reduces the necessary memory size dramatically, and in addition keeps the time to spot the event of interest in the acquired memory low. The question is: how can the analyzer trigger on events which show up in a certain frequency range only now and then?

Detecting rare events

The answer is the Frequency Mask Trigger. Speaking graphically, the frequency mask trigger is a mask in the frequency domain, which is checked with every calculated FFT. This allows for a 100% probability of intercept with full level accuracy down to 1.87 μs. The minimum detectable signal duration is 5 μs.

Mask definition

The frequency mask is configured by a list of individual trace points, defined as position/value pairs, which are connected to form a mask area. The individual mask points can also be defined simply by dragging the points to the required position on the touchscreen. The frequency mask can consist of up to 1001 points and may have any shape.

Frequency mask defined manually

Alternatively, a mask can be defined automatically according to the currently measured data. In this case, the mask is configured to follow the measurement trace with a specific distance to the power levels.

Frequency mask defined automatically according to measured data
Upper and lower masks

By default, the defined mask is an upper mask, i.e. the mask is the area above the defined mask points. In addition or alternatively, a mask can be defined as a lower mask. In this case, the mask is the area below the definded mask points. This is useful, for example, to determine if the measured signal leaves a defined "corridor" of allowed values.

The lower limit mask is defined in the same manner as the upper limit mask. However, it must be activated explicitely and cannot be configured automatically according to the currently measured values.

Trigger conditions

The frequency mask can be evaluated in different ways to control data acquisition, depending on whether the mask area represents the desired or undesired value range.

Trigger condition "entering": Data acquisition starts when the signal enters the mask area and continues until the measurement is stopped or completed
Trigger condition "leaving": Data acquisition starts when the signal leaves the mask area and continues until the measurement is stopped or completed

The selected trigger condition applies to any active limits; that means the calculated FFTs are compared to the upper or lower, or both the upper and lower limits, if activated.

Availability

The frequency mask trigger can be selected as a trigger source for all measurements in realtime operation. As it is evaluated in parallel to the selected result displays, there is no influence on the realtime capabilities of the R&S FSW.

A detailed description of how to define a frequency mask trigger is provided in "How to Work with Frequency Mask Triggers".

Storing and loading frequency masks

As frequency masks can have a very complex structure, they can be stored for later use with other signals. The masks are stored in a file with the extension .FMT in the freqmask subdirectory of the R&S FSW installation directory. By default, the mask name is used as the file name; however, it can be edited.

Trigger output

The frequency mask trigger is a trigger source which exceeds the capabilities of standard spectrum analyzers. To allow other instruments in a test system to make use of it, R&S FSW provides a special connector (TRIGGER OUT). This trigger pulse may be provided to a system setup as an external trigger source.

For details on the TRIGGER OUT connector see "How to Output a Trigger Signal" .

Contents
  • Technical process


Technical process

Realtime Application (R&S FSW-K160R) > Realtime Basics > Triggering Realtime Measurements > Frequency Mask Trigger > Technical process
Technical process

Basically the frequency mask trigger is an extended limit line check: the frequency mask is compared to every FFT spectrum calculated by the realtime hardware.

The R&S FSW performs this mask check up to 600,000 times per second according to the FFT update rate. To ensure a realtime trigger, i.e. a given reaction time, the frequency mask trigger is evaluated by the realtime hardware.

figure "Element-wise comparison of frequency mask with current FFT result" shows the element-wise comparison of a realtime FFT with a frequency mask. The FFT-result is subtracted from the frequency mask value. If one result is negative, the R&S FSW triggers.

Element-wise comparison of frequency mask with current FFT result

Extended limit check means that the frequency mask trigger can link a complex condition to the limit line violation, such as entering or leaving the mask.

As already mentioned, the frequency mask may contain up to 1001 points, but may also be as short as 2 points. Shorter frequency mask trigger definitions are extended to 1001 points by interpolation within the firmware. The frequency mask trigger therefore always compares 1001 FFT points to 1001 frequency mask definition points. If the mask is violated at a single point, the frequency mask trigger will trigger.

In order to get a reliable frequency mask trigger with very short events, it is preferable to set the mask limit levels lower than the expected spectral power levels.


Using Pretrigger and Posttrigger Settings

Realtime Application (R&S FSW-K160R) > Realtime Basics > Triggering Realtime Measurements > Using Pretrigger and Posttrigger Settings
Using Pretrigger and Posttrigger Settings

As described in "Sweep Time and Detector", the amount of time required to sample data for one spectrum (or one frame in a spectrogram) corrresponds to the defined sweep time. If a trigger is used for the measurement, the displayed spectrum starts with the trigger event. However, you can define a pre-trigger and post-trigger period in which data is also captured, in addition to the actual sweep time. (As the posttrigger time starts with the trigger event, it only has an effect if it is longer than the sweep time.) This allows you to analyze the data shortly before the actual trigger event or after the regular sweep period.

The data from this "extended" sweep time (pretrigger+posttrigger) is displayed in realtime spectrograms or PVT waterfalls (see also "Working with Spectrograms and Waterfall Diagrams").

By default, the frame displayed in the Realtime Spectrum and PVT results is the frame that begins with the trigger event. If a pretrigger time is defined, one or more additional frames will be available in the spectrogram/waterfall beneath the frame currently displayed in the Realtime Spectrum or PVT diagram window, respectively. If a posttrigger time is defined, one or more additional frames will be available in the spectrogram/waterfall above the frame currently displayed in the Realtime Spectrum or PVT diagram window, respectively.

Pretrigger, currently displayed, and posttrigger frames


Rearming the Trigger and Stopping on Trigger

Realtime Application (R&S FSW-K160R) > Realtime Basics > Triggering Realtime Measurements > Rearming the Trigger and Stopping on Trigger
Rearming the Trigger and Stopping on Trigger

By default, a trigger event causes the R&S FSW to start a measurement and to immediately rearm the trigger ("Auto Rearm"). In that case, measurements are continuously triggered and measurement results may become obsolete in a very short time. The pre- and posttrigger periods for each sweep time are displayed.

However, you may be interested in the results after the first trigger event only. For this case, a "Stop on Trigger" option is provided. If active, the trigger is not rearmed after the first trigger event has occured; thus, the measurement stops after one sweep. The measurement results for that sweep remain on the display, including the pretrigger and posttrigger periods. Note, however, that if the trigger event occurs before the defined pretrigger time has elapsed, the period between measurement start and the trigger event is shorter than the defined pretrigger time.


Working with Spectrograms and Waterfall Diagrams

Realtime Application (R&S FSW-K160R) > Realtime Basics > Working with Spectrograms and Waterfall Diagrams
Working with Spectrograms and Waterfall Diagrams

In realtime measurements, data is captured seamlessly over a specified time. The most recently measured power levels vs frequency can then be displayed in the Realtime Spectrum, while the most recently measured power vs time values can be displayed in a PVT diagram. In these displays, the results from previous measurements are not included.

However, since the R&S FSW stores the history of the measured data in its memory, the spectrogram display provides a record of the measured spectrum without gaps. You can then analyze the data in detail at a later time by recalling one of the spectrums in the spectrogram history.

The PVT waterfall is basically the same as a spectrogram, but in the time domain. In this diagram, a history of the power vs time levels measured over time is displayed. A particular PVT diagram can then be selected and displayed for detailed analysis.

Contents
  • Time Frames
  • Markers in the Spectrogram
  • Color Maps
  • Zooming into the Spectrogram


Time Frames

Realtime Application (R&S FSW-K160R) > Realtime Basics > Working with Spectrograms and Waterfall Diagrams > Time Frames
Time Frames

The time information in the spectrogram/PVT waterfall is displayed vertically, along the y-axis. Each line (or trace) of the y-axis represents the data during one sweeptime interval and is called a time frame or simply "frame". For spectrograms, as with standard spectrum traces, several measured values are combined in one sweep point using the selected detector (see "Sweep Time and Detector").

Frames are sorted in chronological order, beginning with the most recently recorded frame at the top of the diagram (frame number 0). With the next sweep, the previous frame is moved further down in the diagram, until the maximum number of captured frames is reached. The display is updated continuously during the measurement, and the measured trace data is stored. Spectrogram and PVT waterfall displays are continued even after single sweep measurements unless they are cleared manually.

The maximum number of stored frames is defined by the history depth, which is user-configurable.

Displaying individual frames

In "Sweep Time and Detector", the term "frame" was introduced as one spectrum containing a number of FFTs. Thus, one trace in the spectrogram corresponds to one spectrum in the Realtime Spectrum view. Similarly, one trace in the PVT waterfall corresponds to one PVT trace.

The spectrogram/PVT waterfall diagram includes all stored frames since it was last cleared. Arrows on the left and right border of the spectrogram/PVT waterfall indicate the currently selected frame. The spectrum (or PVT) diagram always displays the spectrum (or PVT) for the currently selected frame. The current frame number (or alternatively a time stamp, if activated) is indicated in the diagram footer of the spectrogram/PVT waterfall. The most recent frame, displayed at the top of the diagram, is frame number 0. Older frames further down in the diagram are indicated by a negative index, e.g."-10". You can display the spectrum (or PVT) diagram of a previous frame by selecting a different frame number.

Separate frame numbers can be selected for the Spectrum or PVT diagrams.

Displaying pretrigger and posttrigger results

By default, the frame displayed in the Realtime Spectrum and PVT results is the frame that begins with the trigger event. In order to display pretrigger results, if available, select a frame in the spectrogram/waterfall beneath the currently selected frame. In order to display posttrigger results (after the (PVT) sweep time), if available, select a frame in the spectrogram/waterfall above the currently selected frame.

Time stamps vs index

By default, the time information of the selected frame is provided as a time stamp in the footer of the spectrogram/PVT waterfall. The time stamp shows the time and date the selected frame was recorded. The length of one frame corresponds to the sweep time. To select a specific frame, you have to enter the (negative) time in seconds, relative to the frame that was recorded last. The largest (absolute) time available is the sweep time multiplied with the number of sweeps performed since the diagram was last cleared.

Alternatively to time stamps, the time information can be provided as an index. The index is also relative to the frame that was recorded last, which has the index number 0. The lowest index is a negative number that corresponds to the history depth. To select a specific frame, you have to enter the (negative) index number of the frame you want to analyze.


Markers in the Spectrogram

Realtime Application (R&S FSW-K160R) > Realtime Basics > Working with Spectrograms and Waterfall Diagrams > Markers in the Spectrogram
Markers in the Spectrogram

Markers and delta markers are shaped like diamonds in the spectrogram. They are only displayed in the spectrogram if the marker position is inside the visible area of the spectrogram. If more than two markers are active, the marker values are displayed in a separate marker table.

In the spectrum result display, the markers and their frequency and level values (1) are displayed as usual. Additionally, the frame number is displayed to indicate the position of the marker in time (2).

In the spectrogram result display, you can activate up to 16 markers or delta markers at the same time. Each marker can be assigned to a different frame. Therefore, in addition to the frequency you also define the frame number when activating a new marker. If no frame number is specified, the marker is positioned on the currently selected frame. All markers are visible that are positioned on a visible frame. Special search functions are provided for spectrogram markers.

In the spectrum result display, only the markers positioned on the currently selected frame are visible. In "Continuous Sweep" mode this means that only markers positioned on frame 0 are visible. To view markers that are positioned on a frame other than frame 0 in the spectrum result display, you must stop the measurement and select the corresponding frame.


Color Maps

Realtime Application (R&S FSW-K160R) > Realtime Basics > Working with Spectrograms and Waterfall Diagrams > Color Maps
Color Maps

Spectrograms and PVT waterfall displays assign power levels to different colors in order to visualize them. The legend above the spectrogram/PVT waterfall display describes the power levels the colors represent. Similarly, Persistence Spectrum displays assign colors to the relative numbers of occurrance (percentage) of specific power levels.

The color display is highly configurable to adapt the display to your needs. You can define:

  • Which colors to use (Color scheme)
  • Which value range to apply the color scheme to
  • How the colors are distributed within the value range, i.e where the focus of the visualization lies (shape of the color curve)

The individual colors are assigned to the power levels automatically by the R&S FSW.

The Color Scheme

You can select which colors are assigned to the measured values. Four different color ranges or "schemes" are available:

  • Hot

    Uses a color range from blue to red. Blue colors indicate low levels, red colors indicate high ones.
  • Cold

    Uses a color range from red to blue. Red colors indicate low levels, blue colors indicate high ones.
    The "Cold" color scheme is the inverse "Hot" color scheme.
  • Radar

    Uses a color range from black over green to light turquoise with shades of green in between. Dark colors indicate low levels, light colors indicate high ones.
  • Grayscale

    Shows the results in shades of gray. Dark gray indicates low levels, light gray indicates high ones.
The Value Range of the Color Map

If the measured values only cover a small area in the diagram, you can optimize the displayed value range so it becomes easier to distinguish between values that are close together, and only parts of interest are displayed at all.

The Shape and Focus of the Color Curve

The color mapping function assigns a specified color to a specified power level in the display. By default, colors on the color map are distributed evenly. However, if a certain area of the value range is to be visualized in greater detail than the rest, you can set the focus of the color mapping to that area. Changing the focus is performed by changing the shape of the color curve.

The color curve is a tool to shift the focus of the color distribution on the color map. By default, the color curve is linear. If you shift the curve to the left or right, the distribution becomes non-linear. The slope of the color curve increases or decreases. One end of the color palette then covers a large amount of results, while the other end distributes several colors over a relatively small result range.

You can use this feature to put the focus on a particular region in the diagram and to be able to detect small variations of the signal.

Example:
Linear color curve shape = 0; colors are distributed evenly over the complete result range

In the color map based on the linear color curve, the range from -105.5 dBm to -60 dBm is covered by blue and a few shades of green only. The range from -60 dBm to -20 dBm is covered by red, yellow and a few shades of green.

Spectrogram with default color curve

The sample spectrogram is dominated by blue and green colors. After shifting the color curve to the left (negative value), more colors cover the range from -105.5 dBm to -60 dBm (blue, green and yellow), which occurs more often in the example. The range from -60 dBm to -20 dBm, on the other hand, is dominated by various shades of red only.

Non-linear color curve shape = -0.5
Spectrogram with shifted color curve


Zooming into the Spectrogram

Realtime Application (R&S FSW-K160R) > Realtime Basics > Working with Spectrograms and Waterfall Diagrams > Zooming into the Spectrogram
Zooming into the Spectrogram

For further and more detailed analysis of the data you have captured, a zoom function is provided for realtime spectrogram diagrams.

The graphical zoom provided for other measurements on the R&S FSW is not available for realtime measurements.

For realtime measurements, the zoom is available only for the spectrogram result display, but it has effects on other result displays. The zoom is only available if a spectrogram is active and selected (blue border).

The zoom is activated using the Single Zoom ( [image]) icon in the toolbar. You define the zoom area by drawing a rectangle on the touchscreen. When you draw the zoom area, its boundaires are shown as a dashed line. The R&S FSW stops the realtime measurement and recalculates the displays for the area you have selected. The definition of the color map remains the same.

When a zoom is activated in the spectrogram, the sweep time and/or resolution bandwidth and span are temporarily reduced, and the selected data that was measured previously and stored in the R&S FSW memory is reprocessed and reevaluated. This improves the resolution of the data (while a graphical zoom merely interpolates the data and thus reduces the resolution).

Zoomed spectrogram display due to reduced sweep time and span

Because the zoom is based on data that has already been captured, the zoom also allows for faster sweep times (and thus spans) than those possible during live measurements.

Inside the zoom area, you can use the common spectrogram functionality (such as selecting a frame or scrolling through the spectrogram). An additional function ("Replay zoom") allows you to switch between the zoomed display and the original display quickly for comparison.

Zoom restrictions

Principally, the zoom is available for all measurement situations, whether you measure continuously, in single sweep mode or use a trigger. However, possible zoom areas are restricted by the size of the memory. If it is not possible to zoom into a spectrogram area, the R&S FSW colors that area in a darker color when you touch it.

The zoom factor is restricted to 10% of the original span of the frequency axis.

In addition, the zoom is also restricted by the originally defined bandwidth or span. Zooming into areas that are outside this bandwidth is not possible.

Note also that zoom availability depends on the trigger mode. Zooming while the measurement is running is possible only in "Free Run" mode. For all other trigger modes, you have to wait until the measurement is paused.

Effects on other result displays

Zooming also has an effect on the Realtime Spectrum and the power vs time result displays. All other result displays are unaffected.

  • The R&S FSW updates the frequency range of the Realtime Spectrum according to the zoomed (new) spectrogram span. The range has an effect on the start, stop and center frequency as well as the span.
    The Realtime Spectrum still shows the spectrum of the currently selected spectrogram frame.
  • The R&S FSW updates the time range of the power vs time result display according to the new height (sweep time) of the spectrogram.
    Note that it is not possible to change the sweep time or the trigger offset for the power vs time diagram while the zoom is active.

Updates in the result displays only take effect if they are active when the spectrogram data is being recalculated.


Understanding Persistence

Realtime Application (R&S FSW-K160R) > Realtime Basics > Understanding Persistence
Understanding Persistence

Persistence describes the duration that past histogram traces remain visible in the display before fading away.

Historical term

The term persistence has its origins in cathode ray tube devices (CRTs). It describes the time period one point on the display stays illuminated after it has been lit by the cathode ray. The higher the persistence, the longer you could observe the illuminated point on the display.

Moving density

In the Persistence Spectrum result display, the persistence results from the moving 'density' (like a moving average) over a certain number of traces. The number of traces that are considered to calculate the density depends on the user-definable persistence duration. The longer the persistence, the more traces are part of the calculation and the deeper the history of displayed information gets. A spectral event that has occured a single time is visible for up to 8 seconds. As densities get smaller at coordinates with signal parts that are not constantly there, the trace color changes. The rate of the color change is high with a low persistence and small with a high persistence.

Detecting changes over time

Note that a signal with constant frequency and level characteristics does not show the effects of persistence on the trace. As soon as the power or frequency of a signal change slightly, however, the effect of persistence becomes visible through color changes or changes in the shape of the trace.

You can remove persistence by setting its duration to 0 seconds.

Persistence Granularity

The amount of data that the R&S FSW uses to draw a single frame in the persistence spectrum is variable. By default, the data that was captured in 100 ms is used to calculate a frame. The time period in which data is captured and the mentioned density is calculated is referred to as the persistence granularity. The higher the granulation, i.e. the longer the data capturing time, the more data is included in each calculation.

A single histogram frame is calculated during the persistence granularity time. An initially empty matrix with 600 by 1001 elements, representing 600 discrete power levels and 1001 discrete frequency steps, is provided at the beginning of each histogram frame. After each newly calculated FFT, the matrix is updated according to the occurance of each frequency/level pair. Every time the persistence granularity interval is completed, the matrix is reset to zero for each element and a new histogram frame is started.

Example: Calculating an individual persistence frame

figure "Schematic illustration of histogram calculation (dot style)" demonstrates this process with a 6 by 8 elements matrix and a ratio of 2 for FFT time to granularity. Thus, two FFTs are calculated for each frame. Both FFTs contain the same signal and varying noise neighboring the signal. The FFTs are converted into a matrix of frequency/level pairs. The two matrices are summed up into the result matrix. The result matrix determines the color of the result trace in the histogram. In this example, red corresponds to a high count or probability, whereas the noise band is displayed in blue for a lower probability.

Schematic illustration of histogram calculation (dot style)
Persistence Spectrum and detectors

The Persistence Spectrum display calculates persistence and histogram information directly from the FFT results. There is no need to use detectors for data reduction as in the spectrogram, since the histogram algorithm already reduces data to a rate that can easily be displayed. For persistence spectrum results, the detector setting affects only the MaxHold trace that can be plotted on top of the persistence spectrum (see "Analyzing Maximum Density - Maxhold Trace").

Trace style

The individual traces in the persistence spectrum can be displayed using vectors or dots.

The FFT matrices in figure "Schematic illustration of histogram calculation (dot style)" contain only a single value per frequency column. This is the level value returned by the FFT. The example shows a trace in dot style, i.e. the matrices are filled with dots only.

In contrast, for vector style traces, each element in the matrix with the value "1" is analyzed; if the neighboring frequency also has the value 1, regardless at which power level, the two frequency points are connected by additional (interpolated) value 1 elements.

Dotted trace style vs Vector trace style
Example: Histogram matrices for vector style traces

figure "Histogram calculation using vector style" shows the vector style representation for exactly the same example that was used in figure "Schematic illustration of histogram calculation (dot style)" for dot style. To derive the vector style matrices from the dot-style matrices, additional "1" elements are inserted to connect the "1" in column 4 to the neighboring "1" in columns 3 and 5.

Histogram calculation using vector style

The additional "1" elements result in increased probability levels when changing from dot to vector mode. The increase is especially visible in areas with noise like signals, i.e. large level fluctuations.

Color mapping for different trace styles

Color mapping for the persistence spectrum is identical to color mapping for the spectrogram or waterfall diagrams. The truncating function is especially useful to display only spectral components of a certain probability (see "Truncate").

A new color mapping is usually necessary after changing the persistence style from vector to dot or vice versa, as the resulting probabilities may vary largely as explained above.

For details on color mapping see "Color Maps".

Truncating the persistence spectrum

By default, results outside the defined value range of the color map are displayed in the colors for the minimum or maximum values in the range.

Default persistence spectrum coloring without truncating

However, a truncate function allows the results of the persistence spectrum outside the value range of the color map to be truncated, that is, not displayed.

Persistence spectrum with truncated coloring
Contents
  • Analyzing Maximum Density - Maxhold Trace


Analyzing Maximum Density - Maxhold Trace

Realtime Application (R&S FSW-K160R) > Realtime Basics > Understanding Persistence > Analyzing Maximum Density - Maxhold Trace
Analyzing Maximum Density - Maxhold Trace

During analysis of a time varying signal, level variations are usually of great interest; in particular, the ratio between the current signal and the maximum measured signal. A special MaxHold trace remembers and shows the maximum densities that have been measured at each point in the diagram. It allows for a worst case estimation of signal-to-noise-ratios (SNR), when talking about noise or interferers. For useful signals, it allows an estimation of amplitude variation. The Persistence Spectrum display can display a MaxHold trace on top of the persistence spectrum. As mentioned above, the persistence traces fade in intensity over time. The MaxHold trace, on the other hand, is assigned a time-independent intensity value to allow you to distinguish the MaxHold trace and the persistence spectrum.

Changing the color intensity

In its default state, the maxhold trace is displayed. You can turn it off expicitely or by reducing the color intensity to 0. You can regulate the brightness of the trace up to the point where it is as intense as the current trace. The default value of 100 is a good choice for standard applications. The maximum value of 255 corresponds to the intensity of the current histogram trace. A MaxHold trace is cleared automatically after each new setting, and it can be reset manually by the user.


Multi-Standard Realtime Analysis

Realtime Application (R&S FSW-K160R) > Realtime Basics > Multi-Standard Realtime Analysis
Multi-Standard Realtime Analysis
Application data

The Multi-Standard Realtime (MSRT) mode combines the advantages of the MSRA mode with its correlated measurements and the gapless results provided by realtime measurements. In this operating mode, data acquisition is performed once as a realtime measurement, and the captured data is then evaluated by any number of applications.

As in MSRA mode, the applications receive data for analysis from the capture buffer, if necessary resampled or with filters applied. The applications can define their own center frequency, sample rate and record length for their application data, which is an extract of the capture buffer data. The applications may not request more sample points than the captured data contains, or samples from a frequency outside the range of the capture buffer, for example.

As opposed to MSRA mode, however, data capturing is not restricted to the sweep time. Rather, as with all realtime measurements, a pretrigger time and posttrigger time are defined, during which data is captured. This data is then available for all MSRT applications.

Obviously, it is of interest to know which application, or more precisely: which data channel is analyzing which part of the captured data and how each data channel is correlated (in time) to others. The MSRT Master display indicates the data covered by each application by vertical blue lines labeled with the application name.

MSRT Master indicating covered bandwidth for 2 applications
Analysis interval

Each application receives an extract of the data from the capture buffer. However, the individual evaluation methods of the application need not analyze the complete data range. Some applications allow you to select a specific part of the data for analysis, e.g. an individual pulse, or to use an offline trigger that defines an additional offset to the capture offset. The data range that is actually analyzed is referred to as the analysis interval.

The analysis interval is indicated in the window title bar for each evaluation, and can be queried via remote control.

For applications that do not allow you to restrict the evaluation range (e.g. I/Q Analyzer, Analog Demodulation), the analysis interval is identical to the application data extract.

Trigger offset vs. capture offset

The beginning of the capture buffer is defined by the trigger event and the trigger offset. The trigger source is defined by the MSRA Master, which means that all channels use the same trigger. However, each application might need a different trigger offset or a different number of pretrigger samples. Instead of a trigger offset, the applications define a capture offset. The capture offset is defined as an offset to the beginning of the capture buffer.

Thus, the beginning of the application data extract is calculated as:

[time of trigger event] + [trigger offset] + [capture offset]

Note that in MSRT mode the trigger offset value may be negative (thus starting before the trigger event), as well as the capture offset. A negative capture offset means the application data starts in the pretrigger time. The capture offset in the MSRT applications must be configured such that the resulting data range lies within the MSRT Master's pretrigger+posttrigger time.

Trigger offset vs. capture offset
Analysis line

As in MSRA mode, an analysis line is provided as a common time marker for all MSRT applications. It can be positioned in any MSRT application or the MSRT Master and is then adjusted in all other applications. Thus, you can easily analyze the results at a specific time in the measurement in all applications and determine correlations.

If the marked point in time is contained in the analysis interval of the application, the line is indicated in all time-based result displays, such as time, symbol, or bit diagrams. By default, the analysis line is displayed, however, it can be hidden from view manually. In all result displays, the "AL" label in the window title bar indicates whether the analysis line lies within the analysis interval or not:

Analysis line in MSRT application
  • orange "AL": the line lies within the interval
  • white "AL": the line lies within the interval, but is not displayed (hidden)
  • no "AL": the line lies outside the interval
Contents
  • Configuration
  • Data Acquisition
  • Using the Sequencer in MSRT Mode
  • Restrictions for Applications


Configuration

Realtime Application (R&S FSW-K160R) > Realtime Basics > Multi-Standard Realtime Analysis > Configuration
Configuration
Master parameters

In MSRT mode, only the MSRT Master performs a data acquisition. Thus, all parameters that determine how the data is captured from the RF input can only be configured in the MSRT Master tab. In all application tabs, these settings are deactivated (or have a different meaning).

Typical master parameters include:
  • RBW and sweep time
  • Trigger settings
  • Center frequency
  • Reference level
  • External reference
  • Impedance, preamplification, attenuation
Channel-specific parameters

Each application, however, can define all parameters concerning analysis individually.

Typical channel-specific parameters include:
  • Center frequency, span and number of trace points for the application data extract
  • Offset of the application data extract from the trigger event
  • Evaluation methods
  • Range and scaling
  • Trace mode
  • Marker positions
Conflicting parameters

Master and channel-specific parameters can be configured independently of one another, in any order that is convenient to you. However, there are dependencies between the parameters, as the applications can only evaluate data that has been captured by the MSRT Master previously. Thus, configuring parameters is not restricted, but you are informed about the violation of possible restrictions by error messages in the status bar of the applications where necessary.


Data Acquisition

Realtime Application (R&S FSW-K160R) > Realtime Basics > Multi-Standard Realtime Analysis > Data Acquisition
Data Acquisition

As mentioned before, only the MSRT Master performs a data acquisition. Thus, the MSRT Master defines the center frequency, RBW and sweep time of the captured I/Q data. It also defines the trigger event, thus all applications have the same trigger. However, an offset from the trigger can be defined by the individual applications (see "Trigger offset vs. capture offset").

Performing sweeps

When you switch to MSRT mode, the Sequencer is automatically activated in continuous mode (see "Using the Sequencer in MSRT Mode").

Alternatively, you can perform measurements manually. You can start a single or continuous sweep from any application, which updates the data in the capture buffer and the results in the current application. The results in the other applications, however, remain unchanged. You must refresh them manually, either individually or all at once, using a "Refresh" function.

Note that in continuous sweep mode, sweeping is aborted when you switch to a different application. You can then continue sweeping from there. This is necessary in order to evaluate the same data in different applications without overwriting the data in the capture buffer.

In single sweep mode, only one sweep is performed; a sweep count is not available - neither for the MSRT Master, nor for the applications. However, depending on the application, a statistics count may be available for statistics based on a single data acquisition. Trace averaging is performed as usual for sweep count = 0, the current trace is averaged with the previously stored averaged trace.

Data availability

The applications can only receive data that is available in the capture buffer. As soon as data has been stored to the capture buffer successfully, a status bit (#9) in the STAT:OPER register is set. If the required application data is not available, an error message is displayed. Details on restrictions are described in "Restrictions for Applications".


Using the Sequencer in MSRT Mode

Realtime Application (R&S FSW-K160R) > Realtime Basics > Multi-Standard Realtime Analysis > Using the Sequencer in MSRT Mode
Using the Sequencer in MSRT Mode

When you switch to MSRT mode, the Sequencer is automatically activated in continuous mode. Unless it is stopped or you select a different Sequencer mode, the MSRT Master will continuously capture data. Evaluation in the applications only starts after a completed sweep. Since the default trigger setting is "Free Run", the sweep continues indefinately, so that no evaluation takes place. Thus, the Sequencer behaviour depends strongly on the trigger settings in MSRT mode.

For details on realtime trigger settings see "Trigger Configuration".

Sequencer modes and trigger settings in MSRT operating mode
Sequencer mode | Trigger setting | Measurement behavior
Single sequence | No trigger (Free run) | Master performs a single sweep ( 1 frame); applications perform single evaluation
 | Trigger + "Auto Rearm" | After trigger, master performs single sweep, subsequently applications perform single evaluation; trigger is rearmed
 | Trigger + "Stop on trigger" | After trigger, master performs single sweep; subsequently applications perform single evaluation; trigger is not rearmed
Continuous sequence | No trigger (Free run) | Master performs continuous sweep; applications do not perform any evaluation
 | Trigger + "Auto Rearm" | After trigger, master performs single sweep; subsequently applications perform single evaluation; trigger is rearmed; sequence is repeated with next trigger
 | Trigger + "Stop on trigger" | Master performs continuous sweep until trigger occurs; subsequently applications perform single evaluation; trigger is not rearmed
Deactivated Sequencer
If the Sequencer is deactivated, note the following behavior in the MSRT mode:
  • If continuous sweep is active (default) and you switch to a different application, continuous sweep is aborted. This is necessary in order to evaluate the same data in different applications without overwriting the data in the capture buffer. Continuous sweep can be started again as usual.
  • Only the application that is currently displayed when a measurement is performed is updated automatically. A "Refresh" function is available to update the display in one or all other applications (see "Performing a Measurement in MSRT Mode").

For details on the Sequencer function see "Running a Sequence of Measurements" .


Restrictions for Applications

Realtime Application (R&S FSW-K160R) > Realtime Basics > Multi-Standard Realtime Analysis > Restrictions for Applications
Restrictions for Applications

As mentioned in various contexts before, the MSRT applications themselves are identical to Signal and Spectrum operating mode; however, the correlation between applications and the MSRT Master require some restrictions. Principally, you are not restricted in setting parameters. However, if any contradictions occur between the configured capture settings and the analysis settings, error messages are displayed in the status bar of the application and an icon ( [image]) is displayed next to the channel label. However, it does not matter in which order you configure the settings - you will not be prevented from doing so.

In particular, the following restrictions apply to applications in MSRT mode:

  • Data acquisition: parameters related to data acquisition can only be configured by the MSRT Master
  • Application data: only data contained in the capture buffer can be analyzed by the application; this implies the following restrictions:
    – Center frequency: must lie within the captured data bandwidth
    – Measurement time/Record length: must be smaller than or equal to the captured data (pretrigger+posttrigger time) from the MSRT Master
    – Capture offset: must be smaller than pretrigger and posttrigger time of the MSRT Master
    – Trace averaging: only for sweep count = 0
  • AUTO SET functions: in applications, only the frequency can be adjusted automatically; all other adjustment functions require a new data acquisition

General restrictions concerning sample rates and maximum usable I/Q bandwidths for I/Q data also apply in MSRT mode; see the R&S FSW I/Q Analyzer User Manual for details.


Configuring the Realtime Spectrum Application

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application
Configuring the Realtime Spectrum Application

Realtime measurements on standard RF input require a special application on the R&S FSW, which you activate using the MODE key on the front panel.

(For details see "Starting the Realtime Spectrum Application".)

When you switch a measurement channel to the Realtime Spectrum application the first time, a set of parameters is passed on from the currently active application (see "Default Settings for Realtime Spectrum Measurements"). After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

When you activate a measurement channel in the Realtime Spectrum application, a Realtime Spectrum measurement for the input signal is started automatically with the default configuration. The "Realtime Config" menu is displayed and provides access to the most important configuration functions.

For a description see
  • "Replay Zoom"
  • "Persistence Spectrum Settings"
  • "Spectrogram and PVT Waterfall Settings"
  • "Color Map Settings"
  • "Frequency Mask Trigger Configuration"
  • "Display Configuration"
Automatic refresh of preview and visualization in dialog boxes after configuration changes

The R&S FSW supports you in finding the correct measurement settings quickly and easily - after each change in settings in dialog boxes, the preview and visualization areas are updated immediately and automatically to reflect the changes. Thus, you can see if the setting is appropriate before closing the dialog box.

Contents
  • Default Settings for Realtime Spectrum Measurements
  • Configuration Overview
  • Input Source Settings
  • Frequency and Span Settings
  • Amplitude Settings
  • Scaling the Y-Axis
  • Trigger Configuration
  • Bandwidth and Sweep Settings
  • Output Settings
  • Adjusting Settings Automatically


Default Settings for Realtime Spectrum Measurements

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Default Settings for Realtime Spectrum Measurements
Default Settings for Realtime Spectrum Measurements

When you switch a measurement channel to the Realtime Spectrum application the first time, a set of parameters is passed on from the currently active application:

  • center frequency and frequency offset
  • reference level and reference level offset
  • attenuation
  • input coupling
  • YIG filter state

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

Apart from these settings, the following default settings are activated directly after a measurement channel has been set to the Realtime Spectrum application, or after a "Preset Channel":

Default settings for Realtime Spectrum channels
Parameter | Setting
input | RF
reference level | 0 dBm
RF attenuation | 10 dB
preamplifier | off
center frequency | fmax/2
frequency offset | 0.0 Hz
span | 160 MHz
RBW | 500 kHz
sweep mode | continuous
sweep time | 30.0 ms (auto)
PVT sweep time | 12.8 ms
span/RBW | 3200
FFT window | Blackman
trigger | free run
trace 1 | clr write
trace 2/3/4/5/6 | blank
detector | positive peak
limits | off
measurement type | High Resolution
evaluation | window 1: Realtime Spectrum window 2: Spectrogram (not MSRT Master)


Configuration Overview

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Configuration Overview
Configuration Overview

Throughout the measurement channel configuration, an overview of the most important currently defined settings is provided in the "Overview". The "Overview" is displayed when you select the "Overview" icon, which is available at the bottom of all softkey menus.

In addition to the main measurement settings, the "Overview" provides quick access to the main settings dialog boxes. The individual configuration steps are displayed in the order of the data flow. Thus, you can easily configure an entire measurement channel from input over processing to output and analysis by stepping through the dialog boxes as indicated in the "Overview".

In particular, the "Overview" provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

  1. "Select Measurement"

    See "Select Measurement"

  2. Input

    See "Input Source Settings"

  3. Amplitude

    See "Amplitude Settings"

  4. Frequency

    See "Frequency and Span Settings"

  5. (Optionally:) Trigger

    See "Trigger Configuration"

  6. Bandwidth

    See "Bandwidth and Sweep Settings"

  7. (Optionally:) Outputs

    See "Output Settings"

  8. Analysis

    See "Analysis"

  9. Display Configuration

    See "Display Configuration"

To configure settings
►

Select any button in the "Overview" to open the corresponding dialog box.

Select a setting in the channel bar (at the top of the measurement channel tab) to change a specific setting.

For step-by-step instructions on configuring Realtime Spectrum measurements, see "How to Perform Realtime Measurements".

└ Preset Channel
└ Select Measurement
└ Specifics for


Preset Channel

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Configuration Overview > Preset Channel
Preset Channel

Select the "Preset Channel" button in the lower lefthand corner of the "Overview" to restore all measurement settings in the current channel to their default values.

Note that the PRESET key on the front panel restores the entire instrument to its default values and thus closes all measurement channels on the R&S FSW (except for the default Spectrum application channel)!

See "Default Settings for Realtime Spectrum Measurements" for details.

Remote command:

SYSTem:​PRESet:​CHANnel[:​EXECute]


Select Measurement

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Configuration Overview > Select Measurement
Select Measurement

Selects a different measurement type to be performed.

See "Realtime Measurement Types".

Remote command:

CONFigure:​REALtime:​MEASurement


Specifics for

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Configuration Overview > Specifics for
Specifics for

The measurement channel may contain several windows for different results. Thus, the settings indicated in the "Overview" and configured in the dialog boxes vary depending on the selected window.

Select an active window from the "Specifics for" selection list that is displayed in the "Overview" and in all window-specific configuration dialog boxes.

The "Overview" and dialog boxes are updated to indicate the settings for the selected window.


Input Source Settings

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Input Source Settings
Input Source Settings

The input source determines which data the R&S FSW will analyze.

Input settings can be configured in the "Input" dialog box.

Some settings are also available in the "Amplitude" tab of the "Amplitude" dialog box.

Output settings are described in "Output Settings".

Contents
  • Radio Frequency Input


Radio Frequency Input

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Input Source Settings > Radio Frequency Input
Radio Frequency Input

The default input source for the R&S FSW is "Radio Frequency", i.e. the signal at the RF INPUT connector on the front panel of the R&S FSW. If no additional options are installed, this is the only available input source.

└ Input Coupling
└ Impedance
└ High-Pass Filter 1...3 GHz
└ YIG-Preselector
└ Input Connector


Input Coupling

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Input Source Settings > Radio Frequency Input > Input Coupling
Input Coupling

The RF input of the R&S FSW can be coupled by alternating current (AC) or direct current (DC).

AC coupling blocks any DC voltage from the input signal. This is the default setting to prevent damage to the instrument. Very low frequencies in the input signal may be distorted.

However, some specifications require DC coupling. In this case, you must protect the instrument from damaging DC input voltages manually. For details, refer to the data sheet.

Remote command:

INPut:​COUPling


Impedance

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Input Source Settings > Radio Frequency Input > Impedance
Impedance

The reference impedance for the measured levels of the R&S FSW can be set to 50 Ω or 75 Ω.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a 75 Ω adapter of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

Remote command:

INPut:​IMPedance


High-Pass Filter 1...3 GHz

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Input Source Settings > Radio Frequency Input > High-Pass Filter 1...3 GHz
High-Pass Filter 1...3 GHz

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Remote command:

INPut:​FILTer:​HPASs[:​STATe]


YIG-Preselector

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Input Source Settings > Radio Frequency Input > YIG-Preselector
YIG-Preselector

Activates or deactivates the YIG-preselector.

Note that the YIG-preselector is active only on frequencies greater than 8 GHz. Therefore, switching the YIG-preselector on or off has no effect if the frequency is below that value.

Remote command:

INPut:​FILTer:​YIG[:​STATe]


Input Connector

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Input Source Settings > Radio Frequency Input > Input Connector
Input Connector

Determines whether the RF input data is taken from the RF INPUT connector (default) or the optional BASEBAND INPUT I connector. This setting is only available if the Analog Baseband Interface (R&S FSW-B71) is installed and active for input. It is not available for the R&S FSW67.

For more information see "Processing Data From the Analog Baseband Interface" .

Remote command:

INPut:​CONNector


Frequency and Span Settings

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Frequency and Span Settings
Frequency and Span Settings

Frequency and span settings can be configured via the "Frequency" dialog box.

└ Center frequency
└ Span
└ Start / Stop
└ Full Span
└ Last Span
└ Center Frequency Stepsize
└ Frequency Offset


Center frequency

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Frequency and Span Settings > Center frequency
Center frequency

Defines the normal center frequency of the signal. The allowed range of values for the center frequency depends on the frequency span.

fmax and spanmin are specified in the data sheet.

Remote command:

[SENSe:​]FREQuency:​CENTer


Span

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Frequency and Span Settings > Span
Span

Defines the frequency span. The center frequency is kept constant. The following range is allowed:

spanmin ≤ f span ≤ f max

fmax and spanmin are specified in the data sheet.

For more information see "Defining the Scope of the Measurement - Frequency Range" .

Remote command:

[SENSe:​]FREQuency:​SPAN


Start / Stop

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Frequency and Span Settings > Start / Stop
Start / Stop

Defines the start and stop frequencies. The following range of values is allowed:

fmin ≤ fstart ≤ fmax – spanmin

fmin + spanmin ≤ fstop ≤ fmax

fmin, fmax and spanmin are specified in the data sheet.

Remote command:

[SENSe:​]FREQuency:​STARt

[SENSe:​]FREQuency:​STOP


Full Span

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Frequency and Span Settings > Full Span
Full Span

Sets the span to the full frequency range of the R&S FSW specified in the data sheet. This setting is useful for overview measurements.

Remote command:

[SENSe:​]FREQuency:​SPAN:​FULL


Last Span

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Frequency and Span Settings > Last Span
Last Span

Sets the span to the previous value. With this function you can switch between an overview measurement and a detailed measurement quickly.

Remote command:

[SENSe:​]FREQuency:​SPAN


Center Frequency Stepsize

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Frequency and Span Settings > Center Frequency Stepsize
Center Frequency Stepsize

Defines the step size by which the center frequency is increased or decreased when the arrow keys are pressed. When you use the rotary knob the center frequency changes in steps of only 1/10 of the "Center Frequency Stepsize".

The step size can be coupled to another value or it can be manually set to a fixed value.

For more details see "Stepping Through the Frequency Range - Center Frequency Stepsize" .

"X * Span" | Sets the step size for the center frequency to a defined factor of the span. The "X-Factor" defines the percentage of the span. Values between 1 and 100 % in steps of 1 % are allowed. The default setting is 10 %.
"= Center" | Sets the step size to the value of the center frequency. The used value is indicated in the "Value" field.
"= Marker" | This setting is only available if a marker is active. Sets the step size to the value of the current marker and removes the coupling of the step size to span. The used value is indicated in the "Value" field.
"Manual" | Defines a fixed step size for the center frequency. Enter the step size in the "Value" field.
Remote command:

[SENSe:​]FREQuency:​CENTer:​STEP


Frequency Offset

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Frequency and Span Settings > Frequency Offset
Frequency Offset

Shifts the displayed frequency range along the x-axis by the defined offset.

This parameter has no effect on the R&S FSW hardware, or on the captured data or on data processing. It is simply a manipulation of the final results in which absolute frequency values are displayed. Thus, the x-axis of a spectrum display is shifted by a constant offset if it shows absolute frequencies, but not if it shows frequencies relative to the signal's center frequency.

A frequency offset can be used to correct the display of a signal that is slightly distorted by the measurement setup, for example.

The allowed values range from -100 GHz to 100 GHz. The default setting is 0 Hz.

Note: In MSRA/MSRT mode, this function is only available for the MSRA/MSRT Master.

Remote command:

[SENSe:​]FREQuency:​OFFSet


Amplitude Settings

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Amplitude Settings
Amplitude Settings

Amplitude settings determine how the R&S FSW must process or display the expected input power levels.

To configure the amplitude settings

Amplitude settings can be configured via the AMPT key or in the "Amplitude" dialog box.

►

To display the "Amplitude" dialog box, do one of the following:

  • Select "Amplitude" from the "Overview".
  • Select the AMPT key and then the "Amplitude Config" softkey.
└ Reference Level
└ Shifting the Display (Offset)
└ RF Attenuation
└ Attenuation Mode / Value
└ Using Electronic Attenuation (Option B25)
└ Input Settings
└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Reference Level

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Amplitude Settings > Reference Level
Reference Level

The reference level is also used to scale power diagrams; the reference level is then used as the maximum on the y-axis.

Since the R&S FSW hardware is adapted according to this value, it is recommended that you set the reference level close above the expected maximum signal level to ensure an optimum measurement (no compression, good signal-to-noise ratio).

Note that the "Reference Level" value ignores the "Shifting the Display (Offset)". It is important to know the actual power level the R&S FSW must handle.

For details see "Reference Level" .

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel

└ Shifting the Display (Offset)


Shifting the Display (Offset)

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Amplitude Settings > Reference Level > Shifting the Display (Offset)
Shifting the Display (Offset)

Defines an arithmetic level offset. This offset is added to the measured level irrespective of the selected unit. The scaling of the y-axis is changed accordingly.

Define an offset if the signal is attenuated or amplified before it is fed into the R&S FSW so the application shows correct power results. All displayed power level results will be shifted by this value.

Note, however, that the "Reference Level" value ignores the "Reference Level Offset". It is important to know the actual power level the R&S FSW must handle.

To determine the required offset, consider the external attenuation or gain applied to the input signal. A positive value indicates that an attenuation took place (R&S FSW increases the displayed power values) , a negative value indicates an external gain (R&S FSW decreases the displayed power values).

The setting range is ±200 dB in 0.01 dB steps.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel:​OFFSet


RF Attenuation

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Amplitude Settings > RF Attenuation
RF Attenuation

Defines the attenuation applied to the RF input.

└ Attenuation Mode / Value


Attenuation Mode / Value

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Amplitude Settings > RF Attenuation > Attenuation Mode / Value
Attenuation Mode / Value

The RF attenuation can be set automatically as a function of the selected reference level (Auto mode). This ensures that the optimum RF attenuation is always used. It is the default setting. By default and when "Using Electronic Attenuation (Option B25)" is not available, mechanical attenuation is applied.

In "Manual" mode, you can set the RF attenuation in 1 dB steps (down to 0 dB, also using the rotary knob). Other entries are rounded to the next integer value. The range is specified in the data sheet. If the defined reference level cannot be set for the defined RF attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed.

NOTICE! Risk of hardware damage due to high power levels. When decreasing the attenuation manually, ensure that the power level does not exceed the maximum level allowed at the RF input, as an overload may lead to hardware damage.

Note: In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible (if option B25 is installed and active) to reduce the amount of mechanical switching required.

For details see "RF Attenuation" .

Remote command:

INPut:​ATTenuation

INPut:​ATTenuation:​AUTO


Using Electronic Attenuation (Option B25)

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Amplitude Settings > Using Electronic Attenuation (Option B25)
Using Electronic Attenuation (Option B25)

If option R&S FSW-B25 is installed, you can also activate an electronic attenuator.

In "Auto" mode, the settings are defined automatically; in "Manual" mode, you can define the mechanical and electronic attenuation separately.

Note: Electronic attenuation is not available for stop frequencies (or center frequencies in zero span) >13.6 GHz.
In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible to reduce the amount of mechanical switching required. Mechanical attenuation may provide a better signal-to-noise ratio, however.
When you switch off electronic attenuation, the RF attenuation is automatically set to the same mode (auto/manual) as the electronic attenuation was set to. Thus, the RF attenuation may be set to automatic mode, and the full attenuation is provided by the mechanical attenuator, if possible.

Both the electronic and the mechanical attenuation can be varied in 1 dB steps. Other entries are rounded to the next lower integer value.

If the defined reference level cannot be set for the given attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed in the status bar.

Remote command:

INPut:​EATT:​STATe

INPut:​EATT:​AUTO

INPut:​EATT


Input Settings

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Amplitude Settings > Input Settings
Input Settings

Some input settings affect the measured amplitude of the signal, as well.

└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Preamplifier (option B24)

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Amplitude Settings > Input Settings > Preamplifier (option B24)
Preamplifier (option B24)

If option R&S FSW-B24 is installed, a preamplifier can be activated for the RF input signal.

You can use a preamplifier to analyze signals from DUTs with low input power.

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the following settings are available:

"Off" | Deactivates the preamplifier.
"15 dB" | The RF input signal is amplified by about 15 dB.
"30 dB" | The RF input signal is amplified by about 30 dB.
Remote command:

INPut:​GAIN:​STATe

INPut:​GAIN[:​VALue]


Scaling the Y-Axis

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Scaling the Y-Axis
Scaling the Y-Axis

The individual scaling settings that affect the vertical axis are described here.

└ Range
└ Ref Level Position
└ Scaling


Range

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Scaling the Y-Axis > Range
Range

Defines the displayed y-axis range in dB.

The default value is 100 dB.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]


Ref Level Position

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Scaling the Y-Axis > Ref Level Position
Ref Level Position

Defines the reference level position, i.e. the position of the maximum AD converter value on the level axis in %, where 0 % corresponds to the lower and 100 % to the upper limit of the diagram.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RPOSition


Scaling

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Scaling the Y-Axis > Scaling
Scaling

Defines the scaling method for the y-axis.

For more information see "Scaling" .

"Logarithmic" | Logarithmic scaling (only available for logarithmic units - dB..., and A, V, Watt)
"Linear Unit" | Linear scaling in the unit of the measured signal
"Linear Percent" | Linear scaling in percentages from 0 to 100
"Absolute" | The labeling of the level lines refers to the absolute value of the reference level (not available for "Linear Percent")
"Relative" | The scaling is in dB, relative to the reference level (only available for logarithmic units - dB...). The upper line of the grid (reference level) is always at 0 dB.
Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y:​SPACing

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MODE


Trigger Configuration

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration
Trigger Configuration
Contents
  • Trigger Source Settings
  • Frequency Mask Trigger Configuration
  • Trigger Input/Output


Trigger Source Settings

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Source Settings
Trigger Source Settings

Trigger settings determine when the input signal is measured.

└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ Frequency Mask
└ Time Domain
└ Trigger Level
└ Trigger Offset
└ Slope
└ Pretrigger capture time
└ Posttrigger capture time
└ Trigger mode (Auto Rearm/ Stop on Trigger)
└ Edit Frequency Mask


Trigger Source

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Source Settings > Trigger Source
Trigger Source

Defines the trigger source. If a trigger source other than "Free Run" is set, "TRG" is displayed in the channel bar and the trigger source is indicated.

Remote command:

TRIGger[:​SEQuence]:​SOURce

└ Free Run
└ External Trigger 1/2/3
└ Frequency Mask
└ Time Domain


Free Run

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Source Settings > Trigger Source > Free Run
Free Run

No trigger source is considered. Data acquisition is started manually or automatically and continues until stopped explicitely.

Remote command:

TRIG:SOUR IMM, see TRIGger[:​SEQuence]:​SOURce


External Trigger 1/2/3

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Source Settings > Trigger Source > External Trigger 1/2/3
External Trigger 1/2/3

Data acquisition starts when the TTL signal fed into the specified input connector (on the front or rear panel) meets or exceeds the specified trigger level.

(See "Trigger Level (Repetition interval)" ).

Note: The "External Trigger 1" softkey automatically selects the trigger signal from the TRIGGER INPUT connector on the front panel.

For details see "TRIGGER INPUT / OUTPUT" and "TRIGGER 3 INPUT/ OUTPUT" .

"External Trigger 1" | Trigger signal from the TRIGGER 1 INPUT connector on the front panel.
"External Trigger 2" | Trigger signal from the TRIGGER 2 INPUT/OUTPUT connector on the front panel.
"External Trigger 3" | Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector on the rear panel.
Remote command:

TRIG:SOUR EXT, TRIG:SOUR EXT2

TRIG:SOUR EXT3

See TRIGger[:​SEQuence]:​SOURce


Frequency Mask

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Source Settings > Trigger Source > Frequency Mask
Frequency Mask

Triggers when the measured signal violates the user-defined frequency mask.

For details see "Frequency Mask Trigger".

Remote command:

TRIG:SOUR MASK, see TRIGger[:​SEQuence]:​SOURce


Time Domain

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Source Settings > Trigger Source > Time Domain
Time Domain

Triggers measurements if the signal exceeds a particular power level in the time domain.

Remote command:

TRIG:SEQ:SOUR TDTR, see TRIGger[:​SEQuence]:​SOURce

TRIGger[:​SEQuence]:​TDTRigger:​LEVel


Trigger Level

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Source Settings > Trigger Level
Trigger Level

Defines the trigger level for the specified trigger source.

For details on supported trigger levels, see the data sheet.

Remote command:

TRIGger[:​SEQuence]:​LEVel[:​EXTernal<port>]

TRIGger[:​SEQuence]:​TDTRigger:​LEVel


Trigger Offset

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Source Settings > Trigger Offset
Trigger Offset

Defines the time offset between the trigger event and the start of the sweep.

offset > 0: | Start of the sweep is delayed
offset < 0: | Sweep starts earlier (pre-trigger)
Remote command:

TRIGger[:​SEQuence]:​HOLDoff[:​TIME]


Slope

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Source Settings > Slope
Slope

For all trigger sources except time and frequency mask (Realtime only) you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Remote command:

TRIGger[:​SEQuence]:​SLOPe


Pretrigger capture time

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Source Settings > Pretrigger capture time
Pretrigger capture time

Defines a time period before the actual trigger event in which data is also captured, in addition to the post-trigger time.

In this case, one or more additional frames will be available in the spectrogram/waterfall beneath the frame displayed in the Realtime Spectrum or PVT diagram window by default.

Remote command:

TRIGger[:​SEQuence]:​PRETrigger[:​TIME]


Posttrigger capture time

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Source Settings > Posttrigger capture time
Posttrigger capture time

Defines a time period after the actual trigger event in which data is captured.

Posttrigger data after the sweep time are displayed as additional frames in the spectrogram/ PVT waterfall above the frame displayed in the Realtime Spectrum or PVT diagram window by default.

Remote command:

TRIGger[:​SEQuence]:​POSTtrigger[:​TIME]


Trigger mode (Auto Rearm/ Stop on Trigger)

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Source Settings > Trigger mode (Auto Rearm/ Stop on Trigger)
Trigger mode (Auto Rearm/ Stop on Trigger)

By default, a trigger event causes the R&S FSW to start a measurement and to immediately rearm the trigger ("Auto Rearm"). In that case, measurements are continuously triggered and measurement results may become obsolete in a very short time. The pre- and posttrigger periods for each sweep time are displayed.

If "Stop on Trigger" is active, the trigger is not rearmed after the first trigger event has occured; thus, the measurement stops after one sweep. The measurement results for that sweep remain on the display, including the pretrigger and posttrigger periods. Note, however, that if the trigger event occurs before the defined pretrigger time has elapsed, the period between measurement start and the trigger event is shorter than the defined pretrigger time.

Remote command:

TRIGger:​MODE


Edit Frequency Mask

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Source Settings > Edit Frequency Mask
Edit Frequency Mask

Opens the "Edit Frequency Mask" dialog, only available if the "Frequency Mask" trigger source is selected.

For details see "Frequency Mask Trigger Configuration".


Frequency Mask Trigger Configuration

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Frequency Mask Trigger Configuration
Frequency Mask Trigger Configuration

The Frequency Mask Trigger (FMT) is a mask in the frequency domain, which is checked with every calculated FFT. When a specific condition concerning this mask occurs during the measurement of the input signal, data capturing is triggered.

For details see "Frequency Mask Trigger".

Frequency masks are created and configured in the "Edit Frequency Mask" dialog box, which is displayed when you do one of the following (after selecting "Frequency Mask" as the trigger source):

  • Press the TRIG key on the front panel, then select the "Edit Frequency Mask" softkey.
  • In the "Overview", select "Trigger", then "Edit Frequency Mask".
Contents
  • Frequency Mask Management
  • Frequency Mask Definition


Frequency Mask Management

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Frequency Mask Trigger Configuration > Frequency Mask Management
Frequency Mask Management

As frequency masks can have a very complex structure, they can be stored for later use with other signals. The masks are stored in a file with the extension .FMT in the freqmask subdirectory of the installation directory. By default, the mask name is used as the file name; however, it can be edited.

└ New Mask
└ Save Mask
└ Load Mask
└ Delete Mask


New Mask

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Frequency Mask Trigger Configuration > Frequency Mask Management > New Mask
New Mask

Clears the current mask configuration to define a new frequency mask.

Remote command:

CALCulate<n>:​MASK:​NAME


Save Mask

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Frequency Mask Trigger Configuration > Frequency Mask Management > Save Mask
Save Mask

Opens a file selection dialog box to save the current frequency mask configuration in a file.

By default, the mask name is used as the file name; however, it can be edited.

The mask is stored in a file with the extension .FMT in the freqmask subdirectory of the R&S FSW installation directory.

Remote command:

Path selection:

CALCulate<n>:​MASK:​CDIRectory

Define mask name:

CALCulate<n>:​MASK:​NAME


Load Mask

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Frequency Mask Trigger Configuration > Frequency Mask Management > Load Mask
Load Mask

Opens a file selection dialog box to restore a saved frequency mask.

The dialog box contains all frequency masks with the extension .FMT in the freqmask subdirectory of the R&S FSW installation directory.

Select the required mask and confirm the selection with the "Load" button.

Remote command:

Path selection:

CALCulate<n>:​MASK:​CDIRectory

Load mask:

CALCulate<n>:​MASK:​NAME


Delete Mask

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Frequency Mask Trigger Configuration > Frequency Mask Management > Delete Mask
Delete Mask

Opens a file selection dialog box to delete a previously saved frequency mask.

If confirmed, the file is deleted.

Remote command:

CALCulate<n>:​MASK:​DELete


Frequency Mask Definition

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Frequency Mask Trigger Configuration > Frequency Mask Definition
Frequency Mask Definition

The "Edit Frequency Mask" dialog box provides a basic structure of an upper frequency mask in the live preview window.

└ Name
└ Comment
└ Mask points
└ Inserting points
└ Deleting points
└ Shifting the mask position horizontally (Shift x)
└ Shifting the mask vertically (Shift y)
└ Changing the y-axis scaling (Y-Axis rel/abs)
└ Defining a mask automatically (Auto-Set Mask)
└ Setting the trigger condition
└ Activating/deactivating upper and lower masks


Name

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Frequency Mask Trigger Configuration > Frequency Mask Definition > Name
Name

Defines the name of the frequency mask. This name is used as the default file name for storage.

Remote command:

CALCulate<n>:​MASK:​NAME


Comment

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Frequency Mask Trigger Configuration > Frequency Mask Definition > Comment
Comment

An optional description of the frequency mask.

Remote command:

CALCulate<n>:​MASK:​COMMent


Mask points

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Frequency Mask Trigger Configuration > Frequency Mask Definition > Mask points
Mask points

Each mask is defined by a minimum of 2 and a maximum of 1001 mask points. Each mask point is defined by its position (x-axis) and value (y-value). Mask points must be defined in ascending order and have unique positions.

Remote command:

CALCulate<n>:​MASK:​UPPer[:​DATA]

CALCulate<n>:​MASK:​LOWer[:​DATA]


Inserting points

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Frequency Mask Trigger Configuration > Frequency Mask Definition > Inserting points
Inserting points

Inserts a mask point in the frequency mask above the selected one in the "Position/Value" list and the preview pane.

Remote command:

Redefine the list of data points:

CALCulate<n>:​MASK:​UPPer[:​DATA]

CALCulate<n>:​MASK:​LOWer[:​DATA]


Deleting points

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Frequency Mask Trigger Configuration > Frequency Mask Definition > Deleting points
Deleting points

Deletes the selected mask point in the "Position/Value" list and the preview pane.

Remote command:

Redefine the list of data points:

CALCulate<n>:​MASK:​UPPer[:​DATA]

CALCulate<n>:​MASK:​LOWer[:​DATA]


Shifting the mask position horizontally (Shift x)

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Frequency Mask Trigger Configuration > Frequency Mask Definition > Shifting the mask position horizontally (Shift x)
Shifting the mask position horizontally (Shift x)

Shifts the x-value (position) of each mask point horizontally by the defined shift width.

Remote command:

CALCulate<n>:​MASK:​UPPer:​SHIFt:​X

CALCulate<n>:​MASK:​LOWer:​SHIFt:​X


Shifting the mask vertically (Shift y)

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Frequency Mask Trigger Configuration > Frequency Mask Definition > Shifting the mask vertically (Shift y)
Shifting the mask vertically (Shift y)

Shifts the y-value of each mask point vertically by the defined shift height

Remote command:

CALCulate<n>:​MASK:​UPPer:​SHIFt:​Y

CALCulate<n>:​MASK:​LOWer:​SHIFt:​Y


Changing the y-axis scaling (Y-Axis rel/abs)

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Frequency Mask Trigger Configuration > Frequency Mask Definition > Changing the y-axis scaling (Y-Axis rel/abs)
Changing the y-axis scaling (Y-Axis rel/abs)

Switches between absolute scaling (in dBm) or relative scaling (in dB) for the mask (y-)values.

Remote command:

CALCulate<n>:​MASK:​MODE


Defining a mask automatically (Auto-Set Mask)

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Frequency Mask Trigger Configuration > Frequency Mask Definition > Defining a mask automatically (Auto-Set Mask)
Defining a mask automatically (Auto-Set Mask)

Defines a mask automatically according to the currently measured data. The mask is configured to follow the measurement trace with a specific distance to the power levels.

Remote command:

CALCulate<n>:​MASK:​UPPer:​AUTO


Setting the trigger condition

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Frequency Mask Trigger Configuration > Frequency Mask Definition > Setting the trigger condition
Setting the trigger condition

Defines how the frequency mask is evaluated to control data acquisition.

For details see "Trigger conditions".

"Entering" | Activates the trigger as soon as the signal enters the frequency mask. To arm the trigger, the signal initially has to be outside the frequency mask.
"Leaving" | Activates the trigger as soon as the signal leaves the frequency mask. To arm the trigger, the signal initially has to be inside the frequency mask.
Remote command:

TRIGger[:​SEQuence]:​MASK:​CONDition


Activating/deactivating upper and lower masks

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Frequency Mask Trigger Configuration > Frequency Mask Definition > Activating/deactivating upper and lower masks
Activating/deactivating upper and lower masks

By default, the defined mask is activated as an upper mask, i.e. the mask is the area above the defined mask points. In addition or alternatively, a lower mask can be activated. In a lower mask, the mask is the area below the defined mask points.

The lower mask is defined in the same manner as the upper mask. However, it must be activated explicitely and cannot be configured automatically according to the currently measured values ("Auto-Set Mask").

Both upper and lower masks can be activated at the same time, in order to define a "corridor" of allowed values.

For details see "Upper and lower masks"

Remote command:

CALCulate<n>:​MASK:​LOWer:​STATe

CALCulate<n>:​MASK:​UPPer:​STATe


Trigger Input/Output

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Input/Output
Trigger Input/Output

External triggers from one of the TRIGGER INPUT/OUTPUT connectors on the R&S FSW are configured in a separate tab of "Trigger" the dialog box.

└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Trigger 2/3

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Input/Output > Trigger 2/3
Trigger 2/3

Defines the usage of the variable TRIGGER INPUT/OUTPUT connectors, where:

"Trigger 2": TRIGGER INPUT/OUTPUT connector on the front panel

"Trigger 3": TRIGGER 3 INPUT/ OUTPUT connector on the rear panel

(Trigger 1 is INPUT only.)

Note: Providing trigger signals as output is described in detail in "How to Output a Trigger Signal" .

"Input" | The signal at the connector is used as an external trigger source by the R&S FSW. No further trigger parameters are available for the connector.
"Output" | The R&S FSW sends a trigger signal to the output connector to be used by connected devices. Further trigger parameters are available for the connector.
Remote command:

OUTPut:​TRIGger<port>:​LEVel

OUTPut:​TRIGger<port>:​DIRection

└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Output Type

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Input/Output > Trigger 2/3 > Output Type
Output Type

Type of signal to be sent to the output

"Device Triggered" | (Default) Sends a trigger when the R&S FSW triggers.
"Trigger Armed" | Sends a (high level) trigger when the R&S FSW is in "Ready for trigger" state. This state is indicated by a status bit in the STATus:OPERation register (bit 5), as well as by a low level signal at the AUX port (pin 9).
"User Defined" | Sends a trigger when user selects "Send Trigger" button. In this case, further parameters are available for the output signal.
Remote command:

OUTPut:​TRIGger<port>:​OTYPe

└ Level
└ Pulse Length
└ Send Trigger


Level

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Input/Output > Trigger 2/3 > Output Type > Level
Level

Defines whether a constant high (1) or low (0) signal is sent to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​LEVel


Pulse Length

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Input/Output > Trigger 2/3 > Output Type > Pulse Length
Pulse Length

Defines the length of the pulse sent as a trigger to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​LENGth


Send Trigger

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Trigger Configuration > Trigger Input/Output > Trigger 2/3 > Output Type > Send Trigger
Send Trigger

Sends a user-defined trigger to the output connector immediately. Note that the trigger pulse level is always opposite to the constant signal level defined by the output "Level" setting, e.g. for "Level = High", a constant high signal is output to the connector until the "Send Trigger" button is selected. Then, a low pulse is sent.

Which pulse level will be sent is indicated by a graphic on the button.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​IMMediate


Bandwidth and Sweep Settings

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Bandwidth and Sweep Settings
Bandwidth and Sweep Settings
To configure the bandwidth, filter and sweep

Bandwidth settings can be configured via the "Bandwidth" tab of the "Bandwidth" dialog box.

Sweep settings can be configured in the "Sweep" dialog box or via the "Sweep" tab of the "Bandwidth" dialog box.

  1. To display the "Bandwidth" dialog box, do one of the following:

    • Select "Bandwidth" from the "Overview".
    • Select the BW key and then the "Bandwidth Config" softkey.

  2. To display the "Sweep" dialog box, do one of the following:

    • Select "Bandwidth" from the "Overview" and switch to the "Sweep" tab in the "Bandwidth" dialog box.
    • Select the SWEEP key and then the "Sweep Config" softkey.
└ RBW
└ Span/RBW
└ FFT Window
└ Sweep Time
└ PVT Sweep Time
└ Continuous Sweep/RUN CONT
└ Single Sweep/ RUN SINGLE
└ Selecting a frame to display
└ Sweep Count
└ Clear Spectrogram


RBW

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Bandwidth and Sweep Settings > RBW
RBW

Defines the resolution bandwidth. The available resolution bandwidths are specified in the data sheet. Numeric input is always rounded to the nearest possible bandwidth.

The resolution bandwidth is coupled to the selected span. If the span is changed, the resolution bandwidth is automatically adjusted, and vice versa.

For more information see "Defining the Resolution Bandwidth".

Remote command:

[SENSe:​]BANDwidth|BWIDth[:​RESolution]


Span/RBW

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Bandwidth and Sweep Settings > Span/RBW
Span/RBW

Defines the coupling ratio (span / RBW). Which coupling ratios are available depends on the selected FFT window and the measurement type (see "Realtime Measurement Types").

Changing the coupling ratio affects the FFT length, which in turn influences the time resolution of the FFT.

Note that for High Resolution measurements, additional higher coupling ratios are available (see "High Resolution Realtime Measurement").

For more information see "Defining the Resolution Bandwidth".

Remote command:

[SENSe:​]BANDwidth|BWIDth[:​RESolution]:​RATio


FFT Window

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Bandwidth and Sweep Settings > FFT Window
FFT Window

In the realtime mode you can select one of several FFT window types. The window type is coupled to the resolution bandwidth.

The following window types are available:
  • Blackman
  • Flattop
  • Gaussian
  • Rectangle
  • Hanning
  • Hamming
  • Kaiser
Remote command:

[SENSe:​]SWEep:​FFT:​WINDow:​TYPE


Sweep Time

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Bandwidth and Sweep Settings > Sweep Time
Sweep Time

Determines the amount of time used to sample data for one spectrum. The sweep time can be defined automatically or manually.

The allowed sweep times depend on the device model; refer to the data sheet.

For more information see "Sweep Time and Detector".

"Auto" | The sweep time is coupled to the span and resolution bandwidth (RBW). If the span or resolution bandwidth is changed, the sweep time is automatically adjusted.
"Manual" | Define the sweep time manually. Allowed values depend on the coupling ratio of span to RBW. For details refer to the data sheet. Numeric input is always rounded to the nearest possible sweep time.
Remote command:

[SENSe:​]SWEep:​TIME:​AUTO

[SENSe<n>:​]SWEep:​TIME


PVT Sweep Time

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Bandwidth and Sweep Settings > PVT Sweep Time
PVT Sweep Time

Determines the amount of time used to sample data for one power vs time diagram. Note that the "Sweep Time" setting for results in the frequency domain and the PVT sweep time values are independent and may be different.

Remote command:

[SENSe<n>:​]SWEep:​TIME


Continuous Sweep/RUN CONT

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Bandwidth and Sweep Settings > Continuous Sweep/RUN CONT
Continuous Sweep/RUN CONT

After triggering, starts the measurement and repeats it continuously until stopped. This is the default setting.

While the measurement is running, the "Continuous Sweep" softkey and the RUN CONT key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again. The results are not deleted until a new measurement is started.

Note: Sequencer. If the Sequencer is active in MSRT mode, the "Continuous Sweep" function does not start data capturing; it merely has an effect on trace averaging over multiple sequences. In this case, trace averaging is performed.
Furthermore, the RUN CONT key controls the Sequencer, not individual sweeps. RUN CONT starts the Sequencer in continuous mode.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate:​CONTinuous


Single Sweep/ RUN SINGLE

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Bandwidth and Sweep Settings > Single Sweep/ RUN SINGLE
Single Sweep/ RUN SINGLE

RUN SINGLE initiates a single measurement. If no trigger is used, data is captured for the defined sweep time, resulting in one spectrogram frame. Otherwise, the measurement starts after triggering and the measurement time is defined by the post- and pretrigger times. The result may be more than one frame.

RUN CONT starts a measurement and repeats it continuously until stopped.

While the measurement is running, the "Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Note: Sequencer. If the Sequencer is active in MSRT mode, the "Single Sweep" function does not start data capturing; it merely has an effect on trace averaging over multiple sequences. In this case, no trace averaging is performed.
Furthermore, the RUN SINGLE key controls the Sequencer, not individual sweeps. RUN SINGLE starts the Sequencer in single mode.
If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate[:​IMMediate]

CALCulate:​SGRam|SPECtrogram:​CONT


Selecting a frame to display

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Bandwidth and Sweep Settings > Selecting a frame to display
Selecting a frame to display

Selects a specific frame, loads the corresponding trace from the memory, and displays it in the Realtime Spectrum or Power vs Time window.

Different frames can be displayed in the Realtime Spectrum and Power vs Time windows.

Note that activating a marker or changing the position of the active marker automatically selects the frame that belongs to that marker.

This function is only available in single sweep mode or if the sweep is stopped.

The most recent frame is number 0, all previous frames have a negative number.

For more information see "Time Frames".

Remote command:

CALCulate<n>:​SGRam|SPECtrogram:​FRAMe:​SELect


Sweep Count

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Bandwidth and Sweep Settings > Sweep Count
Sweep Count

Defines the number of measurements to be performed in the single sweep mode. Values from 0 to 200000 are allowed. If the values 0 or 1 are set, one measurement is performed. The sweep count is applied to all the traces in all Realtime Spectrum and Persistence Spectrum diagrams.

If the trace configurations "Average", "Max Hold" or "Min Hold" are set, this value also determines the number of averaging or maximum search procedures.

In continuous sweep mode, if sweep count = 0 (default), averaging is performed over 10 sweeps. For sweep count =1, no averaging, maxhold or minhold operations are performed.

For more information see "How Much Data is Measured: Sweep Points and Sweep Count" .

Remote command:

[SENSe:​]SWEep:​COUNt


Clear Spectrogram

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Bandwidth and Sweep Settings > Clear Spectrogram
Clear Spectrogram

Resets the spectrogram result display and clears the history buffer.

This function is only available if a spectrogram is selected.

Remote command:

CALCulate<n>:​SGRam|SPECtrogram:​CLEar[:​IMMediate]


Output Settings

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Output Settings
Output Settings

The R&S FSW can provide output to special connectors for other devices.

For details on connectors refer to "Instrument Tour" .

Providing trigger signals as output is described in "How to Output a Trigger Signal" .

Output settings can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

└ Noise Source
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Noise Source

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Output Settings > Noise Source
Noise Source

Switches the supply voltage for an external noise source on or off.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of a DUT.

Remote command:

DIAGnostic:​SERVice:​NSOurce


Adjusting Settings Automatically

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Adjusting Settings Automatically
Adjusting Settings Automatically

Some settings can be adjusted by the R&S FSW automatically according to the current measurement settings. In order to do so, a measurement is performed. The duration of this measurement can be defined automatically or manually.

To activate the automatic adjustment of a setting, select the corresponding function in the AUTO SET menu or in the configuration dialog box for the setting, where available.

MSRA/MSRT operating modes

In MSRA/MSRT operating mode, settings related to data acquisition can only be adjusted automatically for the MSRA/MSRT Master, not the applications.

Adjusting settings automatically during triggered measurements

When you select an auto adjust function a measurement is performed to determine the optimal settings. If you select an auto adjust funtion for a triggered measurement, you are asked how the R&S FSW should behave:

  • (default:) The measurement for adjustment waits for the next trigger
  • The measurement for adjustment is performed without waiting for a trigger.
    The trigger source is temporarily set to "Free Run". After the measurement is completed, the original trigger source is restored.

Remote command:

[SENSe:​]ADJust:​CONFigure:​TRIG

└ Adjusting all Determinable Settings Automatically (Auto All)
└ Adjusting the Center Frequency Automatically (Auto Freq)
└ Setting the Reference Level Automatically (Auto Level)
└ Resetting the Automatic Measurement Time (Meastime Auto)
└ Changing the Automatic Measurement Time (Meastime Manual)
└ Upper Level Hysteresis
└ Lower Level Hysteresis


Adjusting all Determinable Settings Automatically (Auto All)

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Adjusting Settings Automatically > Adjusting all Determinable Settings Automatically (Auto All)
Adjusting all Determinable Settings Automatically (Auto All)

Activates all automatic adjustment functions for the current measurement settings.

This includes:

  • Auto Frequency
  • Auto Level

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​ALL


Adjusting the Center Frequency Automatically (Auto Freq)

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Adjusting Settings Automatically > Adjusting the Center Frequency Automatically (Auto Freq)
Adjusting the Center Frequency Automatically (Auto Freq)

This function adjusts the center frequency automatically.

The optimum center frequency is the frequency with the highest S/N ratio in the frequency span. As this function uses the signal counter, it is intended for use with sinusoidal signals.

(See "Performing a Highly Accurate Frequency Measurement (Signal Count)" )

Remote command:

[SENSe:​]ADJust:​FREQuency


Setting the Reference Level Automatically (Auto Level)

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Adjusting Settings Automatically > Setting the Reference Level Automatically (Auto Level)
Setting the Reference Level Automatically (Auto Level)

Automatically determines the optimal reference level for the current input data. At the same time, the internal attenuators and the preamplifier (for analog baseband input: the full scale level) are adjusted so the signal-to-noise ratio is optimized, while signal compression, clipping and overload conditions are minimized.

In order to do so, a level measurement is performed to determine the optimal reference level.

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​LEVel


Resetting the Automatic Measurement Time (Meastime Auto)

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Adjusting Settings Automatically > Resetting the Automatic Measurement Time (Meastime Auto)
Resetting the Automatic Measurement Time (Meastime Auto)

Resets the measurement duration for automatic settings to the default value.

For details see "Adjusting Settings Automatically" .

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE


Changing the Automatic Measurement Time (Meastime Manual)

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Adjusting Settings Automatically > Changing the Automatic Measurement Time (Meastime Manual)
Changing the Automatic Measurement Time (Meastime Manual)

This function allows you to change the measurement duration for automatic setting adjustments. Enter the value in seconds.

For details see "Adjusting Settings Automatically" .

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE

[SENSe:​]ADJust:​CONFigure:​DURation


Upper Level Hysteresis

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Adjusting Settings Automatically > Upper Level Hysteresis
Upper Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​UPPer


Lower Level Hysteresis

Realtime Application (R&S FSW-K160R) > Configuring the Realtime Spectrum Application > Adjusting Settings Automatically > Lower Level Hysteresis
Lower Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​LOWer


Configuring and Performing Measurements in MSRT Mode

Realtime Application (R&S FSW-K160R) > Configuring and Performing Measurements in MSRT Mode
Configuring and Performing Measurements in MSRT Mode

MSRT is a special operating mode on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Starting the Multi-Standard Realtime (MSRT) Operating Mode".

When you switch the operating mode of the R&S FSW to MSRT mode the first time, the Sequencer is automatically activated in continuous mode (see "Performing a Measurement in MSRT Mode"), starting a continuous Realtime Spectrum sweep with the default settings. The "Realtime Config" menu is displayed, providing access to the most important configuration functions.

Default measurement in MSRT mode

When you switch to MSRT mode, the Sequencer is automatically activated in Continuous Sequence mode. Since the default trigger mode is "Free Run" and "Auto Rearm", the MSRT Master continuously performs a realtime measurement until it is stopped. During this time, the Sequencer never passes the data on to other MSRT applications and no evaluation is performed in those result displays.

Thus, it is important that you configure a trigger for the MSRT Master, or stop the Sequencer and switch between the Master and the application tabs manually. In this case, the continuous measurement is stopped when you switch tabs. However, you will have to update the subsequent application displays manually, using the "Refresh" functions (see "Refresh"/"Refresh All").

Contents
  • Configuring the MSRT Master
  • Trigger Settings
  • Data Acquisition
  • Performing a Measurement in MSRT Mode


Configuring the MSRT Master

Realtime Application (R&S FSW-K160R) > Configuring and Performing Measurements in MSRT Mode > Configuring the MSRT Master
Configuring the MSRT Master

The MSRT Master is the only channel that captures data in MSRT mode. It also controls global configuration settings for all applications. Thus, all settings that refer to data acquisition can only be configured in the MSRT Master tab. These settings are deactivated in the configuration overviews and dialog boxes for all application channels. All other settings, e.g. concerning the evaluated data range, the display configuration or analysis, can be configured individually for each application and the Master.

In principle, the MSRT Master is configured as a Realtime Spectrum application in Signal and Spectrum Analyzer mode (see "Configuring the Realtime Spectrum Application").

Restrictions

Note that although some restrictions apply to parameters that affect both the MSRT Master and applications (see "Restrictions for Applications"), it does not matter in which order you configure them. If any contradictions occur between the captured data and the data to be evaluated, error messages are displayed in the status bar of the application and an icon ( [image] or [image]) is displayed next to the channel label. However, you will not be prevented from configuring contradictory settings.


Trigger Settings

Realtime Application (R&S FSW-K160R) > Configuring and Performing Measurements in MSRT Mode > Trigger Settings
Trigger Settings

Trigger settings determine when the input signal is measured. These settings are only available for the MSRT Master.

When you switch to MSRT mode, the Sequencer is automatically activated in Continuous Sequence mode. Since the default trigger mode is "Free Run" and "Auto Rearm", the MSRT Master continuously performs a realtime measurement until it is stopped. During this time, the Sequencer never passes the data on to other MSRT applications and no evaluation is performed in those result displays.

Thus, it is important that you configure a trigger for MSRT measurements, or else the advantage of the MSRT operating mode - analyzing data in various applications - is futile. Alternatively, stop the Sequencer and switch between the Master and the application tabs manually. In this case, the continuous measurement is stopped when you switch tabs. However, you will have to update the subsequent application displays manually, as well, using the "Refresh" functions (see "Performing a Measurement in MSRT Mode").

Trigger settings can be configured via the TRIG key or in the "Trigger" dialog box, which is displayed when you select the "Trigger" button in the "Overview". See "Trigger Configuration".

└ Capture Offset


Capture Offset

Realtime Application (R&S FSW-K160R) > Configuring and Performing Measurements in MSRT Mode > Trigger Settings > Capture Offset
Capture Offset

This setting is only available for applications in MSRA or MSRT operating mode. It has a similar effect as the trigger offset in other measurements: it defines the time offset between the capture buffer start and the start of the extracted application data.

In MSRA mode, the offset must be a positive value, as the capture buffer starts at the trigger time = 0.

For more information see "Trigger offset vs. capture offset".

For details on the MSRT operating mode see "Applications and Operating Modes".

Remote command:

[SENSe:​]RTMS:​CAPTure:​OFFSet


Data Acquisition

Realtime Application (R&S FSW-K160R) > Configuring and Performing Measurements in MSRT Mode > Data Acquisition
Data Acquisition

The data acquisition settings define which parts of the input signal are captured for further evaluation in the MSRT applications.

Configuring data acquisition is only possible for the MSRT Master channel. In MSRT application channels, these settings define the analysis interval (see "Trigger offset vs. capture offset"). Be sure to select the correct measurement channel before changing these settings.

Data acquisition settings can be configured in the "Bandwidth" dialog box, which is displayed when you select the "Bandwidth" button in the "Overview". See "Bandwidth and Sweep Settings".


Performing a Measurement in MSRT Mode

Realtime Application (R&S FSW-K160R) > Configuring and Performing Measurements in MSRT Mode > Performing a Measurement in MSRT Mode
Performing a Measurement in MSRT Mode

When you switch the operating mode of the R&S FSW to MSRT mode the first time, the Sequencer is automatically activated in continuous mode (see "Performing a Measurement in MSRT Mode"), starting a continuous Realtime Spectrum sweep with the default settings.

The Sequencer behaviour depends strongly on the trigger settings in MSRT mode (see "Using the Sequencer in MSRT Mode").

For details on the Sequencer function see "Running a Sequence of Measurements" .

Manual measurement

To control the MSRT measurement manually, stop the Sequencer and switch between the Master and the application tabs manually. Perform either a single sweep (using the "Single Sweep/ RUN SINGLE" funciton), or a continuous sweep (using the "Continuous Sweep/RUN CONT" function). The continuous sweep is stopped when you switch tabs.

If the Sequencer is deactivated, only the application that is currently displayed when a measurement is performed is updated automatically. The other applications must be updated manually using the "Refresh" functions (in the "Sequencer" menu or "Sweep" menu, see "Bandwidth and Sweep Settings").

The "Sequencer" menu is available from the toolbar.

└ Sequencer State
└ Sequencer Mode
└ Refresh All
└ Refresh


Sequencer State

Realtime Application (R&S FSW-K160R) > Configuring and Performing Measurements in MSRT Mode > Performing a Measurement in MSRT Mode > Sequencer State
Sequencer State

Activates or deactivates the Sequencer. If activated, sequential operation according to the selected Sequencer mode is started immediately.

For details on sequential operation see "The Sequencer Concept" .

Remote command:

SYSTem:​SEQuencer

INITiate:​SEQuencer:​IMMediate

INITiate:​SEQuencer:​ABORt


Sequencer Mode

Realtime Application (R&S FSW-K160R) > Configuring and Performing Measurements in MSRT Mode > Performing a Measurement in MSRT Mode > Sequencer Mode
Sequencer Mode

Defines how often which measurements are performed. The currently selected mode softkey is highlighted blue. During an active Sequencer process, the selected mode softkey is highlighted orange.

For details on sequential operation see "Sequencer modes" .

"Single Sequence"

Each measurement is performed once, until all measurements in all active channels have been performed.

"Continuous Sequence"

The measurements in each active channel are performed one after the other, repeatedly, in the same order, until sequential operation is stopped.

This is the default Sequencer mode.

In MSRT mode, the behaviour of a continuous sequence depends on the trigger setting, see "Using the Sequencer in MSRT Mode".

Remote command:

INITiate:​SEQuencer:​MODE


Refresh All

Realtime Application (R&S FSW-K160R) > Configuring and Performing Measurements in MSRT Mode > Performing a Measurement in MSRT Mode > Refresh All
Refresh All

This function is only available if the Sequencer is deactivated, no sweep is currently running, and only in MSRA or MSRT mode.

The data in the capture buffer is re-evaluated by all active applications, for example after a new sweep was performed while the Sequencer was off.

Note: To update only the displays in the currently active application, use the "Refresh" function in the "Sweep" menu for that application (see "Refresh").

For details on the MSRA operating mode see "Welcome to the MSRA Operating Mode" .

For details on the MSRT operating mode see "Welcome to the R&S FSW Realtime Extension".

Remote command:

INITiate:​SEQuencer:​REFResh[:​ALL]


Refresh

Realtime Application (R&S FSW-K160R) > Configuring and Performing Measurements in MSRT Mode > Performing a Measurement in MSRT Mode > Refresh
Refresh

This function is only available if the Sequencer is deactivated and only for MSRA or MSRT applications.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

This is useful, for example, after evaluation changes have been made or if a new sweep was performed from another application; in this case, only that application is updated automatically after data acquisition.

Note: To update all active applications at once, use the "Refresh all" function in the "Sequencer" menu.
(See "Refresh All").

Remote command:

INITiate:​REFResh


Analysis

Realtime Application (R&S FSW-K160R) > Analysis
Analysis

Specific result configuration for persistence and spectrogram or waterfall displays, as well as general result analysis settings concerning the trace, markers, windows etc. can be configured via the "Analysis" button in the "Overview".

Contents
  • Display Configuration
  • Persistence Spectrum Settings
  • Spectrogram and PVT Waterfall Settings
  • Color Map Settings
  • Trace Settings
  • Trace / Data Export Configuration
  • Trace Math
  • Marker Settings
  • Limit Line Settings and Functions
  • Zoom Functions
  • Analysis in MSRT Applications


Display Configuration

Realtime Application (R&S FSW-K160R) > Analysis > Display Configuration
Display Configuration

The captured signal can be displayed using various evaluation methods. All evaluation methods available for the Realtime Spectrum application are displayed in the evaluation bar in SmartGrid mode when you do one of the following:

  • Select the [image] "SmartGrid" icon from the toolbar.
  • Select the "Display Config" button in the "Overview".
  • In the "Realtime Config" or "Meas" menu, select the "Display Config" softkey.

Up to 6 evaluation methods can be displayed simultaneously in separate windows. The realtime evaluation methods are described in "Measurements and Result Displays".

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .


Persistence Spectrum Settings

Realtime Application (R&S FSW-K160R) > Analysis > Persistence Spectrum Settings
Persistence Spectrum Settings

The persistence spectrum is highly configurable. You can change the colors with which the densities are visualized, the persistence of the data, and the style of the displayed results.

└ Diagram Style
└ Persistence
└ Granularity
└ Configuring the Maxhold Function
└ Intensity
└ Resetting the Maxhold Function
└ Color Mapping


Diagram Style

Realtime Application (R&S FSW-K160R) > Analysis > Persistence Spectrum Settings > Diagram Style
Diagram Style

The persistence spectrum can be displayed using vectors or dots.

For details see "Trace style".

"Vectors" | Using vectors, the individual points - and thus the densities - are interpolated. The result is a persistence spectrum that contains no gaps between coordinates. Each point of the histogram is connected to the neighboring ones.
"Dots" | Using dots, only those coordinates are displayed for which data has actually been measured. The result is a histogram made up out of individual points.
Remote command:

DISPlay:​WINDow:​[SUBWindow:​]TRACe:​SYMBol


Persistence

Realtime Application (R&S FSW-K160R) > Analysis > Persistence Spectrum Settings > Persistence
Persistence

Persistence defines the duration that shadows of past histogram traces remain visible in the display before fading away.

The number of traces that are considered when calculating the density depends on this persistence length.

For low persistence values, the density colors change quickly in the persistence spectrogram.

For high persistence values, the colors change slowly.

A value of 0 seconds deactivates persistence.

For details see "Understanding Persistence".

Remote command:

DISPlay:​WINDow:​[SUBWindow:​]TRACe:​PERSistence:​DURation


Granularity

Realtime Application (R&S FSW-K160R) > Analysis > Persistence Spectrum Settings > Granularity
Granularity

Defines the amount of data that the R&S FSW uses to draw a single frame in the persistence spectrum. By default, the moving density of the data that was captured in 100 ms is displayed for each frame.

For details see "Persistence Granularity".

Remote command:

DISPlay:​WINDow:​[SUBWindow:​]TRACe:​PERSistence:​GRANularity


Configuring the Maxhold Function

Realtime Application (R&S FSW-K160R) > Analysis > Persistence Spectrum Settings > Configuring the Maxhold Function
Configuring the Maxhold Function

The maxhold function remembers and shows the maximum densities that have been measured at each point in the diagram.

If activated, the maximum values from all past sweeps are indicated in the persistence spectrum, together with the measured values from the current sweep.

Note: Setting the "Intensity" to 0 has the same effect as deactivating the Maxhold function.

For details see "Analyzing Maximum Density - Maxhold Trace".

Remote command:

DISPlay:​WINDow:​[SUBWindow:​]TRACe:​MAXHold[:​STATe]

└ Intensity
└ Resetting the Maxhold Function


Intensity

Realtime Application (R&S FSW-K160R) > Analysis > Persistence Spectrum Settings > Configuring the Maxhold Function > Intensity
Intensity

The maximum values (that is, the maxhold trace) are displayed in the defined intensity. The higher the intensity, the brighter the maximum values are displayed. With maximum intensity, the maximum values are displayed just as bright as the currently measured values.

Note: Setting the intensity to 0 has the same effect as deactivating the Maxhold function.

To change the intensity, move the slider to the left (weaker) or right (stronger).

Note that while the intensity of the maxhold trace may differ to the currently measured trace, the color mapping is the same for both traces.

For details see "Analyzing Maximum Density - Maxhold Trace".

Remote command:

DISPlay:​WINDow:​[SUBWindow:​]TRACe:​MAXHold:​INTensity


Resetting the Maxhold Function

Realtime Application (R&S FSW-K160R) > Analysis > Persistence Spectrum Settings > Configuring the Maxhold Function > Resetting the Maxhold Function
Resetting the Maxhold Function

The previous results of the maxhold function are cleared and the function starts determining new maximum values.

For details see "Analyzing Maximum Density - Maxhold Trace".

Remote command:

DISPlay:​WINDow:​[SUBWindow:​]TRACe:​MAXHold:​RESet


Color Mapping

Realtime Application (R&S FSW-K160R) > Analysis > Persistence Spectrum Settings > Color Mapping
Color Mapping

Opens the "Color Map" dialog.

For details see "Color Map Settings".


Spectrogram and PVT Waterfall Settings

Realtime Application (R&S FSW-K160R) > Analysis > Spectrogram and PVT Waterfall Settings
Spectrogram and PVT Waterfall Settings

The individual settings available for spectrogram and waterfall displays are described here. For settings on color mapping, see "Color Map Settings".

└ History Depth
└ Time Stamp
└ Selecting a frame to display
└ Clear Spectrogram
└ Clear Power vs Time Waterfall
└ Color Mapping


History Depth

Realtime Application (R&S FSW-K160R) > Analysis > Spectrogram and PVT Waterfall Settings > History Depth
History Depth

Sets the number of frames that the R&S FSW stores in its memory. The maximum history depth is 100.000 frames.

If the memory is full, the R&S FSW deletes the oldest frames stored in the memory and replaces them with the new data.

Remote command:

CALCulate<n>:​SGRam|SPECtrogram:​HDEPth


Time Stamp

Realtime Application (R&S FSW-K160R) > Analysis > Spectrogram and PVT Waterfall Settings > Time Stamp
Time Stamp

Activates and deactivates the time stamp. If activated (default), the time stamp shows the system time while the measurement is running. In single sweep mode or if the sweep is stopped, the time stamp shows the time and date at the end of the sweep.

Individual frames are referred to by their time difference to the end of the sweep.

If deactivated, individual frames are referred to by their frame number in the spectrogram and waterfall diagrams.

For details see "Time stamps vs index".

Remote command:

CALCulate<n>:​SGRam|SPECtrogram:​TSTamp[:​STATe]

CALCulate<n>:​SGRam|SPECtrogram:​TSTamp:​DATA?


Selecting a frame to display

Realtime Application (R&S FSW-K160R) > Analysis > Spectrogram and PVT Waterfall Settings > Selecting a frame to display
Selecting a frame to display

Selects a specific frame, loads the corresponding trace from the memory, and displays it in the Realtime Spectrum or Power vs Time window.

Different frames can be displayed in the Realtime Spectrum and Power vs Time windows.

Note that activating a marker or changing the position of the active marker automatically selects the frame that belongs to that marker.

This function is only available in single sweep mode or if the sweep is stopped.

The most recent frame is number 0, all previous frames have a negative number.

For more information see "Time Frames".

Remote command:

CALCulate<n>:​SGRam|SPECtrogram:​FRAMe:​SELect


Clear Spectrogram

Realtime Application (R&S FSW-K160R) > Analysis > Spectrogram and PVT Waterfall Settings > Clear Spectrogram
Clear Spectrogram

Resets the spectrogram result display and clears the history buffer.

This function is only available if a spectrogram is selected.

Remote command:

CALCulate<n>:​SGRam|SPECtrogram:​CLEar[:​IMMediate]


Clear Power vs Time Waterfall

Realtime Application (R&S FSW-K160R) > Analysis > Spectrogram and PVT Waterfall Settings > Clear Power vs Time Waterfall
Clear Power vs Time Waterfall

Resets the Power vs Time Waterfall result display and clears the history buffer.

Remote command:

CALCulate<n>:​SGRam|SPECtrogram:​CLEar[:​IMMediate]


Color Mapping

Realtime Application (R&S FSW-K160R) > Analysis > Spectrogram and PVT Waterfall Settings > Color Mapping
Color Mapping

Opens the "Color Map" dialog.

For details see "Color Map Settings".


Color Map Settings

Realtime Application (R&S FSW-K160R) > Analysis > Color Map Settings
Color Map Settings

The settings for color maps are displayed in the "Color Mapping" dialog box that is displayed when you select a spectrogram, persistence spectrum, or waterfall display and then do one of the following:

  • In the "Realtime Config" menu, select the "Color Mapping" softkey.
  • In the "Traces" dialog box, in the "Spectrogram/Waterfall" tab or "Persistence" tab, select the "Color Mapping" button.
  • In the spectrogram, persistence spectrum, or waterfall display, tap the color map.

For more information on color maps see "Color Maps".

For details on changing color map settings see "How to Configure the Color Mapping".

In addition to the available color settings, the dialog box displays the current color map and provides a preview of the display with the current settings.

Color Mapping dialog box
1 = Color map: shows the current color distribution
2 = Preview pane: shows a preview of the diagram with any changes that you make to the color scheme
3 = Color curve pane: graphical representation of all settings available to customize the color scheme
4/5 = Color range start and stop sliders: define the range of the color map or amplitudes for the spectrogram
6 = Color curve slider: adjusts the focus of the color curve
7 = Histogram: shows the distribution of measured values
8 = Scale of the horizontal axis (value range)
└ Start / Stop
└ Shape
└ Truncate
└ Hot/Cold/Radar/Grayscale
└ Auto
└ Set to Default


Start / Stop

Realtime Application (R&S FSW-K160R) > Analysis > Color Map Settings > Start / Stop
Start / Stop

Defines the lower and upper boundaries of the value range of the diagram.

For details see "Color Maps" .

Remote command:

DISPlay[:​WINDow<n>]:​SGRam|SPECtrogram:​COLor:​LOWer

DISPlay[:​WINDow<n>]:​SGRam|SPECtrogram:​COLor:​UPPer

DISPlay:​WINDow:​PSPectrum:​COLor:​LOWer

DISPlay:​WINDow:​PSPectrum:​COLor:​UPPer


Shape

Realtime Application (R&S FSW-K160R) > Analysis > Color Map Settings > Shape
Shape

Defines the shape and focus of the color curve for the spectrogram result display.

For details see "Color Maps" .

"-1 to <0" | More colors are distributed among the lower values
"0" | Colors are distributed linearly among the values
">0 to 1" | More colors are distributed among the higher values
Remote command:

DISPlay[:​WINDow<n>]:​SGRam|SPECtrogram:​COLor:​SHAPe

DISPlay:​WINDow:​PSPectrum:​COLor:​SHAPe


Truncate

Realtime Application (R&S FSW-K160R) > Analysis > Color Map Settings > Truncate
Truncate

This command is available for Persistence Spectrum only.

By default, results that are smaller than the start value of the color map range are displayed in the color for the minimum value. Results that are larger than the stop value of the color map range are displayed in the color for the maximum value.

If the "Truncate" function is activated, the results of the persistence spectrum outside the value range of the color map are truncated, that is, not displayed.

For details see "Color Maps" .

Remote command:

DISPlay:​WINDow:​PSPectrum:​COLor:​TRUNcate


Hot/Cold/Radar/Grayscale

Realtime Application (R&S FSW-K160R) > Analysis > Color Map Settings > Hot/Cold/Radar/Grayscale
Hot/Cold/Radar/Grayscale

Sets the color scheme for the spectrogram.

For details see "Color Maps" .

Remote command:

DISPlay[:​WINDow<n>]:​SGRam|SPECtrogram:​COLor[:​STYLe]

DISPlay:​WINDow:​PSPectrum:​COLor[:​STYLe]


Auto

Realtime Application (R&S FSW-K160R) > Analysis > Color Map Settings > Auto
Auto

Defines the color range automatically according to the existing measured values for optimized display.


Set to Default

Realtime Application (R&S FSW-K160R) > Analysis > Color Map Settings > Set to Default
Set to Default

Sets the color map to the default settings.

Remote command:

DISPlay[:​WINDow<n>]:​SGRam|SPECtrogram:​COLor:​DEFault

DISPlay:​WINDow:​PSPectrum:​COLor:​DEFault


Trace Settings

Realtime Application (R&S FSW-K160R) > Analysis > Trace Settings
Trace Settings

The trace settings determine how the measured data is analyzed and displayed in the window. Depending on the result display, between 1 and 4 traces may be displayed.

Trace settings can be configured via the TRACE key, in the "Traces" dialog box, or in the vertical "Traces" tab of the "Analysis" dialog box.

Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box (see "Specifics for").

Trace data can also be exported to an ASCII file for further analysis. For details see "Trace / Data Export Configuration".

└ Trace 1/Trace 2/Trace 3/Trace 4
└ Mode
└ Detector
└ Hold
└ Average Count
└ Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)
└ Copy Trace


Trace 1/Trace 2/Trace 3/Trace 4

Realtime Application (R&S FSW-K160R) > Analysis > Trace Settings > Trace 1/Trace 2/Trace 3/Trace 4
Trace 1/Trace 2/Trace 3/Trace 4

Selects the corresponding trace for configuration. The currently selected trace is highlighted orange.

For details see "How to Configure a Standard Trace" .

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>[:​STATe]

Selected via numeric suffix of TRACe<t> commands


Mode

Realtime Application (R&S FSW-K160R) > Analysis > Trace Settings > Mode
Mode

Defines the update mode for subsequent traces.

For details see "Analyzing Several Traces - Trace Mode" .

"Clear Write" | Overwrite mode: the trace is overwritten by each sweep. This is the default setting.
"Max Hold" | The maximum value is determined over several sweeps and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is greater than the previous one.
"Min Hold" | The minimum value is determined over several sweeps and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is greater than the previous one.
"View" | The current contents of the trace memory are frozen and displayed.
"Blank" | Removes the selected trace from the display.
Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE


Detector

Realtime Application (R&S FSW-K160R) > Analysis > Trace Settings > Detector
Detector

Defines the trace detector to be used for trace analysis.

Detectors perform a data reduction from the swept values to the displayed trace points. The detector type determines which of the samples are displayed for each trace point.

Note: The detector activated for the specific trace is indicated in the corresponding trace information in the window title bar by an abbreviation.

The trace detector can analyze the measured data using various methods:

"Positive Peak"

Determines the largest of all positive peak values from the levels measured at the individual x-values which are displayed in one trace point

"Negative Peak"

Determines the smallest of all negative peak values from the levels measured at the individual x-values which are displayed in one trace point

"Average"

Calculates the linear average of all samples contained in a sweep point.

To this effect, R&S FSW uses the linear voltage after envelope detection. The sampled linear values are summed up and the sum is divided by the number of samples (= linear average value). Each sweep point thus corresponds to the average of the measured values summed up in the sweep point.

The average detector supplies the average value of the signal irrespective of the waveform (CW carrier, modulated carrier, white noise or impulsive signal).

"Sample"

Selects the last measured value of the levels measured at the individual x-values which are displayed in one trace point; all other measured values for the x-axis range are ignored

Remote command:

[SENSe:​][WINDow:​]DETector<t>[:​FUNCtion]


Hold

Realtime Application (R&S FSW-K160R) > Analysis > Trace Settings > Hold
Hold

If activated, traces in "Min Hold", "Max Hold" and "Average" mode are not reset after specific parameter changes have been made.

Normally, the measurement is started anew after parameter changes, before the measurement results are analyzed (e.g. using a marker). In all cases that require a new measurement after parameter changes, the trace is reset automatically to avoid false results (e.g. with span changes). For applications that require no reset after parameter changes, the automatic reset can be switched off.

The default setting is off.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE:​HCONtinuous


Average Count

Realtime Application (R&S FSW-K160R) > Analysis > Trace Settings > Average Count
Average Count

Determines the number of averaging or maximum search procedures If the trace modes "Average", "Max Hold" or "Min Hold" are set.

In continuous sweep mode, if sweep count = 0 (default), averaging is performed over 10 sweeps. For sweep count =1, no averaging, maxhold or minhold operations are performed.

Remote command:

[SENSe:​]AVERage:​COUNt


Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)

Realtime Application (R&S FSW-K160R) > Analysis > Trace Settings > Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)
Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)

Displays the "Traces" settings and focuses the "Mode" list for the selected trace.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>[:​STATe]


Copy Trace

Realtime Application (R&S FSW-K160R) > Analysis > Trace Settings > Copy Trace
Copy Trace

The "Copy Trace" softkey opens the "Copy Trace" tab of the "Trace Configuration" dialog box.

The "Copy Trace" tab contains functionality to copy trace data to another trace.

The first group of buttons (labelled "Trace 1" to "Trace 4") select the source trace. The second group of buttons (labelled "Copy to Trace 1" to "Copy to Trace 4") select the destination.

Remote command:

TRACe<n>:​COPY


Trace / Data Export Configuration

Realtime Application (R&S FSW-K160R) > Analysis > Trace / Data Export Configuration
Trace / Data Export Configuration

The standard data management functions (e.g. saving or loading instrument settings) that are available for all R&S FSW applications are not described here.

See "Data Management" for a description of the standard functions.

For step-by-step instructions on how to export a trace, see "How to Export Trace Data" .

└ Export all Traces and all Table Results
└ Include Instrument Measurement Settings
└ Trace to Export
└ Decimal Separator
└ Export Trace to ASCII File


Export all Traces and all Table Results

Realtime Application (R&S FSW-K160R) > Analysis > Trace / Data Export Configuration > Export all Traces and all Table Results
Export all Traces and all Table Results

Selects all displayed traces and result tables (e.g. Result Summary, marker table etc.) in the current application for export to an ASCII file.

Alternatively, you can select one specific trace only for export (see "Trace to Export").

The results are output in the same order as they are displayed on the screen: window by window, trace by trace, and table row by table row.

Remote command:

FORMat:​DEXPort:​TRACes


Include Instrument Measurement Settings

Realtime Application (R&S FSW-K160R) > Analysis > Trace / Data Export Configuration > Include Instrument Measurement Settings
Include Instrument Measurement Settings

Includes additional instrument and measurement settings in the header of the export file for result data.

Remote command:

FORMat:​DEXPort:​HEADer


Trace to Export

Realtime Application (R&S FSW-K160R) > Analysis > Trace / Data Export Configuration > Trace to Export
Trace to Export

Defines an individual trace that will be exported to a file.

This setting is not available if "Export all Traces and all Table Results" is selected.


Decimal Separator

Realtime Application (R&S FSW-K160R) > Analysis > Trace / Data Export Configuration > Decimal Separator
Decimal Separator

Defines the decimal separator for floating-point numerals for the data export files. Evaluation programs require different separators in different languages.

Remote command:

FORMat:​DEXPort:​DSEParator


Export Trace to ASCII File

Realtime Application (R&S FSW-K160R) > Analysis > Trace / Data Export Configuration > Export Trace to ASCII File
Export Trace to ASCII File

Opens a file selection dialog box and saves the selected trace in ASCII format (.dat) to the specified file and directory.

The results are output in the same order as they are displayed on the screen: window by window, trace by trace, and table row by table row.

If the spectrogram display is selected when you perform this function, the entire histogram buffer with all frames is exported to a file. The data corresponding to a particular frame begins with information about the frame number and the time that frame was recorded. For large history buffers the export operation may take some time.

Note: Secure user mode.

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Remote command:

MMEMory:​STORe<n>:​TRACe


Trace Math

Realtime Application (R&S FSW-K160R) > Analysis > Trace Math
Trace Math

Trace math settings can be configured via the TRACE key, in the "Trace Math" tab of the "Traces" dialog box.

└ Trace Math Function
└ Trace Math Off
└ Trace Math Position
└ Trace Math Mode


Trace Math Function

Realtime Application (R&S FSW-K160R) > Analysis > Trace Math > Trace Math Function
Trace Math Function

Defines which trace is subtracted from trace 1. The result is displayed in trace 1 and refers to the zero point defined with the "Trace Math Position" setting. The following subtractions can be performed:

"T1-T2 -> T1" | Subtracts trace 2 from trace 1.
"T1-T3 -> T1" | Subtracts trace 3 from trace 1
"T1-T4 -> T1" | Subtracts trace 4 from trace 1

To switch off the trace math, use the "Trace Math Off" button.

Remote command:

CALCulate<n>:​MATH[:​EXPression][:​DEFine]

CALCulate<n>:​MATH:​STATe


Trace Math Off

Realtime Application (R&S FSW-K160R) > Analysis > Trace Math > Trace Math Off
Trace Math Off

Deactivates any previously selected trace math functions.

Remote command:

CALC:MATH:STAT OFF, see CALCulate<n>:​MATH:​STATe


Trace Math Position

Realtime Application (R&S FSW-K160R) > Analysis > Trace Math > Trace Math Position
Trace Math Position

Defines the zero point on the y-axis of the resulting trace in % of the diagram height. The range of values extends from -100 % to +200 %.

Remote command:

CALCulate<n>:​MATH:​POSition


Trace Math Mode

Realtime Application (R&S FSW-K160R) > Analysis > Trace Math > Trace Math Mode
Trace Math Mode

Defines the mode for the trace math calculations.

"Lin"

Activates linear subtraction, which means that the power level values are converted into linear units prior to subtraction. After the subtraction, the data is converted back into its original unit.

This setting takes effect if the grid is set to a linear scale. In this case, subtraction is done in two ways (depending on the set unit):

  • The unit is set to either W or dBm: the data is converted into W prior to subtraction, i.e. averaging is done in W.
  • The unit is set to either V, A, dBmV, dBµV, dBµA or dBpW: the data is converted into V prior to subtraction, i.e. subtraction is done in V.

"Log"

Activates logarithmic subtraction.

This subtraction method only takes effect if the grid is set to a logarithmic scale, i.e. the unit of the data is dBm. In this case the values are subtracted in dBm. Otherwise (i.e. with linear scaling) the behavior is the same as with linear subtraction.

"Power"

Activates linear power subtraction.

The power level values are converted into unit Watt prior to subtraction. After the subtraction, the data is converted back into its original unit.

Unlike the linear mode, the subtraction is always done in W.

Remote command:

CALCulate<n>:​MATH:​MODE


Marker Settings

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings
Marker Settings

Marker settings can be configured via the MARKER key or in the "Marker" dialog box. To display the "Marker" dialog box, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker" tab.

The marker "Search" settings are described in "Marker Search Settings and Positioning Functions" .

Contents
  • Individual Marker Setup
  • General Marker Settings
  • Marker Search Settings and Positioning Functions


Individual Marker Setup

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Individual Marker Setup
Individual Marker Setup

Up to 17 markers or delta markers can be activated for each window simultaneously. Initial marker setup is performed using the "Marker" dialog box.

The markers are distributed among 3 tabs for a better overview. By default, the first marker is defined as a normal marker, whereas all others are defined as delta markers with reference to the first marker. All markers are assigned to trace 1, but only the first marker is active.

└ Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta
└ Selected Marker
└ Marker State
└ Marker Position (X-value)
└ Marker Level (Y-value)
└ Frame
└ Marker Type
└ Reference Marker
└ Assigning the Marker to a Trace
└ Select Marker
└ All Markers Off


Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Individual Marker Setup > Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta
Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta

The "Marker X" softkey activates the corresponding marker and opens an edit dialog box to enter the marker position ("X-value"). Pressing the softkey again deactivates the selected marker.

Marker 1 is always the default reference marker for relative measurements. If activated, markers 2 to 16 are delta markers that refer to marker 1. These markers can be converted into markers with absolute value display using the "Marker Type" function.

Several markers can be configured very easily using the "Marker" dialog box, see "Marker Settings" .

Note: If normal marker 1 is the active marker, pressing the "Mkr Type" softkey switches on an additional delta marker 1.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?

CALCulate<n>:​DELTamarker<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>:​X

CALCulate<n>:​DELTamarker<m>:​X:​RELative?

CALCulate<n>:​DELTamarker<m>:​Y?

In spectrogram display:

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​FRAMe

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​FRAMe


Selected Marker

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Individual Marker Setup > Selected Marker
Selected Marker

Marker name. The marker which is currently selected for editing is highlighted orange.

Remote command:

Marker selected via suffix <m> in remote commands.


Marker State

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Individual Marker Setup > Marker State
Marker State

Activates or deactivates the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Marker Position (X-value)

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Individual Marker Setup > Marker Position (X-value)
Marker Position (X-value)

Defines the position (x-value) of the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​DELTamarker<m>:​X


Marker Level (Y-value)

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Individual Marker Setup > Marker Level (Y-value)
Marker Level (Y-value)

Defines the level (y-value) of the marker in the Persistence Spectrum diagram.

Remote command:

CALCulate<n>:​MARKer<m>:​Y?

CALCulate<n>:​DELTamarker<m>:​Y?


Frame

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Individual Marker Setup > Frame
Frame

Spectrogram frame number the marker is assigned to. The most recently swept frame is number 0, all previous frames have negative numbers.

Remote command:

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​FRAMe


Marker Type

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Individual Marker Setup > Marker Type
Marker Type

Toggles the marker type.

The type for marker 1 is always "Normal", the type for delta marker 1 is always "Delta". These types cannot be changed.

Note: If normal marker 1 is the active marker, switching the "Mkr Type" activates an additional delta marker 1. For any other marker, switching the marker type does not activate an additional marker, it only switches the type of the selected marker.

"Normal" | A normal marker indicates the absolute value at the defined position in the diagram.
"Delta" | A delta marker defines the value of the marker relative to the specified reference marker (marker 1 by default).
Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Reference Marker

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Individual Marker Setup > Reference Marker
Reference Marker

Defines a marker as the reference marker which is used to determine relative analysis results (delta marker values).

Remote command:

CALCulate<n>:​DELTamarker<m>:​MREF


Assigning the Marker to a Trace

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Individual Marker Setup > Assigning the Marker to a Trace
Assigning the Marker to a Trace

The "Trace" setting assigns the selected marker to an active trace. The trace determines which value the marker shows at the marker position. If the marker was previously assigned to a different trace, the marker remains on the previous frequency or time, but indicates the value of the new trace.

Note: Markers in the persistence spectrum. In the persistence spectrum result display, you can place each marker either on the current persistence trace or the maxhold trace, if it is active.

If a trace is turned off, the assigned markers and marker functions are also deactivated.

Remote command:

CALCulate<n>:​MARKer<m>:​TRACe


Select Marker

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Individual Marker Setup > Select Marker
Select Marker

Opens a dialog box to select and activate or deactivate one or more markers quickly.

Remote command:

Marker selected via suffix <m> in remote commands.


All Markers Off

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Individual Marker Setup > All Markers Off
All Markers Off

Deactivates all markers in one step.

Remote command:

CALCulate<n>:​MARKer<m>:​AOFF


General Marker Settings

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > General Marker Settings
General Marker Settings

Some general marker settings allow you to influence the marker behavior for all markers.

These settings are located in the "Marker Settings" tab of the "Marker" dialog box. To display this tab, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey. Then select the horizontal "Marker Settings" tab.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker" tab. Then select the horizontal "Marker Settings" tab.
└ Marker Table Display
└ Marker Stepsize


Marker Table Display

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > General Marker Settings > Marker Table Display
Marker Table Display

Defines how the marker information is displayed.

For more details see "Marker Results" .

"On" | Displays the marker information in a table in a separate area beneath the diagram.
"Off" | Displays the marker information within the diagram area.
"Auto" | (Default) Up to two markers are displayed in the diagram area. If more markers are active, the marker table is displayed automatically.
Remote command:

DISPlay:​MTABle


Marker Stepsize

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > General Marker Settings > Marker Stepsize
Marker Stepsize

Defines the size of the steps that the marker position is moved using the rotary knob.

"Standard" | The marker position is moved from pixel to pixel on the display. This setting is most suitable to move the marker over a larger distance.
"Sweep Points" | The marker position is moved from one sweep point to the next. This setting is required for a very precise positioning if more sweep points are collected than the number of pixels that can be displayed on the screen. It is the default mode.
Remote command:

CALCulate:​MARKer:​X:​SSIZe


Marker Search Settings and Positioning Functions

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions
Marker Search Settings and Positioning Functions

Several functions are available to set the marker to a specific position very quickly and easily, or to use the current marker position to define another characteristic value. In order to determine the required marker position, searches may be performed. The search results can be influenced by special settings.

For more information on searching for signal peaks see "Searching for Signal Peaks" .

Contents
  • Marker Search Settings
  • Positioning Functions


Marker Search Settings

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Marker Search Settings
Marker Search Settings

Spectrograms show not only the current sweep results, but also the sweep history. Thus, when searching for peaks, you must define the search settings within a single time frame (x-direction) and within several time frames (y-direction).

These settings are are available in the "Search Settings" tab of the "Marker" dialog box. To display this tab, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey. Then select the horizontal "Search Settings" tab.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Config" tab. Then select the horizontal "Search Settings" tab.
└ Search Mode for Next Peak in X Direction
└ Search Mode for Next Peak in Y Direction
└ Marker Search Type
└ Marker Search Area
└ Exclude LO
└ Peak Excursion
└ Auto Max / Min Peak Search
└ Search Limits
└ Search Limits (Left / Right)
└ Search Threshold
└ Deactivating All Search Limits


Search Mode for Next Peak in X Direction

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Mode for Next Peak in X Direction
Search Mode for Next Peak in X Direction

Selects the search mode for the next peak search within the currently selected frame.

"Left" | Determines the next maximum/minimum to the left of the current peak.
"Absolute" | Determines the next maximum/minimum to either side of the current peak.
"Right" | Determines the next maximum/minimum to the right of the current peak.
Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum:​LEFT

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​MARKer<m>:​MAXimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MINimum:​LEFT

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​MARKer<m>:​MINimum:​RIGHt


Search Mode for Next Peak in Y Direction

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Mode for Next Peak in Y Direction
Search Mode for Next Peak in Y Direction

Selects the search mode for the next peak search within all frames at the current marker position.

This setting is only available for spectrogram displays.

"Up" | Determines the next maximum/minimum above the current peak (in more recent frames).
"Absolute" | Determines the next maximum/minimum above or below the current peak (in all frames).
"Down" | Determines the next maximum/minimum below the current peak (in older frames).
Remote command:

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​Y:​MAXimum:​ABOVe

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​Y:​MAXimum:​ABOVe

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​Y:​MAXimum:​BELow

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​Y:​MAXimum:​BELow

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​Y:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​Y:​MAXimum:​NEXT

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​Y:​MINimum:​ABOVe

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​Y:​MINimum:​ABOVe

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​Y:​MINimum:​BELow

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​Y:​MINimum:​BELow

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​Y:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​Y:​MINimum:​NEXT


Marker Search Type

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Marker Search Settings > Marker Search Type
Marker Search Type

Defines the type of search to be performed in the spectrogram.

"X-Search" | Searches only within the currently selected frame.
"Y-Search" | Searches within all frames but only at the current marker position.
"XY-Search" | Searches in all frames at all positions.
Remote command:

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​XY:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​XY:​MAXimum[:​PEAK]

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​XY:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​XY:​MINimum[:​PEAK]

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​Y:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​Y:​MAXimum[:​PEAK]

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​Y:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​Y:​MINimum[:​PEAK]

CALCulate<n>:​MARKer<m>:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MAXimum[:​PEAK]

CALCulate<n>:​MARKer<m>:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MINimum[:​PEAK]


Marker Search Area

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Marker Search Settings > Marker Search Area
Marker Search Area

Defines which frames the search is performed in.

This setting is only available for spectrogram displays.

"Visible" | Only the visible frames are searched.
"Memory" | All frames stored in the memory are searched.
Remote command:

CALCulate<n>:​MARKer:​SGRam|SPECtrogram:​SARea

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​SARea


Exclude LO

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Marker Search Settings > Exclude LO
Exclude LO

If activated, restricts the frequency range for the marker search functions.

"ON" | The minimum frequency included in the peak search range is ≥ 5 × resolution bandwidth (RBW). Due to the interference by the first local oscillator to the first intermediate frequency at the input mixer, the LO is represented as a signal at 0 Hz. To avoid the peak marker jumping to the LO signal at 0 Hz, this frequency is excluded from the peak search.
"OFF" | No restriction to the search range. The frequency 0 Hz is included in the marker search functions.
Remote command:

CALCulate:​MARKer:​LOEXclude


Peak Excursion

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Marker Search Settings > Peak Excursion
Peak Excursion

Defines the minimum level value by which a signal must rise or fall so that it will be identified as a maximum or a minimum by the search functions.

For more information see "Searching for Signal Peaks" .

Remote command:

CALCulate<n>:​MARKer:​PEXCursion


Auto Max / Min Peak Search

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Marker Search Settings > Auto Max / Min Peak Search
Auto Max / Min Peak Search

If activated, a maximum or minimum peak search is performed automatically for marker 1 after each sweep.

For spectrogram displays, define which frame the peak is to be searched in.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum:​AUTO

CALCulate<n>:​MARKer<m>:​MINimum:​AUTO


Search Limits

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Limits
Search Limits

The search results can be restricted by limiting the search area or adding search conditions.

└ Search Limits (Left / Right)
└ Search Threshold
└ Deactivating All Search Limits


Search Limits (Left / Right)

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Limits > Search Limits (Left / Right)
Search Limits (Left / Right)

If activated, limit lines are defined and displayed for the search. Only results within the limited search range are considered.

For details on limit lines for searches see "Peak search limits" .

Remote command:

CALCulate:​MARKer:​X:​SLIMits[:​STATe]

CALCulate:​MARKer:​X:​SLIMits:​LEFT

CALCulate:​MARKer:​X:​SLIMits:​RIGHT


Search Threshold

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Limits > Search Threshold
Search Threshold

Defines an absolute threshold as an additional condition for the peak search. Only peaks that exceed the threshold are detected.

Remote command:

CALCulate:​THReshold


Deactivating All Search Limits

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Limits > Deactivating All Search Limits
Deactivating All Search Limits

Deactivates the search range limits.

Remote command:

CALCulate:​MARKer:​X:​SLIMits[:​STATe]

CALCulate:​THReshold:​STATe


Positioning Functions

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Positioning Functions
Positioning Functions

The following functions set the currently selected marker to the result of a peak search or set other characteristic values to the current marker value. These functions are available as softkeys in the "Marker To" menu, which is displayed when you press the MKR -> key.

└ Select Marker
└ Peak Search
└ Search Next Peak
└ Search Minimum
└ Search Next Minimum
└ Center Frequency = Marker Frequency
└ Reference Level = Marker Level
└ Marker to Trigger


Peak Search

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Positioning Functions > Peak Search
Peak Search

Sets the selected marker/delta marker to the maximum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MAXimum[:​PEAK]


Search Next Peak

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Positioning Functions > Search Next Peak
Search Next Peak

Sets the selected marker/delta marker to the next (lower) maximum of the assigned trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT


Search Minimum

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Positioning Functions > Search Minimum
Search Minimum

Sets the selected marker/delta marker to the minimum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MINimum[:​PEAK]


Search Next Minimum

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Positioning Functions > Search Next Minimum
Search Next Minimum

Sets the selected marker/delta marker to the next (higher) minimum of the selected trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT


Center Frequency = Marker Frequency

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Positioning Functions > Center Frequency = Marker Frequency
Center Frequency = Marker Frequency

Sets the center frequency to the selected marker or delta marker frequency. A peak can thus be set as center frequency, for example to analyze it in detail with a smaller span.

This function is not available for zero span measurements.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​CENTer


Reference Level = Marker Level

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Positioning Functions > Reference Level = Marker Level
Reference Level = Marker Level

Sets the reference level to the selected marker level.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​REFerence


Marker to Trigger

Realtime Application (R&S FSW-K160R) > Analysis > Marker Settings > Marker Search Settings and Positioning Functions > Positioning Functions > Marker to Trigger
Marker to Trigger

Sets the marker directly on the most recent trigger event.

This function is only available for spectrograms, and only if a trigger event already occurred.

Remote command:

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​Y:​TRIGger


Limit Line Settings and Functions

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions
Limit Line Settings and Functions

Up to 8 limit lines can be displayed simultaneously in the R&S FSW. Many more can be stored on the instrument.

Contents
  • Limit Line Management
  • Limit Line Details


Limit Line Management

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Management
Limit Line Management

Limit lines are managed in the "Line Config" dialog box which is displayed when you press the LINES key and then "Lines Config" softkey.

For the limit line overview, the R&S FSW searches for all stored limit lines with the file extension .LIN in the limits subfolder of the main installation folder. The overview allows you to determine which limit lines are available and can be used for the current measurement.

For details on settings for individual lines see "Limit Line Details".

For more basic information on limit lines see "Basics on Limit Lines" .

For instructions on configuring and working with limit lines see "Defining Limit Lines" .

└ Name
└ Unit
└ Compatibility
└ Visibility
└ Traces to be Checked
└ Comment
└ Included Lines in Overview (View Filter)
└ Show lines for all modes
└ X-Offset
└ Y-Offset
└ Create New Line
└ Edit Line
└ Copy Line
└ Delete Line
└ Disable All Lines


Name

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Management > Name
Name

The name of the stored limit line.


Unit

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Management > Unit
Unit

The unit in which the y-values of the data points of the limit line are defined.


Compatibility

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Management > Compatibility
Compatibility

Indicates whether the limit line definition is compatible with the current measurement settings.

For more information on which conditions a limit line must fulfill to be compatible, see "Basics on Limit Lines" .


Visibility

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Management > Visibility
Visibility

Displays or hides the limit line in the diagram. Up to 8 limit lines can be visible at the same time. Inactive limit lines can also be displayed in the diagram.

Remote command:

CALCulate:​LIMit<k>:​LOWer:​STATe

CALCulate:​LIMit<k>:​UPPer:​STATe

CALCulate:​LIMit:​ACTive


Traces to be Checked

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Management > Traces to be Checked
Traces to be Checked

Defines which traces are automatically checked for conformance with the limit lines. As soon as a trace to be checked is defined, the assigned limit line is active. One limit line can be activated for several traces simultaneously. If any of the "Traces to be Checked" violate any of the active limit lines, a message is indicated in the diagram.

Remote command:

CALCulate:​LIMit<k>:​TRACe<t>:​CHECk


Comment

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Management > Comment
Comment

An optional description of the limit line.


Included Lines in Overview (View Filter)

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Management > Included Lines in Overview (View Filter)
Included Lines in Overview (View Filter)

Defines which of the stored lines are included in the overview.

"Show compatible"

Only compatible lines

Whether a line is compatible or not is indicated in the "Compatibility" setting.

For more information on which conditions a limit line must fulfill to be compatible, see "Basics on Limit Lines" .

"Show all"

All stored limit lines with the file extension .LIN in the limits subfolder of the main installation folder (if not restricted by "Show lines for all modes" setting).

└ Show lines for all modes


Show lines for all modes

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Management > Included Lines in Overview (View Filter) > Show lines for all modes
Show lines for all modes

If activated (default), limit lines from all applications are displayed. Otherwise, only lines that were created in the Spectrum application are displayed.

Note that limit lines from some applications may include additional properties that are lost when the limit lines are edited in the Spectrum application. In this case a warning is displayed when you try to store the limit line.


X-Offset

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Management > X-Offset
X-Offset

Shifts a limit line that has been specified for relative frequencies or times (x-axis) horizontally.

This setting does not have any effect on limit lines that are defined by absolute values for the x-axis.

Remote command:

CALCulate:​LIMit<k>:​CONTrol:​OFFSet


Y-Offset

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Management > Y-Offset
Y-Offset

Shifts a limit line that has relative values for the y-axis (levels or linear units such as volt) vertically.

This setting does not have any effect on limit lines that are defined by absolute values for the y-axis.

Remote command:

CALCulate:​LIMit<k>:​LOWer:​OFFSet

CALCulate:​LIMit<k>:​UPPer:​OFFSet


Create New Line

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Management > Create New Line
Create New Line

Creates a new limit line.

For instructions see "How to configure a new limit line" .


Edit Line

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Management > Edit Line
Edit Line

Edit an existing limit line configuration.

For instructions see "How to edit existing limit lines" .


Copy Line

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Management > Copy Line
Copy Line

Copy the selected limit line configuration to create a new line.

For instructions see "How to edit existing limit lines" .

Remote command:

CALCulate:​LIMit<k>:​COPY


Delete Line

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Management > Delete Line
Delete Line

Delete the selected limit line configuration.

For instructions see "How to edit existing limit lines" .

Remote command:

CALCulate:​LIMit<k>:​DELete


Disable All Lines

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Management > Disable All Lines
Disable All Lines

Disable all limit lines in one step.

Remote command:

CALCulate:​LIMit<k>:​STATe


Limit Line Details

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Details
Limit Line Details

Limit lines details are configured in the "Edit Line Line" dialog box which is displayed when you select the "New", "Edit" or "Copy To" buttons in the "Line Config" dialog box.

└ Name
└ Comment
└ Threshold
└ Margin
└ X-Axis
└ Y-Axis
└ Data points
└ Insert Value
└ Delete Value
└ Shift x
└ Shift y
└ Save


Name

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Details > Name
Name

Defines the limit line name. All names must be compatible with Windows conventions for file names. The limit line data is stored under this name (with a .LIN extension).

Remote command:

CALCulate:​LIMit<k>:​NAME


Comment

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Details > Comment
Comment

Defines an optional comment for the limit line. The text may contain up to 40 characters.

Remote command:

CALCulate:​LIMit:​COMMent


Threshold

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Details > Threshold
Threshold

Defines an absolute threshold value (only for relative scaling of the y-axis).

For details on thresholds see "Basics on Limit Lines" .

Remote command:

CALCulate:​LIMit<k>:​LOWer:​THReshold

CALCulate:​LIMit<k>:​UPPer:​THReshold


Margin

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Details > Margin
Margin

Defines a margin for the limit line. The default setting is 0 dB (i.e. no margin).

For details on margins see "Basics on Limit Lines" .

Remote command:

CALCulate:​LIMit<k>:​LOWer:​MARGin

CALCulate:​LIMit<k>:​UPPer:​MARGin


X-Axis

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Details > X-Axis
X-Axis

Describes the horizontal axis on which the data points of the limit line are defined. Includes the following settings:

  • Domain:
    – "Hz": for frequency domain
    – "s": for time domain
  • Scaling mode: absolute or relative (Hz/s/%) values
    For relative values, the frequencies are referred to the currently set center frequency. In the zero span mode, the left boundary of the diagram is used as the reference.
  • Scaling: linear or logarithmic
Remote command:

CALCulate:​LIMit<k>:​LOWer:​SPACing

CALCulate:​LIMit<k>:​UPPer:​SPACing

CALCulate:​LIMit<k>:​LOWer:​MODE

CALCulate:​LIMit<k>:​UPPer:​MODE

CALCulate:​LIMit<k>:​CONTrol:​DOMain


Y-Axis

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Details > Y-Axis
Y-Axis

Describes the vertical axis on which the data points of the limit line are defined. Includes the following settings:

  • Level unit
  • Scaling mode: absolute or relative (dB/%) values
    Relative limit values refer to the reference level.
  • Limit type: upper or lower limit; values must stay above the lower limit and below the upper limit to pass the limit check
Remote command:

CALCulate:​LIMit<k>:​UNIT

CALCulate:​LIMit<k>:​LOWer:​SPACing

CALCulate:​LIMit<k>:​UPPer:​SPACing


Data points

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Details > Data points
Data points

Each limit line is defined by a minimum of 2 and a maximum of 200 data points. Each data point is defined by its position (x-axis) and value (y-value). Data points must be defined in ascending order. The same position can have two different values.

Remote command:

CALCulate:​LIMit<k>:​CONTrol[:​DATA]

CALCulate:​LIMit<k>:​LOWer[:​DATA]

CALCulate:​LIMit<k>:​UPPer[:​DATA]


Insert Value

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Details > Insert Value
Insert Value

Inserts a data point in the limit line above the selected one in the "Edit Limit Line" dialog box.


Delete Value

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Details > Delete Value
Delete Value

Deletes the selected data point in the "Edit Limit Line" dialog box.


Shift x

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Details > Shift x
Shift x

Shifts the x-value of each data point horizontally by the defined shift width (as opposed to an additive offset defined for the entire limit line, see "X-Offset").

Remote command:

CALCulate:​LIMit<k>:​CONTrol:​SHIFt


Shift y

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Details > Shift y
Shift y

Shifts the y-value of each data point vertically by the defined shift width (as opposed to an additive offset defined for the entire limit line, see "Y-Offset").

Remote command:

CALCulate:​LIMit<k>:​LOWer:​SHIFt

CALCulate:​LIMit<k>:​UPPer:​SHIFt


Save

Realtime Application (R&S FSW-K160R) > Analysis > Limit Line Settings and Functions > Limit Line Details > Save
Save

Saves the currently edited limit line under the name defined in the "Name" field.


Zoom Functions

Realtime Application (R&S FSW-K160R) > Analysis > Zoom Functions
Zoom Functions

The zoom functions are only available from the toolbar.

In realtime measurements, zooming is only available for spectrograms.

For details on the zoom functions see "Zooming into the Spectrogram".

└ Single Zoom
└ Restore Original Display
└ Deactivating Zoom (Selection mode)
└ Replay Zoom


Single Zoom

Realtime Application (R&S FSW-K160R) > Analysis > Zoom Functions > Single Zoom
Single Zoom

Define the zoom area by drawing a rectangle on the touchscreen. When you draw the zoom area, its boundaries are shown as a dashed line. The R&S FSW stops the realtime measurement and recalculates the displays for the area you have selected. The definition of the color map remains the same.

Note: In realtime measurements, this function is only available for an active spectrogram.
The graphical zoom provided for other measurements on the R&S FSW is not available for realtime measurements.

For details and restrictions see "Zooming into the Spectrogram".

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​AREA


Restore Original Display

Realtime Application (R&S FSW-K160R) > Analysis > Zoom Functions > Restore Original Display
Restore Original Display

Restores the original display, that is, the originally calculated displays for the entire capture buffer.

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe


Deactivating Zoom (Selection mode)

Realtime Application (R&S FSW-K160R) > Analysis > Zoom Functions > Deactivating Zoom (Selection mode)
Deactivating Zoom (Selection mode)

Deactivates zoom mode; tapping the screen no longer invokes a zoom, but selects an object.

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe


Replay Zoom

Realtime Application (R&S FSW-K160R) > Analysis > Zoom Functions > Replay Zoom
Replay Zoom

Switches between the zoomed displays and the original displays quickly for comparison.

If enabled, the zoomed displays are shown, that is, the recalculated displays for the selected zoom area.

If disabled, the original display is restored, that is, the originally calculated displays for the entire capture buffer.

This function is only available after a measurement has been performed.

For details see "Zooming into the Spectrogram".


Analysis in MSRT Applications

Realtime Application (R&S FSW-K160R) > Analysis > Analysis in MSRT Applications
Analysis in MSRT Applications

The data that was captured by the MSRT Master can be analyzed in various different applications.

The analysis settings and functions available in MSRT mode are those described for the individual applications. The MSRT Master is in effect a Realtime Spectrum application and has the same analysis functions and settings.

See "Analysis" for a description of the analysis functions and settings available for the Realtime Spectrum application and thus the MSRT Master.

Application data extract and analysis interval

The settings required to configure the application data extract or analysis intervals vary depending on the application. See the corresponding application manuals for details.

In addition, a "Capture Offset" is available to define the application data extract or analysis interval (see "Trigger Settings").

Analysis line settings

To hide or show and position the analysis line, a dialog box is available. To display the "Analysis Line" dialog box, tap the "AL" icon in the toolbar (only available in MSRT mode). The current position of the analysis line is indicated on the icon.

└ Position
└ Show Line


Position

Realtime Application (R&S FSW-K160R) > Analysis > Analysis in MSRT Applications > Position
Position

Defines the position of the analysis line in the time domain. The position must lie within the measurement time of the multistandard measurement.

Remote command:

CALCulate:​RTMS:​ALINe[:​VALue]


Show Line

Realtime Application (R&S FSW-K160R) > Analysis > Analysis in MSRT Applications > Show Line
Show Line

Hides or displays the analysis line in the time-based windows. By default, the line is displayed.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Remote command:

CALCulate:​RTMS:​ALINe:​SHOW


How to Perform Realtime Measurements

Realtime Application (R&S FSW-K160R) > How to Perform Realtime Measurements
How to Perform Realtime Measurements
Contents
  • How to Perform a Basic Realtime Measurement
  • How to Obtain Time Domain Results in Realtime
  • How to Analyze Persistency in Realtime Measurements
  • How to Configure the Color Mapping
  • How to Work with Frequency Mask Triggers
  • How to Perform Measurements in MSRT Mode


How to Perform a Basic Realtime Measurement

Realtime Application (R&S FSW-K160R) > How to Perform Realtime Measurements > How to Perform a Basic Realtime Measurement
How to Perform a Basic Realtime Measurement

The following step-by-step instructions demonstrate how to perform a basic realtime measurement with the R&S FSW-K160R option.

  1. Press the MODE key on the front panel and select the "Realtime Spectrum" application.

  2. Press the RUN CONT key to stop the default continuous measurement.

  3. Select the "Overview" softkey to display the "Overview" for a realtime measurement.

    A "High Resolution" measurement is selected by default, which is a realtime measurement with bandwidth of 160 MHz. This measurement type is appropriate for most realtime measurements if no time-domain results are required. The basic measurement described here can also be performed using the multi-domain measurement type.

  4. Select the "Amplitude" button to define the required reference level and configure the attenuation, if necessary.

  5. Select the "Frequency" button to define the frequency range to be measured (maximum 160 MHz).

    Configure at least one of the following parameter combinations:
    • center frequency and span
    • start and stop frequency

  6. Optionally, select the "Trigger" button to use an external trigger or to configure a frequency mask trigger for the measurement. For details on using a frequency mask trigger see "How to Work with Frequency Mask Triggers".

    To restrict measurement to a specific time around a trigger event, define a pretrigger and posttrigger time in the "Trigger" settings.

  7. Select the "Bandwidth" button to configure the FFT parameters.

    • "RBW": define an absolute value or a coupling factor to the span
    • "FFT window": select the window function depending on the required characterists
    • "Sweep time": define how long data is to be captured for one spectrum display

  8. Select the "Analysis" button and then the "Spectrogram/Waterfall" tab to configure the spectrogram.

    • History depth: number of frames to be stored in the spectrogram (possibly for several consecutive measurements).
    • Optionally, deactivate the time stamp option to refer to the individual frames using an index number instead of the time they were captured.
    • Optionally, select "Color Mapping" to change the colors with which the power levels are represented in the spectrogram. For details see "How to Configure the Color Mapping".
    • Select "Clear Spectrogram" to start a new spectrogram display.

  9. Press RUN SINGLE to start a sweep with the defined settings.

    When the sweep is finished, the Spectrogram displays all captured frames, and the Realtime Spectrum displays the spectrum that starts with the trigger event (or the most recently captured spectrum for free-run measurements).

  10. Scroll through the individual frames of the Spectrogram:

    1. Tap the Spectrogram window.

    2. Press the SWEEP key.

    3. Select the "Select Frame" softkey and change the index number (negative numbers from 0 downwards).

    The Realtime Spectrum displays the stored spectrum for the selected frame.

  11. Optionally, export the trace data of the spectrogram to a file.

    1. Select the "Analysis" button in the "Overview".

    2. In the "Traces" tab of the "Analysis" dialog box, switch to the "Trace Export" tab.

    3. From the "Specifics for" list, select the spectrogram display.

    4. Select "Export Trace to ASCII File".

    5. Define a file name and storage location and select "OK".


How to Obtain Time Domain Results in Realtime

Realtime Application (R&S FSW-K160R) > How to Perform Realtime Measurements > How to Obtain Time Domain Results in Realtime
How to Obtain Time Domain Results in Realtime

The following step-by-step instructions demonstrate how to perform a realtime measurement and obtain results in the time domain with the R&S FSW-K160R option.

  1. Press the MODE key on the front panel and select the "Realtime Spectrum" application.

  2. Press the RUN CONT key to stop the default continuous measurement.

  3. Select the "Overview" softkey to display the "Overview" for a realtime measurement.

  4. Select the "Select Measurement" button and select the "Multi Domain" measurement, which provides time domain results in addition to spectrum results.

  5. Select the "Amplitude" button to define the required reference level and configure the attenuation, if necessary.

  6. Optionally, select the "Trigger" button to use an external trigger, a time domain trigger, or a frequency mask trigger for the measurement. For details on using a frequency mask trigger see "How to Work with Frequency Mask Triggers".

    To restrict measurement to a specific time around a trigger event, define a pretrigger and posttrigger time in the "Trigger" settings.

    If a trigger is used, enable the "Stop on Trigger" option to perform a single measurement.

  7. Select the "Bandwidth" button to configure the FFT parameters.

    • "RBW": define an absolute value or a coupling factor to the span
    • "FFT window": select the window function depending on the required characterists
    • "PVT Sweep time": define how long data is to be captured for one Power vs Time display

  8. Select the "Analysis" button and then the "Spectrogram/Waterfall" tab to configure the waterfall diagram.

    • History depth: number of frames to be stored in the waterfall (possibly for several consecutive measurements).
    • Optionally, deactivate the time stamp option to refer to the individual frames using an index number instead of the time they were captured.
    • Optionally, select "Color Mapping" (in the "Power vs Time Waterfall Config" area) to change the colors with which the power levels are represented in the waterfall. For details see "How to Configure the Color Mapping".
    • Select "Clear Power vs Time Waterfall" to start a new waterfall diagram.

  9. Press RUN SINGLE to start a sweep with the defined settings.

    When the sweep is finished, the "PVT Waterfall" diagram displays the captured frames, and the "PVT" diagram displays the results that start with the trigger event (or the most recently measured values for free-run measurements).

  10. Scroll through the individual frames of the waterfall:

    1. Tap the "PVT Waterfall" window.

    2. Press the SWEEP key.

    3. Select the "Select Frame" softkey and change the index number (negative numbers from 0 downwards).

    The "PVT" window displays the stored diagram for the selected frame.

  11. Optionally, export the trace data of the PVT diagram or PVT waterfall to a file.

    1. Select the "Analysis" button in the "Overview".

    2. In the "Traces" tab of the "Analysis" dialog box, switch to the "Trace Export" tab.

    3. From the "Specifics for" list, select the "PVT" or "PVT Waterfall" window

    4. Select "Export Trace to ASCII File".

    5. Define a file name and storage location and select "OK".


How to Analyze Persistency in Realtime Measurements

Realtime Application (R&S FSW-K160R) > How to Perform Realtime Measurements > How to Analyze Persistency in Realtime Measurements
How to Analyze Persistency in Realtime Measurements

The following step-by-step instructions demonstrate how to analyze persistency in a realtime measurement with the R&S FSW-K160R option.

  1. Configure the Realtime Spectrum application to perform a realtime measurement as described in "How to Perform a Basic Realtime Measurement" or "How to Obtain Time Domain Results in Realtime".

  2. Select the "Display Config" softkey and add a "Persistence Spectrum" window to the display.

  3. Exit the SmartGrid mode.

  4. Select the "Persistence Config" softkey to configure the persistency.

    • "Persistence": define how long each measured value is considered in the density calculation
    • "Granularity": define the time frame used to calculate a single line in the histogram (i.e. a single frame in the "Persistence Spectrum")
    • Optionally, select "Dots" style to display only true values without interpolated data.
    • Optionally, select "Color Mapping" to change the colors with which the density is represented in the "Persistence Spectrum". For details see "How to Configure the Color Mapping".
    • Optionally, deactivate or change the intensity of the "Maxhold" trace that shows only the maximum density for all frequencies.
    • Select "Reset" to start a new persistency histogram.

  5. Press RUN SINGLE to start a sweep with the defined persistency settings.

    When the sweep is finished, the "Persistence Spectrum" displays the density of all measured values, and the Realtime Spectrum displays the spectrum that starts with the trigger event (or the most recently captured spectrum for free-run measurements).

    Now you can analyze the colors in the "Persistence Spectrum", which indicate the probability of a particular level in the spectrum.


How to Configure the Color Mapping

Realtime Application (R&S FSW-K160R) > How to Perform Realtime Measurements > How to Configure the Color Mapping
How to Configure the Color Mapping

The color display is highly configurable to adapt the spectrograms to your needs.

The settings for color mapping are defined in the "Color Mapping" dialog box. To display this dialog box, do one of the following:

  • Tap the color map in the spectrogram display.
  • Press the "Color Mapping" softkey in the "Spectrogram" menu.
To select a color scheme

You can select which colors are assigned to the measured values.

►

In the "Color Mapping" dialog box, select the option for the color scheme to be used.

Editing the value range of the color map

The distribution of the measured values is displayed as a histogram in the "Color Mapping" dialog box. To cover the entire measurement value range, make sure the first and last bar of the histogram are included.

To ignore noise in a spectrogram, for example, exclude the lower power levels from the histogram.

The value range of the color map must cover at least 10% of the value range on the horizontal axis of the diagram, that means, the difference between the start and stop values must be at least 10%.

The value range can be set numerically or graphically.

To set the value range graphically using the color range sliders

  1. Select and drag the bottom color curve slider (indicated by a gray box at the left of the color curve pane) to the lowest value you want to include in the color mapping.

  2. Select and drag the top color curve slider (indicated by a gray box at the right of the color curve pane) to the highest value you want to include in the color mapping.

To set the value range numerically

  1. In the "Start" field, enter the percentage from the left border of the histogram that marks the beginning of the value range.

  2. In the "Stop" field, enter the percentage from the right border of the histogram that marks the end of the value range.

Example:

The color map starts at -100 dBm and ends at 0 dBm (i.e. a range of 100 dB). In order to suppress the noise, you only want the color map to start at -90 dBm. Thus, you enter 10% in the "Start" field. The R&S FSW shifts the start point 10% to the right, to -90 dBm.

Adjusting the reference level and level range

Note that changing the reference level and level range of the measurement also affects the color mapping in the spectrogram.

Truncating persistence spectrum results

By default, results that are smaller than the start value of the color map range are displayed in the color for the minimum value. Results that are larger than the stop value of the color map range are displayed in the color for the maximum value.

In order to hide results outside the value range of the color map, use the "Truncate" function.

Editing the shape of the color curve

The color curve is a tool to shift the focus of the color distribution on the color map. By default, the color curve is linear, i.e. the colors on the color map are distributed evenly. If you shift the curve to the left or right, the distribution becomes non-linear. The slope of the color curve increases or decreases. One end of the color palette then covers a large amount of results, while the other end distributes several colors over a relatively small result range.

The color curve shape can be set numerically or graphically.

To set the color curve shape graphically using the slider
► | Select and drag the color curve shape slider (indicated by a gray box in the middle of the color curve) to the left or right. The area beneath the slider is focussed, i.e. more colors are distributed there.
To set the color curve shape numerically
►

In the "Shape" field, enter a value to change the shape of the curve:

  • A negative value (-1 to <0) focusses the lower values
  • 0 defines a linear distribution
  • A positive value (>0 to 1) focusses the higher values


How to Work with Frequency Mask Triggers

Realtime Application (R&S FSW-K160R) > How to Perform Realtime Measurements > How to Work with Frequency Mask Triggers
How to Work with Frequency Mask Triggers

The Frequency Mask Trigger (FMT) is a mask in the frequency domain, which is checked with every calculated FFT. When a specific condition concerning this mask occurs during the measurement of the input signal, data capturing is triggered.

For details see "Frequency Mask Trigger"

Contents
  • How to Create a New Frequency Mask
  • How to Use a Frequency Mask Trigger


How to Create a New Frequency Mask

Realtime Application (R&S FSW-K160R) > How to Perform Realtime Measurements > How to Work with Frequency Mask Triggers > How to Create a New Frequency Mask
How to Create a New Frequency Mask

The frequency mask is configured by a set of individual trace points which are connected to form a mask area. The frequency mask may have any shape, defined by up to 1001 points.

There are several ways to create a new mask:
  • Automatically, according to the currently measured values
  • Graphically, by moving the mask points on the touchscreen
  • Numerically, by defining the x- and y-values of the mask points

You can combine the methods. For example, at first you draw the mask quickly on the touchscreen, and then modify the point coordinates with precise values. Or you create an upper mask automatically and then add a lower mask manually.

To create a mask automatically

  1. Press the MEAS CONFIG key, then select the "Edit Frequency Mask" softkey.

    A default (upper) mask is displayed in the preview area of the "Edit Frequency Mask" dialog box.

  2. Select "Auto-Set Mask".

    A mask in close proximity to the currently measured data is created.

  3. If necessary, modify the mask or add a lower mask as described in "To create a mask manually".

To create a mask manually

  1. Press the MEAS CONFIG key, then select the "Edit Frequency Mask" softkey.

    If an existing mask is already displayed in the preview area of the "Edit Frequency Mask" dialog box, select "New Mask".

    A default (upper) mask with 4 points is displayed in the preview area of the "Edit Frequency Mask" dialog box.

  2. To define a lower mask, select the "Lower Mask" option.

    A default lower mask with 4 points is displayed in the preview area of the "Edit Frequency Mask" dialog box.

  3. If only a lower mask is required, deselect the "Upper Mask" option.

  4. For each mask, tap the corner points of the mask in the preview area and drag them to the required destination, or enter the position and value of each mask point in the list of coordinates to the left of the preview area.

  5. If necessary, insert additional mask points to design a more complex shape:

    1. Tap an existing mask point in the preview area or in the list of coordinates before which you want to insert a new point.

    2. Select the "Insert" button.

      An additional point is inserted in the mask in the preview area and in the list of co-ordinates.

    3. Drag the new point to the required destination, or define its coordinates.

  6. To shift the entire mask (upper and lower) vertically or horizontally, for example to consider a frequency or reference level offset in the input signal, select the "Shift x" or "Shift y" button.

  7. Repeat these steps until the required mask shape is displayed.

    For upper masks, the display region above the defined mask points is defined as the frequency mask. For lower masks, the display region below the mask points is defined as the frequency mask.

  8. Define how the frequency mask is to be evaluated, depending on whether the mask area represents the desired or undesired value range. See "Trigger conditions" for detailed descriptions of the possible conditions.

  9. Optionally, store the frequency mask configuration for later use:

    1. Provide a name and, optionally, a comment for the mask.

    2. Select "Save Mask".

    3. In the file selection dialog box, select the storage location for the file (default: the freqmask subdirectory of the installation directory).

      By default, the mask name is used as the file name; however, it can be edited.

    4. Select "Save".

    The mask is stored in a file with the extension .FMT in the selected directory.


How to Use a Frequency Mask Trigger

Realtime Application (R&S FSW-K160R) > How to Perform Realtime Measurements > How to Work with Frequency Mask Triggers > How to Use a Frequency Mask Trigger
How to Use a Frequency Mask Trigger

  1. Press the TRIG key, then select the "Frequency Mask" softkey to use a mask as the trigger source.

  2. Press the MEAS CONFIG key, then select the "Edit Frequency Mask" softkey.

  3. Define which frequency mask is to be used as a trigger source:

    • Create a new mask as defined in "How to Create a New Frequency Mask".

    Or:

    1. Select "Load Mask" to select a stored frequency mask.

    2. In the file selection dialog box, select the storage location of the file (default: the freqmask subdirectory of the installation directory) with the extension .FMT.

    3. If necessary, modify the mask as described in "To create a mask manually".

    The next realtime measurement will be triggered when the specified event concerning the frequency mask occurs.


How to Perform Measurements in MSRT Mode

Realtime Application (R&S FSW-K160R) > How to Perform Realtime Measurements > How to Perform Measurements in MSRT Mode
How to Perform Measurements in MSRT Mode

The following step-by-step instructions demonstrate how to perform a measurement in MSRT mode.

How to capture data in MSRT mode

  1. Press the MODE key on the front panel and select the "Multi-Standard Realtime" operating mode.

    Confirm the message.

  2. Select the "Overview" softkey to display the "Overview" for a Realtime measurement.

  3. Select the "Amplitude" button to define the required reference level and configure the attenuation, if necessary.

  4. Select the "Frequency" button to define the frequency range to be measured (maximum 160 MHz).

    Configure at least one of the following parameter combinations:
    • center frequency and span
    • start and stop frequency

  5. Select the "Trigger" button to use an external trigger or to configure a frequency mask trigger for the measurement. For details on using a frequency mask trigger see "How to Work with Frequency Mask Triggers".

    Define a pretrigger and posttrigger time in the "Trigger" settings.

    Enable the "Stop on Trigger" option to perform a single measurement.

  6. Select the "Bandwidth" button to configure the FFT parameters.

    • "RBW": define an absolute value or a coupling factor to the span
    • "FFT window": select the window function depending on the required characterists
    • "Sweep time": define how long data is to be captured for one spectrum display

  7. If necessary, select the "Display Config" button and select other displays (up to a total of 6) required to control the acquired data.

    Arrange them on the display to suit your preferences.

  8. Exit the SmartGrid mode.

    After the trigger event occurrs, a single measurement is performed and you can analyze the captured I/Q data in various MSRT applications at the same time.

How to analyze the captured data in MSRT applications

  1. Press the MODE key on the front panel and select a MSRT application.

  2. Select the "Overview" softkey to display the "Overview" for the MSRT application.

  3. Define the application data extract, i.e. the range of the capture buffer you want to analyze in this application.

  4. Define the analysis interval, i.e. the frame number or similar within the application data you want to analyze in this application (not necessary for I/Q Analyzer or Analog Demodulation applications).

  5. Select the "Frequency" button and define the center frequency for the analysis interval.

  6. Select the "Display Config" button and select other displays to analyze the data in the configured interval.

    Arrange them on the display to suit your preferences.

  7. Exit the SmartGrid mode.

    Repeat these steps for any other applications.

How to perform analysis of the correlated data

  1. Perform a single data aquisition measurement as described in "How to capture data in MSRT mode".

  2. Activate measurement channels for the MSRT applications you require as described in "How to analyze the captured data in MSRT applications".

  3. Select the MSRT View to get an overview of the captured data and the configured applications.

    Determine the individual data ranges that you want to analyze in the different applications. If necessary, adapt the application data and analysis interval settings for the applications to reflect the relevant data ranges.

    The analysis line indicates a common time in all time-based result displays for easy comparison.


Optimizing and Troubleshooting the Measurement

Realtime Application (R&S FSW-K160R) > Optimizing and Troubleshooting the Measurement
Optimizing and Troubleshooting the Measurement

If the results do not meet your expectations, try the following methods to optimize the measurement or solve problems:

└ No results are displayed in MSRT applications


No results are displayed in MSRT applications

Realtime Application (R&S FSW-K160R) > Optimizing and Troubleshooting the Measurement > No results are displayed in MSRT applications
No results are displayed in MSRT applications

When you switch to MSRT mode, the Sequencer is automatically activated in Continuous Sequence mode. Since the default trigger mode is "Free Run" and "Auto Rearm", the MSRT Master continuously performs a realtime measurement until it is stopped. During this time, the Sequencer never passes the data on to other MSRT applications and no evaluation is performed in those result displays.

Thus, it is important that you configure a trigger for the MSRT Master, or stop the Sequencer and switch between the Master and the application tabs manually. In this case, the continuous measurement is stopped when you switch tabs. However, you will have to update the subsequent application displays manually, using the "Refresh" functions (see "Refresh"/"Refresh All").

For details see "Configuring and Performing Measurements in MSRT Mode".


Remote Commands to Perform Realtime Measurements

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements
Remote Commands to Perform Realtime Measurements

The following commands are specific to performing measurements in the Realtime Spectrum application in a remote environment.

It is assumed that the R&S FSW has already been set up for remote control in a network as described in "How to Set Up a Network and Remote Control" .

Note that basic tasks that are also performed in the base unit in the same way are not described here.

In particular, this includes:

  • Managing Settings and Results, i.e. storing and loading settings and result data, see "Managing Settings and Results"
  • Basic instrument configuration, e.g. checking the system configuration, customizing the screen layout, or configuring networks and remote operation, see "Configuring the "
  • Using the common status registers, see "Using the Status Register"

The following tasks specific to realtime measurements are described here:

Contents
  • Introduction
  • Common Suffixes
  • Activating the Realtime Spectrum Application
  • Selecting the Measurement Type
  • Configuring Realtime Measurements
  • Capturing Data and Performing Sweeps
  • Retrieving Results
  • Analyzing Results
  • Querying the Status Registers
  • Commands for Compatibility
  • Remote Commands for MSRT Operating Mode
  • Programming Examples: Performing Realtime Measurements


Introduction

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Introduction
Introduction

Commands are program messages that a controller (e.g. a PC) sends to the instrument or software. They operate its functions ('setting commands' or 'events') and request information ('query commands'). Some commands can only be used in one way, others work in two ways (setting and query). If not indicated otherwise, the commands can be used for settings and queries.

The syntax of a SCPI command consists of a header and, in most cases, one or more parameters. To use a command as a query, you have to append a question mark after the last header element, even if the command contains a parameter.

A header contains one or more keywords, separated by a colon. Header and parameters are separated by a "white space" (ASCII code 0 to 9, 11 to 32 decimal, e.g. blank). If there is more than one parameter for a command, these are separated by a comma from one another.

Only the most important characteristics that you need to know when working with SCPI commands are described here. For a more complete description, refer to the User Manual of the R&S FSW.

Remote command examples

Note that some remote command examples mentioned in this general introduction may not be supported by this particular application.

Contents
  • Long and Short Form
  • Numeric Suffixes
  • Optional Keywords
  • Alternative Keywords
  • SCPI Parameters


Long and Short Form

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Introduction > Long and Short Form
Long and Short Form

The keywords have a long and a short form. You can use either the long or the short form, but no other abbreviations of the keywords.

The short form is emphasized in upper case letters. Note however, that this emphasis only serves the purpose to distinguish the short from the long form in the manual. For the instrument, the case does not matter.

Example:

SENSe:FREQuency:CENTer is the same as SENS:FREQ:CENT.


Numeric Suffixes

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Introduction > Numeric Suffixes
Numeric Suffixes

Some keywords have a numeric suffix if the command can be applied to multiple instances of an object. In that case, the suffix selects a particular instance (e.g. a measurement window).

Numeric suffixes are indicated by angular brackets (<n>) next to the keyword.

If you don't quote a suffix for keywords that support one, a 1 is assumed.

Example:

DISPlay[:WINDow<1...4>]:ZOOM:STATe enables the zoom in a particular measurement window, selected by the suffix at WINDow.

DISPlay:WINDow4:ZOOM:STATe ON refers to window 4.


Optional Keywords

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Introduction > Optional Keywords
Optional Keywords

Some keywords are optional and are only part of the syntax because of SCPI compliance. You can include them in the header or not.

Note that if an optional keyword has a numeric suffix and you need to use the suffix, you have to include the optional keyword. Otherwise, the suffix of the missing keyword is assumed to be the value 1.

Optional keywords are emphasized with square brackets.

Example:

Without a numeric suffix in the optional keyword:

[SENSe:]FREQuency:CENTer is the same as FREQuency:CENTer

With a numeric suffix in the optional keyword:

DISPlay[:WINDow<1...4>]:ZOOM:STATe

DISPlay:ZOOM:STATe ON enables the zoom in window 1 (no suffix).

DISPlay:WINDow4:ZOOM:STATe ON enables the zoom in window 4.


Alternative Keywords

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Introduction > Alternative Keywords
Alternative Keywords

A vertical stroke indicates alternatives for a specific keyword. You can use both keywords to the same effect.

Example:

[SENSe:]BANDwidth|BWIDth[:RESolution]

In the short form without optional keywords, BAND 1MHZ would have the same effect as BWID 1MHZ.


SCPI Parameters

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Introduction > SCPI Parameters
SCPI Parameters

Many commands feature one or more parameters.

If a command supports more than one parameter, these are separated by a comma.

Example:

LAYout:ADD:WINDow Spectrum,LEFT,MTABle

Parameters may have different forms of values.

Contents
  • Numeric Values
  • Boolean
  • Character Data
  • Character Strings
  • Block Data


Numeric Values

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Introduction > SCPI Parameters > Numeric Values
Numeric Values

Numeric values can be entered in any form, i.e. with sign, decimal point or exponent. In case of physical quantities, you can also add the unit. If the unit is missing, the command uses the basic unit.

Example:

with unit: SENSe:FREQuency:CENTer 1GHZ

without unit: SENSe:FREQuency:CENTer 1E9 would also set a frequency of 1 GHz.

Values exceeding the resolution of the instrument are rounded up or down.

If the number you have entered is not supported (e.g. in case of discrete steps), the command returns an error.

Instead of a number, you can also set numeric values with a text parameter in special cases.

  • MIN/MAX
    Defines the minimum or maximum numeric value that is supported.
  • DEF
    Defines the default value.
  • UP/DOWN
    Increases or decreases the numeric value by one step. The step size depends on the setting. In some cases you can customize the step size with a corresponding command.
Querying numeric values

When you query numeric values, the system returns a number. In case of physical quantities, it applies the basic unit (e.g. Hz in case of frequencies). The number of digits after the decimal point depends on the type of numeric value.

Example:

Setting: SENSe:FREQuency:CENTer 1GHZ

Query: SENSe:FREQuency:CENTer? would return 1E9

In some cases, numeric values may be returned as text.

  • INF/NINF
    Infinity or negative infinity. Represents the numeric values 9.9E37 or -9.9E37.
  • NAN
    Not a number. Represents the numeric value 9.91E37. NAN is returned in case of errors.


Boolean

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Introduction > SCPI Parameters > Boolean
Boolean

Boolean parameters represent two states. The "ON" state (logically true) is represented by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by "OFF" or the numeric value 0.

Querying boolean parameters

When you query boolean parameters, the system returns either the value 1 ("ON") or the value 0 ("OFF").

Example:

Setting: DISPlay:WINDow:ZOOM:STATe ON

Query: DISPlay:WINDow:ZOOM:STATe? would return 1


Character Data

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Introduction > SCPI Parameters > Character Data
Character Data

Character data follows the syntactic rules of keywords. You can enter text using a short or a long form. For more information see "Long and Short Form".

Querying text parameters

When you query text parameters, the system returns its short form.

Example:

Setting: SENSe:BANDwidth:RESolution:TYPE NORMal

Query: SENSe:BANDwidth:RESolution:TYPE? would return NORM


Character Strings

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Introduction > SCPI Parameters > Character Strings
Character Strings

Strings are alphanumeric characters. They have to be in straight quotation marks. You can use a single quotation mark ( ' ) or a double quotation mark ( " ).

Example:

INSTRument:DELete 'Spectrum'


Block Data

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Introduction > SCPI Parameters > Block Data
Block Data

Block data is a format which is suitable for the transmission of large amounts of data.

The ASCII character # introduces the data block. The next number indicates how many of the following digits describe the length of the data block. In the example the 4 following digits indicate the length to be 5168 bytes. The data bytes follow. During the transmission of these data bytes all end or other control signs are ignored until all bytes are transmitted. #0 specifies a data block of indefinite length. The use of the indefinite format requires a NL^END message to terminate the data block. This format is useful when the length of the transmission is not known or if speed or other considerations prevent segmentation of the data into blocks of definite length.


Common Suffixes

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Common Suffixes
Common Suffixes

The following common suffixes are used in remote commands specific to realtime measurements:

Suffix | Value range | Description
<m> | 1..16 | Marker
<n> | 1..6 | Window
<t> | 1..4 | Trace


Activating the Realtime Spectrum Application

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Activating the Realtime Spectrum Application
Activating the Realtime Spectrum Application

Realtime measurements require a special application. A measurement is started immediately with the default settings.

List of Commands
INSTrument:CREate:DUPLicate
INSTrument:CREate[:NEW]
INSTrument:CREate:REPLace
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
SYSTem:PRESet:COMPatible
SYSTem:PRESet:CHANnel[:EXECute]


INSTrument:CREate:DUPLicate

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Activating the Realtime Spectrum Application > INSTrument:CREate:DUPLicate
INSTrument:CREate:DUPLicate

This command duplicates the currently selected measurement channel, i.e starts a new measurement channel of the same type and with the identical measurement settings. The name of the new channel is the same as the copied channel, extended by a consecutive number (e.g. "Spectrum" -> "Spectrum 2").

The channel to be duplicated must be selected first using the INST:SEL command.

(See INSTrument[:​SELect] ).

This command is not available if the MSRA/MSRT Master channel is selected.

Example: | INST:SEL 'Spectrum' INST:CRE:DUPL Duplicates the channel named 'Spectrum' and creates a new measurement channel named 'Spectrum 2'.
Usage: | Event


INSTrument:CREate[:NEW]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Activating the Realtime Spectrum Application > INSTrument:CREate[:NEW]
INSTrument:CREate[:NEW] <ChannelType>, <ChannelName>

This command adds an additional measurement channel. The number of measurement channels you can configure at the same time depends on available memory.

Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel. The channel name is displayed as the tab label for the measurement channel.

Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).

Example: INST:CRE SAN, 'Spectrum 2'

Adds an additional spectrum display named "Spectrum 2".

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Manual operation: See "New Channel"


INSTrument:CREate:REPLace

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Activating the Realtime Spectrum Application > INSTrument:CREate:REPLace
INSTrument:CREate:REPLace <ChannelName1>,<ChannelType>,<ChannelName2>

This command replaces a measurement channel with another one.

Parameters:
<ChannelName1> | String containing the name of the measurement channel you want to replace.
<ChannelType> | Channel type of the new channel. For a list of available channel types see INSTrument:​LIST?.
<ChannelName2> | String containing the name of the new channel. Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).
Example: | INST:CRE:REPL 'Spectrum2',IQ,'IQAnalyzer' Replaces the channel named 'Spectrum2' by a new measurement channel of type 'IQ Analyzer' named 'IQAnalyzer'.
Manual operation: | See "Replace Current Channel"


INSTrument:DELete

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Activating the Realtime Spectrum Application > INSTrument:DELete
INSTrument:DELete <ChannelName>

This command deletes a measurement channel. If you delete the last measurement channel, the default "Spectrum" channel is activated.

Parameters:
<ChannelName> | String containing the name of the channel you want to delete. A measurement channel must exist in order to be able delete it.
Example: | INST:DEL 'Spectrum4' Deletes the spectrum channel with the name 'Spectrum4'.


INSTrument:LIST?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Activating the Realtime Spectrum Application > INSTrument:LIST?
INSTrument:LIST?

This command queries all active measurement channels. This is useful in order to obtain the names of the existing measurement channels, which are required in order to replace or delete the channels.

Return values:
<ChannelType>, <ChannelName> | For each channel, the command returns the channel type and channel name (see tables below). Tip: to change the channel name, use the INSTrument:​REName command.
Example: | INST:LIST? Result for 3 measurement channels: 'ADEM','Analog Demod','IQ','IQ Analyzer','SANALYZER','Spectrum'
Usage: | Query only
Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode
Application | <ChannelType> Parameter | Default Channel Name*)
Spectrum | SANALYZER | Spectrum
I/Q Analyzer | IQ | IQ Analyzer
Pulse (R&S FSW-K6) | PULSE | Pulse
Analog Demodulation (R&S FSW-K7) | ADEM | Analog Demod
GSM (R&S FSW-K10) | GSM | GSM
Multi-Carrier Group Delay (R&S FSW-K17) | MCGD | MC Group Delay
Noise (R&S FSW-K30) | NOISE | Noise
Phase Noise (R&S FSW-K40) | PNOISE | Phase Noise
Transient Analysis (R&S FSW-K60) | TA | Transient Analysis
VSA (R&S FSW-K70) | DDEM | VSA
3GPP FDD BTS (R&S FSW-K72) | BWCD | 3G FDD BTS
3GPP FDD UE (R&S FSW-K73) | MWCD | 3G FDD UE
TD-SCDMA BTS (R&S FSW-K76) | BTDS | TD-SCDMA BTS
TD-SCDMA UE (R&S FSW-K77) | MTDS | TD-SCDMA UE
cdma2000 BTS (R&S FSW-K82) | BC2K | CDMA2000 BTS
cdma2000 MS (R&S FSW-K83) | MC2K | CDMA2000 MS
1xEV-DO BTS (R&S FSW-K84) | BDO | 1xEV-DO BTS
1xEV-DO MS (R&S FSW-K85) | MDO | 1xEV-DO MS
WLAN (R&S FSW-K91) | WLAN | WLAN
LTE (R&S FSW-K10x) | LTE | LTE
Realtime Spectrum (R&S FSW-K160R) | RTIM | Realtime Spectrum
Note: the default channel name is also listed in the table. If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel.


INSTrument:REName

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Activating the Realtime Spectrum Application > INSTrument:REName
INSTrument:REName <ChannelName1>, <ChannelName2>

This command renames a measurement channel.

Parameters:
<ChannelName1> | String containing the name of the channel you want to rename.
<ChannelName2> | String containing the new channel name. Note that you can not assign an existing channel name to a new channel; this will cause an error.
Example: | INST:REN 'Spectrum2','Spectrum3' Renames the channel with the name 'Spectrum2' to 'Spectrum3'.


INSTrument[:SELect]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Activating the Realtime Spectrum Application > INSTrument[:SELect]
INSTrument[:SELect] <ChannelType>

Selects the application (channel type) for the current channel.

See also INSTrument:​CREate[:​NEW].

For a list of available channel types see table "Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode".

Parameters:
<ChannelType> | RTIM Realtime Spectrum application, R&S FSW-K160R (not MSRT operating mode! See INSTrument:​MODE)
Example: | See "Example 2: Performing a Basic Realtime Measurement".
Usage: | SCPI confirmed
Manual operation: | See "I/Q Analyzer" See "Analog Demodulation" See "Pulse Measurements" See "Transient Analysis" See "Vector Signal Analysis (VSA)" See "New Channel"


SYSTem:PRESet:COMPatible

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Activating the Realtime Spectrum Application > SYSTem:PRESet:COMPatible
SYSTem:PRESet:COMPatible <OpMode>

This command defines the operating mode that is activated when you switch on the R&S FSW or press the PRESET key.

Parameters:
<OpMode>
SANalyzer

(Default:) Defines Signal and Spectrum Analyzer operating mode as the presetting.

MSRA

Defines Multi-Standard Radio Analysis (MSRA) as the preset default operating mode.

RTSM

Defines Multi-Standard Realtime (MSRT) as the preset default operating mode.

*RST: SAN
Usage: Event


SYSTem:PRESet:CHANnel[:EXECute]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Activating the Realtime Spectrum Application > SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:CHANnel[:EXECute]

This command restores the default instrument settings in the current channel.

Use INST:SEL to select the channel.

For details see "Factory Default Configuration" .

Example: | INST 'Spectrum2' Selects the channel for "Spectrum2". SYST:PRES:CHAN:EXEC Restores the factory default settings to the "Spectrum2" channel.
Usage: | Event
Manual operation: | See "Preset Channel"


Selecting the Measurement Type

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Selecting the Measurement Type
Selecting the Measurement Type

Different measurement types allow for realtime measurements optimized either for High Resolution or providing additional evaluation in the time domain.

List of Commands
CONFigure:REALtime:MEASurement


CONFigure:REALtime:MEASurement

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Selecting the Measurement Type > CONFigure:REALtime:MEASurement
CONFigure:REALtime:MEASurement <MeasType>

Selects a realtime measurement optimized either for high frequency resolution or providing additional evaluation in the time domain.

Parameters:
<MeasType>
HRESolution

High Resolution realtime measurements are performed with an exceptionally large bandwidth of 160 MHz, allowing for very precise results in the frequency domain.

Additional Span/RBW couplings are available for precise frequency results.

Time domain evaluation is not available.

MDOMain

Multi Domain realtime measurements allow for results both in the frequency and time domains, however with a restriced bandwidth of 100 MHz.

*RST: HRESolution
Example:

See "Example 4: Obtaining Time Domain Results in Realtime".

Manual operation: See "Select Measurement"


Configuring Realtime Measurements

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements
Configuring Realtime Measurements
Contents
  • Configuring Input/Output Settings
  • Configuring the Vertical Axis (Amplitude, Scaling)
  • Defining the Frequency and Span
  • Configuring Bandwidth and Sweep Settings
  • Triggering
  • Configuring Spectrograms and PVT Waterfalls
  • Configuring the Persistence Spectrum
  • Configuring Color Maps
  • Adjusting Settings Automatically
  • Configuring the Result Display


Configuring Input/Output Settings

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Input/Output Settings
Configuring Input/Output Settings

The following commands are required to define input and output settings. Any settings related to data acquisition or data output are only available for the Realtime Spectrum Application or the MSRT Master.

Contents
  • RF Input
  • Configuring the Outputs


RF Input

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Input/Output Settings > RF Input
RF Input
List of Commands
INPut:ATTenuation:PROTection:RESet
INPut:CONNector
INPut:COUPling
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:IMPedance
INPut:SELect


INPut:ATTenuation:PROTection:RESet

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Input/Output Settings > RF Input > INPut:ATTenuation:PROTection:RESet
INPut:ATTenuation:PROTection:RESet

This command resets the attenuator and reconnects the RF input with the input mixer after an overload condition occured and the protection mechanism intervened.The error status bit (bit 3 in the STAT:QUES:POW status register) and the INPUT OVLD message in the status bar are cleared.

The command works only if the overload condition has been eliminated first.

Usage: Event


INPut:CONNector

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Input/Output Settings > RF Input > INPut:CONNector
INPut:CONNector <ConnType>

Determines whether the RF input data is taken from the RF input connector or the optional Analog Baseband I connector. This command is only available if the Analog Baseband interface (R&S FSW-B71) is installed and active for input.

For more information see "Processing Data From the Analog Baseband Interface" .

Parameters:
<ConnType>
RF

RF input connector

AIQI

Analog Baseband I connector

*RST: RF
Example: INP:CONN:AIQI

Selects the analog baseband input.

Usage: SCPI confirmed
Manual operation: See "Input Connector"


INPut:COUPling

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Input/Output Settings > RF Input > INPut:COUPling
INPut:COUPling <CouplingType>

This command selects the coupling type of the RF input.

Parameters:
<CouplingType>
AC

AC coupling

DC

DC coupling

*RST: AC
Example: INP:COUP DC
Usage: SCPI confirmed
Manual operation: See "Input Coupling"


INPut:FILTer:HPASs[:STATe]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Input/Output Settings > RF Input > INPut:FILTer:HPASs[:STATe]
INPut:FILTer:HPASs[:STATe] <State>

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "High-Pass Filter 1...3 GHz"


INPut:FILTer:YIG[:STATe]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Input/Output Settings > RF Input > INPut:FILTer:YIG[:STATe]
INPut:FILTer:YIG[:STATe] <State>

This command turns the YIG-preselector on and off.

Note the special conditions and restrictions for the YIG filter described in "YIG-Preselector".

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 (0 for I/Q Analyzer, GSM, VSA and MC Group Delay measurements)
Example: INP:FILT:YIG OFF

Deactivates the YIG-preselector.

Manual operation: See "YIG-Preselector"


INPut:IMPedance

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Input/Output Settings > RF Input > INPut:IMPedance
INPut:IMPedance <Impedance>

This command selects the nominal input impedance of the RF input.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a matching pad of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The power loss correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

Parameters:
<Impedance>
50 | 75
*RST: 50 Ω
Example: INP:IMP 75
Usage: SCPI confirmed
Manual operation: See "Impedance"


INPut:SELect

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Input/Output Settings > RF Input > INPut:SELect
INPut:SELect <Source>

This command selects the signal source for measurements, i.e. it defines which connector is used to input data to the R&S FSW. If no additional options are installed, only RF input is supported.

Parameters:
<Source>
RF

Radio Frequency ("RF INPUT" connector)

*RST: RF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


Configuring the Outputs

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Input/Output Settings > Configuring the Outputs
Configuring the Outputs

Configuring trigger input/output is described in "Configuring the Trigger Output".

List of Commands
DIAGnostic:SERVice:NSOurce
OUTPut:IF:IFFRequency


DIAGnostic:SERVice:NSOurce

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Input/Output Settings > Configuring the Outputs > DIAGnostic:SERVice:NSOurce
DIAGnostic:SERVice:NSOurce <State>

This command turns the 28 V supply of the BNC connector labeled NOISE SOURCE CONTROL on the front panel on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DIAG:SERV:NSO ON
Manual operation: See "Noise Source"


OUTPut:IF:IFFRequency

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Input/Output Settings > Configuring the Outputs > OUTPut:IF:IFFRequency
OUTPut:IF:IFFRequency <Frequency>

This command defines the frequency for the IF output. The IF frequency of the signal is converted accordingly.

This command is available in the time domain and if the IF/VIDEO/DEMOD output is configured for IF.

Parameters:
<Frequency>
*RST: 50.0 MHz


Configuring the Vertical Axis (Amplitude, Scaling)

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling)
Configuring the Vertical Axis (Amplitude, Scaling)

The following commands are required to configure the amplitude and vertical axis settings in a remote environment.

Contents
  • Amplitude Settings
  • Configuring the Attenuation
  • Configuring a Preamplifier
  • Scaling the Y-Axis


Amplitude Settings

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings
Amplitude Settings
Useful commands for amplitude configuration described elsewhere:
  • [SENSe:​]ADJust:​LEVel
Remote commands exclusive to amplitude configuration:
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:REFerence
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet


CALCulate<n>:MARKer<m>:FUNCtion:REFerence

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > CALCulate<n>:MARKer<m>:FUNCtion:REFerence
CALCulate<n>:MARKer<m>:FUNCtion:REFerence

This command matches the reference level to the power level of a marker.

If you use the command in combination with a delta marker, that delta marker is turned into a normal marker.

Example: | CALC:MARK2:FUNC:REF Sets the reference level to the level of marker 2.
Usage: | Event
Manual operation: | See "Reference Level = Marker Level"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel <ReferenceLevel>

This command defines the reference level.

Example: DISP:TRAC:Y:RLEV -60dBm
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Reference Level"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet <Offset>

This command defines a reference level offset.

Parameters:
<Offset>
Range: | -200 dB to 200 dB
*RST: | 0dB
Example: DISP:TRAC:Y:RLEV:OFFS -10dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Shifting the Display (Offset)"


Configuring the Attenuation

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation
Configuring the Attenuation
List of Commands
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe


INPut:ATTenuation

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:ATTenuation
INPut:ATTenuation <Attenuation>

This command defines the total attenuation for RF input.

If you set the attenuation manually, it is no longer coupled to the reference level, but the reference level is coupled to the attenuation. Thus, if the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

Parameters:
<Attenuation>
Range: | see data sheet
Increment: | 5 dB
*RST: | 10 dB (AUTO is set to ON)
Example: INP:ATT 30dB

Defines a 30 dB attenuation and decouples the attenuation from the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:ATTenuation:AUTO

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:ATTenuation:AUTO
INPut:ATTenuation:AUTO <State>

This command couples or decouples the attenuation to the reference level. Thus, when the reference level is changed, the R&S FSW determines the signal level for optimal internal data processing and sets the required attenuation accordingly.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:ATT:AUTO ON

Couples the attenuation to the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:EATT

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:EATT
INPut:EATT <Attenuation>

This command defines an electronic attenuation manually. Automatic mode must be switched off (INP:EATT:AUTO OFF, see INPut:​EATT:​AUTO).

If the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

Parameters:
<Attenuation>
attenuation in dB
Range: | see data sheet
Increment: | 1 dB
*RST: | 0 dB (OFF)
Example: INP:EATT:AUTO OFF
INP:EATT 10 dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:AUTO

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:EATT:AUTO
INPut:EATT:AUTO <State>

This command turns automatic selection of the electronic attenuation on and off.

If on, electronic attenuation reduces the mechanical attenuation whenever possible.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:EATT:AUTO OFF
Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:STATe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:EATT:STATe
INPut:EATT:STATe <State>

This command turns the electronic attenuator on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:EATT:STAT ON

Switches the electronic attenuator into the signal path.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


Configuring a Preamplifier

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring a Preamplifier
Configuring a Preamplifier
List of Commands
INPut:GAIN:STATe
INPut:GAIN[:VALue]


INPut:GAIN:STATe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring a Preamplifier > INPut:GAIN:STATe
INPut:GAIN:STATe <State>

This command turns the preamplifier on and off.

The command requires option R&S FSW-B24.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:GAIN:STAT ON

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


INPut:GAIN[:VALue]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring a Preamplifier > INPut:GAIN[:VALue]
INPut:GAIN[:VALue] <Gain>

This command selects the preamplification level if the preamplifier is activated (INP:GAIN:STAT ON, see INPut:​GAIN:​STATe).

The command requires option R&S FSW-B24.

Parameters:
<Gain>
15 dB | 30 dB

The availability of preamplification levels depends on the R&S FSW model.

R&S FSW8/13: 15dB and 30 dB

R&S FSW26 or higher: 30 dB

All other values are rounded to the nearest of these two.

*RST: OFF
Example: INP:GAIN:VAL 30

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


Scaling the Y-Axis

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis
Scaling the Y-Axis
List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y:SPACing


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe] <Range>

This command defines the display range of the y-axis.

Parameters:
<Range>
Range: | 1 dB to 200 dB
*RST: | 100 dB
Example: DISP:TRAC:Y 110dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Range"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

Automatic scaling of the y-axis is performed once, then switched off again.

Usage: SCPI confirmed


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE <Mode>

This command selects the type of scaling of the y-axis.

When the display update during remote control is off, this command has no immediate effect.

Parameters:
<Mode>
ABSolute

absolute scaling of the y-axis

RELative

relative scaling of the y-axis

*RST: ABSolute
Example: DISP:TRAC:Y:MODE REL
Manual operation: See "Scaling"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition <Position>

This command defines the vertical position of the reference level on the display grid.

The R&S FSW adjusts the scaling of the y-axis accordingly.

Example:

DISP:TRAC:Y:RPOS 50PCT

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Ref Level Position"


DISPlay[:WINDow<n>]:TRACe:Y:SPACing

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y:SPACing
DISPlay[:WINDow<n>]:TRACe:Y:SPACing <ScalingType>

This command selects the scaling of the y-axis.

Parameters:
<ScalingType>
LOGarithmic

Logarithmic scaling.

LINear

Linear scaling in %.

LDB

Linear scaling in the specified unit.

PERCent

Linear scaling in %.

*RST: LOGarithmic
Example: DISP:TRAC:Y:SPAC LIN

Selects linear scaling in %.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Scaling"


Defining the Frequency and Span

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Defining the Frequency and Span
Defining the Frequency and Span

The commands required to configure the frequency and span settings in a remote environment are described here. The tasks for manual operation are described in "Frequency and Span Settings" .

List of Commands
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:LINK
[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor
[SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:SPAN
[SENSe:]FREQuency:SPAN:FULL
[SENSe:]FREQuency:STARt
[SENSe:]FREQuency:STOP


[SENSe:]FREQuency:CENTer

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Defining the Frequency and Span > [SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer <Frequency>

This command defines the center frequency.

Parameters:
<Frequency>

The allowed range and fmax is specified in the data sheet.

UP

Increases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

DOWN

Decreases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

*RST: | fmax/2
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Center frequency"


[SENSe:]FREQuency:CENTer:STEP

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Defining the Frequency and Span > [SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP <StepSize>

This command defines the center frequency step size.

Parameters:
<StepSize>

fmax is specified in the data sheet.

Range: | 1 to fMAX
*RST: | 0.1 x span
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Manual operation: See "Center Frequency Stepsize"


[SENSe:]FREQuency:CENTer:STEP:AUTO

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Defining the Frequency and Span > [SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:AUTO <State>

This command couples or decouples the center frequency step size to the span.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: FREQ:CENT:STEP:AUTO ON

Activates the coupling of the step size to the span.


[SENSe:]FREQuency:CENTer:STEP:LINK

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Defining the Frequency and Span > [SENSe:]FREQuency:CENTer:STEP:LINK
[SENSe:]FREQuency:CENTer:STEP:LINK <CouplingType>

This command couples and decouples the center frequency step size to the span or the resolution bandwidth.

Parameters:
<CouplingType>
SPAN

Couples the step size to the span. Available for measurements in the frequency domain.

OFF

Decouples the step size.

*RST: SPAN
Example: FREQ:CENT:STEP:LINK SPAN


[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Defining the Frequency and Span > [SENSe:]FREQuency:CENTer:STEP:LINK:FACTor
[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor <Factor>
Parameters:
<Factor>
1 to 100 PCT
*RST: 10
Example: FREQ:CENT:STEP:LINK:FACT 20PCT


[SENSe:]FREQuency:OFFSet

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Defining the Frequency and Span > [SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:OFFSet <Offset>

This command defines a frequency offset.

If this value is not 0 Hz, the application assumes that the input signal was frequency shifted outside the application. All results of type "frequency" will be corrected for this shift numerically by the application.

Note: In MSRA/MSRT mode, the setting command is only available for the MSRA/MSRT Master. For MSRA/MSRT applications, only the query command is available.

Parameters:
<Offset>
Range: | -100 GHz to 100 GHz
*RST: | 0 Hz
Example: FREQ:OFFS 1GHZ
Usage: SCPI confirmed
Manual operation: See "Frequency Offset"


[SENSe:]FREQuency:SPAN

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Defining the Frequency and Span > [SENSe:]FREQuency:SPAN
[SENSe:]FREQuency:SPAN <Span>

This command defines the frequency span.

Parameters:
<Span>
Range: | 1 kHz to 100 MHz (Multi-domain), 160 MHz (High-resolution measurement)
*RST: | fmax
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Span"
See "Last Span"


[SENSe:]FREQuency:SPAN:FULL

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Defining the Frequency and Span > [SENSe:]FREQuency:SPAN:FULL
[SENSe:]FREQuency:SPAN:FULL

This command restores the full span.

Usage: | Event SCPI confirmed
Manual operation: | See "Full Span"


[SENSe:]FREQuency:STARt

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Defining the Frequency and Span > [SENSe:]FREQuency:STARt
[SENSe:]FREQuency:STARt <Frequency>

Defines the start frequency for a realtime measurement. If you set a start frequency that would exceed the maximum span (100 MHz for Multi-domain, 160 MHz for High-resolution measurement), the R&S FSW adjusts the stop frequency to stay within the maximum span.

Parameters:
<Frequency>
0 to (fmax - min span)
*RST: 0
Example: FREQ:STAR 20MHz
Usage: SCPI confirmed
Manual operation: See "Start / Stop"


[SENSe:]FREQuency:STOP

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Defining the Frequency and Span > [SENSe:]FREQuency:STOP
[SENSe:]FREQuency:STOP <Frequency>

Defines the stop frequency for a realtime measurement. If you set a start frequency that would exceed the maximum span (100 MHz for Multi-domain, 160 MHz for High-resolution measurement), the R&S FSW adjusts the start frequency to stay within the maximum span.

Parameters:
<Frequency>
min span to fmax
*RST: fmax
Example: FREQ:STOP 2000 MHz
Usage: SCPI confirmed
Manual operation: See "Start / Stop"


Configuring Bandwidth and Sweep Settings

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Bandwidth and Sweep Settings
Configuring Bandwidth and Sweep Settings

The commands required to configure the bandwidth, sweep and filter settings in a remote environment are described here. The tasks for manual operation are described in "Bandwidth and Sweep Settings".

Useful commands for configuring sweeps described elsewhere:
  • [SENSe:​]AVERage:​COUNt
Remote commands exclusive to configuring bandwidth and sweeps:
List of Commands
[SENSe:]BANDwidth|BWIDth[:RESolution]
[SENSe:]BANDwidth|BWIDth[:RESolution]:RATio
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:FFT:WINDow:TYPE
[SENSe<n>:]SWEep:TIME
[SENSe:]SWEep:TIME:AUTO


[SENSe:]BANDwidth|BWIDth[:RESolution]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Bandwidth and Sweep Settings > [SENSe:]BANDwidth|BWIDth[:RESolution]
[SENSe:]BANDwidth|BWIDth[:RESolution] <Bandwidth>

This command defines the resolution bandwidth and decouples the resolution bandwidth from the span.

In the Realtime application, the resolution bandwidth is always coupled to the span.

Parameters:
<Bandwidth>
refer to data sheet
Example: BAND 1 MHz

Sets the resolution bandwidth to 1 MHz

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "RBW"


[SENSe:]BANDwidth|BWIDth[:RESolution]:RATio

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Bandwidth and Sweep Settings > [SENSe:]BANDwidth|BWIDth[:RESolution]:RATio
[SENSe:]BANDwidth|BWIDth[:RESolution]:RATio <Ratio>

This command defines the ratio between the resolution bandwidth (Hz) and the span (Hz).

Note that the ratio defined with the remote command (RBW/span) is reciprocal to that of the manual operation (span/RBW).

Parameters:
<Ratio>
Range: 0.0001 to 1
Example: BAND:RAT 0.1
Example:

"Example 3: Analyzing Persistency"

Usage: SCPI confirmed
Manual operation: See "Span/RBW"


[SENSe:]SWEep:COUNt

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Bandwidth and Sweep Settings > [SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt <SweepCount>

This command defines the number of sweeps that the application uses to average traces.

(For Pulse measurements, see also "Trace Statistics" ).

In case of continuous sweeps, the application calculates the moving average over the average count.

In case of single sweeps, the application stops the measurement and calculates the average after the average count has been reached.

Example: SWE:COUN 64

Sets the number of sweeps to 64.

INIT:CONT OFF

Switches to single sweep mode.

INIT;*WAI

Starts a sweep and waits for its end.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Sweep Count"


[SENSe:]SWEep:FFT:WINDow:TYPE

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Bandwidth and Sweep Settings > [SENSe:]SWEep:FFT:WINDow:TYPE
[SENSe:]SWEep:FFT:WINDow:TYPE <FFTWindow>

This command selects the type of FFT window that you want to use in realtime mode.

Parameters:
<FFTWindow>
BLACkharris
FLATtop
GAUSsian
HAMMing
HANNing
KAISerbessel
RECTangular
*RST: BLACkharris
Example: SWE:FFT:WIND:TYPE HANN

Selects the Hanning FFT window.

Example:

See "Example 3: Analyzing Persistency".

Example:

See "Example 4: Obtaining Time Domain Results in Realtime".

Manual operation: See "FFT Window"


[SENSe<n>:]SWEep:TIME

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Bandwidth and Sweep Settings > [SENSe<n>:]SWEep:TIME
[SENSe<n>:]SWEep:TIME <Time>

Determines the amount of time used to sample data for one spectrum or one PVT diagram.

For more information see "Sweep Time and Detector".

Suffix: |
<n> | 1..6 Window For realtime measurements, this suffix is relevant to distinguish between the PVT sweep time and the spectrum sweep time.
Parameters:
<Time> | refer to data sheet
Example: | Window 1: Realtime Spectrum Window 2: PVT diagram SWE:TIME 0.3s SENS2:SWE:TIME 0.128s
Example: | See "Example 4: Obtaining Time Domain Results in Realtime".
Usage: | SCPI confirmed
Manual operation: | See "Sweep Time" See "PVT Sweep Time"


[SENSe:]SWEep:TIME:AUTO

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Bandwidth and Sweep Settings > [SENSe:]SWEep:TIME:AUTO
[SENSe:]SWEep:TIME:AUTO <State>

This command activates and deactivates automatic sweep time definition.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: SWE:TIME:AUTO ON

Activates automatic sweep time.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Sweep Time"


Triggering

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering
Triggering

The following remote commands are required to configure a triggered measurement in a remote environment. In MSRT mode, these commands are only available for the MSRT Master channel. More details are described for manual operation in "Trigger Configuration".

*OPC should be used after requesting data. This will hold off any subsequent changes to the selected trigger source, until after the sweep is completed and the data is returned.

Contents
  • Configuring the Triggering Conditions
  • Configuring a Frequency Mask Trigger
  • Configuring the Trigger Output


Configuring the Triggering Conditions

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring the Triggering Conditions
Configuring the Triggering Conditions
List of Commands
TRIGger:MODE
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:POSTtrigger[:TIME]
TRIGger[:SEQuence]:PRETrigger[:TIME]
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:TDTRigger:LEVel


TRIGger:MODE

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring the Triggering Conditions > TRIGger:MODE
TRIGger:MODE <Mode>

This command turns continuous triggering on and off.

Parameters:
<Mode>
CONTinuous

Continuous measurement

STOP

Measurement stops after the trigger event is done

*RST: CONTinuous
Example:

See "Example 2: Performing a Basic Realtime Measurement".

Example:

See "Example 3: Analyzing Persistency".

Example:

See "Example 4: Obtaining Time Domain Results in Realtime".

Manual operation: See "Trigger mode (Auto Rearm/ Stop on Trigger)"


TRIGger[:SEQuence]:HOLDoff[:TIME]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:HOLDoff[:TIME] <Offset>

Defines the time offset between the trigger event and the start of the sweep (data capturing).

Parameters:
<Offset>
*RST: 0 s
Example: TRIG:HOLD 500us
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger Offset"


TRIGger[:SEQuence]:LEVel[:EXTernal<port>]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel[:EXTernal<port>] <TriggerLevel>

This command defines the level the external signal must exceed to cause a trigger event.

Suffix:
<port>

Selects the trigger port.

1 = trigger port 1 (TRIGGER INPUT connector on front panel)

2 = trigger port 2 (TRIGGER INPUT/OUTPUT connector on front panel)

3 = trigger port 3 (TRIGGER3 INPUT/OUTPUT connector on rear panel)

Parameters:
<TriggerLevel>
Range: | 0.5 V to 3.5 V
*RST: | 1.4 V
Example: TRIG:LEV 2V
Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:POSTtrigger[:TIME]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:POSTtrigger[:TIME]
TRIGger[:SEQuence]:POSTtrigger[:TIME] <Time>

This command defines the length of the posttrigger.

Parameters:
<Time>

Length of the posttrigger in seconds.

Note that the pre- and posttrigger combined may not be longer than 1 second.

Range: | 0 s to 1 s
*RST: | 60 ms
Example: TRIG:POST 0.5s

Selects a posttrigger time of 0.5 seconds.

Example:

See "Example 2: Performing a Basic Realtime Measurement".

Example:

See "Example 3: Analyzing Persistency".

Example:

See "Example 4: Obtaining Time Domain Results in Realtime".

Manual operation: See "Posttrigger capture time"


TRIGger[:SEQuence]:PRETrigger[:TIME]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:PRETrigger[:TIME]
TRIGger[:SEQuence]:PRETrigger[:TIME] <Time>

This command defines the length of the pretrigger.

Parameters:
<Time>

Length of the pretrigger in seconds.

Note that the pre- and posttrigger combined may not be longer than 1 second.

Range: | 0 s to 1 s
*RST: | 60 ms
Example: TRIG:PRE 0.5s

Selects a pretrigger time of 0.5 seconds.

Example:

See "Example 2: Performing a Basic Realtime Measurement".

Example:

See "Example 3: Analyzing Persistency".

Example:

See "Example 4: Obtaining Time Domain Results in Realtime".

Manual operation: See "Pretrigger capture time"


TRIGger[:SEQuence]:SLOPe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SLOPe <Type>

For external and time domain trigger sources you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Parameters:
<Type>
POSitive | NEGative
POSitive

Triggers when the signal rises to the trigger level (rising edge).

NEGative

Triggers when the signal drops to the trigger level (falling edge).

*RST: POSitive
Example: TRIG:SLOP NEG
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Slope"


TRIGger[:SEQuence]:SOURce

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:SOURce <Source>

This command selects the trigger source.

Note on external triggers:

If a measurement is configured to wait for an external trigger signal in a remote control program, remote control is blocked until the trigger is received and the program can continue. Make sure this situation is avoided in your remote control programs.

Parameters:
<Source>
IMMediate

Free Run

EXTernal

Trigger signal from the TRIGGER INPUT connector.

EXT2

Trigger signal from the TRIGGER INPUT/OUTPUT connector.

Note: Connector must be configured for "Input".

EXT3

Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector.

Note: Connector must be configured for "Input".

MASK

Triggers when the measured signal violates the user-defined frequency mask.

For details see "Frequency Mask Trigger".

TDTR

Triggers when the measured signal exceeds the defined power level in the time domain.

*RST: IMMediate
Example: TRIG:SOUR EXT

Selects the external trigger input as source of the trigger signal

Example:

See "Example 2: Performing a Basic Realtime Measurement" and "Example 4: Obtaining Time Domain Results in Realtime".

Example:

See "Basic I/Q Analysis with Improved Performance" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Example:

See "Programming Example" .

Manual operation: See "Trigger Source"
See "Free Run"
See "External Trigger 1/2/3"
See "Frequency Mask"
See "Time Domain"


TRIGger[:SEQuence]:TDTRigger:LEVel

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:TDTRigger:LEVel
TRIGger[:SEQuence]:TDTRigger:LEVel <TriggerLevel>

This command sets the trigger level for the time domain trigger.

Parameters:
<TriggerLevel>
Default unit: dBm
Example: TRIG:TDTR:LEV 0

Sets a trigger level of 0 dBm.

Example:

See "Example 4: Obtaining Time Domain Results in Realtime".

Manual operation: See "Time Domain"
See "Trigger Level"


Configuring a Frequency Mask Trigger

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring a Frequency Mask Trigger
Configuring a Frequency Mask Trigger

The Frequency Mask Trigger (FMT) is a mask in the frequency domain, which is checked with every calculated FFT. When a specific condition concerning this mask occurs during the measurement of the input signal, data capturing is triggered.

For details see "Frequency Mask Trigger".

List of Commands
CALCulate<n>:MASK:CDIRectory
CALCulate<n>:MASK:COMMent
CALCulate<n>:MASK:DELete
CALCulate<n>:MASK:LOWer:SHIFt:X
CALCulate<n>:MASK:LOWer:SHIFt:Y
CALCulate<n>:MASK:LOWer:STATe
CALCulate<n>:MASK:LOWer[:DATA]
CALCulate<n>:MASK:MODE
CALCulate<n>:MASK:NAME
CALCulate<n>:MASK:SPAN
CALCulate<n>:MASK:UPPer:AUTO
CALCulate<n>:MASK:UPPer:SHIFt:X
CALCulate<n>:MASK:UPPer:SHIFt:Y
CALCulate<n>:MASK:UPPer:STATe
CALCulate<n>:MASK:UPPer[:DATA]
TRIGger[:SEQuence]:MASK:CONDition


CALCulate<n>:MASK:CDIRectory

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring a Frequency Mask Trigger > CALCulate<n>:MASK:CDIRectory
CALCulate<n>:MASK:CDIRectory <Subdirectory>

This command selects the directory the R&S FSW stores frequency masks in.

Parameters:
<Subdirectory> | String containing the path to the directory. The directory has to be a subdirectory of the default directory. Thus the path is always relative to the default directory (C:\R_S\INSTR\freqmask). An empty string selects the default directory.
Example: | See "Example 1: Creating a Frequency Mask Trigger".
Example: | See "Example 2: Performing a Basic Realtime Measurement".
Manual operation: | See "Save Mask" See "Load Mask"


CALCulate<n>:MASK:COMMent

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring a Frequency Mask Trigger > CALCulate<n>:MASK:COMMent
CALCulate<n>:MASK:COMMent <Comment>

This command defines a comment for the frequency mask that you have selected with CALCulate<n>:​MASK:​NAME .

Parameters:
<Comment> | String containing the comment for the frequency mask.
Example: | See "Example 1: Creating a Frequency Mask Trigger".
Manual operation: | See "Comment"


CALCulate<n>:MASK:DELete

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring a Frequency Mask Trigger > CALCulate<n>:MASK:DELete
CALCulate<n>:MASK:DELete

This command deletes the currently selected frequency mask.

Before making any changes to a frequency mask, you have to select one by name with CALCulate<n>:​MASK:​NAME .

Usage: | Event
Manual operation: | See "Delete Mask"


CALCulate<n>:MASK:LOWer:SHIFt:X

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring a Frequency Mask Trigger > CALCulate<n>:MASK:LOWer:SHIFt:X
CALCulate<n>:MASK:LOWer:SHIFt:X <Frequency>

This command shifts the lower frequency mask horizontally by a specified distance. Positive values move the mask to the right, negative values shift the mask to the left.

Before making any changes to a frequency mask, you have to select one by name with CALCulate<n>:​MASK:​NAME .

Parameters:
<Frequency>

Defines the distance of the shift.

Default unit: Hz
Manual operation: See "Shifting the mask position horizontally (Shift x)"


CALCulate<n>:MASK:LOWer:SHIFt:Y

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring a Frequency Mask Trigger > CALCulate<n>:MASK:LOWer:SHIFt:Y
CALCulate<n>:MASK:LOWer:SHIFt:Y <Level>

This command shifts the lower frequency mask vertically by a specified distance. Positive values move the mask upwards, negative values shift the mask downwards.

Before making any changes to a frequency mask, you have to select one by name with CALCulate<n>:​MASK:​NAME .

Parameters:
<Level>

Defines the distance of the shift. The shift is relative to the current position.

Default unit: dB
Example:

See "Example 1: Creating a Frequency Mask Trigger".

Manual operation: See "Shifting the mask vertically (Shift y)"


CALCulate<n>:MASK:LOWer:STATe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring a Frequency Mask Trigger > CALCulate<n>:MASK:LOWer:STATe
CALCulate<n>:MASK:LOWer:STATe <State>

This command turns the lower frequency mask on and off.

Before making any changes to a frequency mask, you have to select one by name with CALCulate<n>:​MASK:​NAME .

Parameters:
<State> | ON | OFF
Example: | See "Example 1: Creating a Frequency Mask Trigger".
Manual operation: | See "Activating/deactivating upper and lower masks"


CALCulate<n>:MASK:LOWer[:DATA]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring a Frequency Mask Trigger > CALCulate<n>:MASK:LOWer[:DATA]
CALCulate<n>:MASK:LOWer[:DATA] <Frequency>,<Level>,...

This command defines the shape of the lower frequency mask.

Before making any changes to a frequency mask, you have to select one by name with CALCulate<n>:​MASK:​NAME .

The unit of the power levels depends on CALCulate<n>:​MASK:​MODE.

If you are using the command with the vector network analysis option (R&S FSW-K70), you can only use this command as a query.

Parameters:
<Frequency>, <Level> | [N] pairs of numerical values. [N] is the number of data points the mask consists of. Each data point is defined by the frequency (in Hz) and the level (in dB or dBm). All values are separated by commas. Note that the data points have to be inside the current span.
Example: | See "Example 1: Creating a Frequency Mask Trigger".
Manual operation: | See "Mask points" See "Inserting points" See "Deleting points"


CALCulate<n>:MASK:MODE

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring a Frequency Mask Trigger > CALCulate<n>:MASK:MODE
CALCulate<n>:MASK:MODE <Mode>

This command defines the scaling of the level axis for frequency masks.

Parameters:
<Mode>
ABSolute

absolute scaling of the level axis.

RELative

relative scaling of the level axis.

*RST: RELative
Example:

See "Example 1: Creating a Frequency Mask Trigger".

Manual operation: See "Changing the y-axis scaling (Y-Axis rel/abs)"


CALCulate<n>:MASK:NAME

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring a Frequency Mask Trigger > CALCulate<n>:MASK:NAME
CALCulate<n>:MASK:NAME <Name>

This command creates or selects a frequency mask with the name that you specify by the parameter. When you use it as a query, the command returns the name of the mask currently in use.

Parameters:
<Name> | String containing the name of the mask. Note that an empty string does not select a frequency mask.
Example: | See "Example 1: Creating a Frequency Mask Trigger".
Example: | See "Example 2: Performing a Basic Realtime Measurement".
Manual operation: | See "New Mask" See "Save Mask" See "Load Mask" See "Name"


CALCulate<n>:MASK:SPAN

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring a Frequency Mask Trigger > CALCulate<n>:MASK:SPAN
CALCulate<n>:MASK:SPAN <Span>

This command defines the frequency span of the frequency mask.

Parameters:
<Span>
Range: | 1 kHz to (100 MHz for Multi-domain, 160 MHz for High-resolution measurement)
*RST: | fmax
Example: CALC:MASK:SPAN 10 MHz

Defines a span of 10 MHz.

Example:

See "Example 1: Creating a Frequency Mask Trigger".


CALCulate<n>:MASK:UPPer:AUTO

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring a Frequency Mask Trigger > CALCulate<n>:MASK:UPPer:AUTO
CALCulate<n>:MASK:UPPer:AUTO

This command automatically defines the shape of an upper frequency mask according to the spectrum that is currently measured.

Example: | See "Example 1: Creating a Frequency Mask Trigger".
Usage: | Event
Manual operation: | See "Defining a mask automatically (Auto-Set Mask)"


CALCulate<n>:MASK:UPPer:SHIFt:X

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring a Frequency Mask Trigger > CALCulate<n>:MASK:UPPer:SHIFt:X
CALCulate<n>:MASK:UPPer:SHIFt:X <Frequency>

This command shifts the lower frequency mask horizontally by a specified distance. Positive values move the mask to the right, negative values shift the mask to the left.

You have to select a mask before you can use this command with CALCulate<n>:​MASK:​NAME .

Parameters:
<Frequency> | Defines the distance of the shift.
Manual operation: | See "Shifting the mask position horizontally (Shift x)"


CALCulate<n>:MASK:UPPer:SHIFt:Y

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring a Frequency Mask Trigger > CALCulate<n>:MASK:UPPer:SHIFt:Y
CALCulate<n>:MASK:UPPer:SHIFt:Y <Level>

This command shifts the upper frequency mask vertically by a specified distance. Positive values move the mask upwards, negative values shift the mask downwards.

You have to select a mask before you can use this command with CALCulate<n>:​MASK:​NAME .

Parameters:
<Level>

Defines the distance of the shift. The shift is relative to the current position.

Default unit: dB
Manual operation: See "Shifting the mask vertically (Shift y)"


CALCulate<n>:MASK:UPPer:STATe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring a Frequency Mask Trigger > CALCulate<n>:MASK:UPPer:STATe
CALCulate<n>:MASK:UPPer:STATe <State>

This command turns the upper frequency mask on and off.

Before making any changes to a frequency mask, you have to select one by name with CALCulate<n>:​MASK:​NAME .

Parameters:
<State> | ON | OFF
Manual operation: | See "Activating/deactivating upper and lower masks"


CALCulate<n>:MASK:UPPer[:DATA]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring a Frequency Mask Trigger > CALCulate<n>:MASK:UPPer[:DATA]
CALCulate<n>:MASK:UPPer[:DATA] <Frequency>,<Level>,...

This command activates and defines the shape of the upper frequency mask trigger mask.

You have to select a mask before you can use this command with CALCulate<n>:​MASK:​NAME .

The unit of the power levels depends on CALCulate<n>:​MASK:​MODE.

Parameters:
<Frequency>, <Level> | [N] pairs of numerical values. [N] is the number of data points the mask consists of. Each data point is defined by the frequency (in Hz) and the amplitude (in dB or dBm). All values are separated by commas. Note that the data points have to be inside the current span.
Example: | See "Example 1: Creating a Frequency Mask Trigger".
Manual operation: | See "Mask points" See "Inserting points" See "Deleting points"


TRIGger[:SEQuence]:MASK:CONDition

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring a Frequency Mask Trigger > TRIGger[:SEQuence]:MASK:CONDition
TRIGger[:SEQuence]:MASK:CONDition <Condition>

This command sets the condition that activates the frequency mask trigger.

For details see "Frequency Mask Trigger".

Parameters:
<Condition>
ENTer

Triggers on entering the frequency mask.

LEAVing

Triggers on leaving the frequency mask.

*RST: INSide
Example:

See "Example 2: Performing a Basic Realtime Measurement".

Example:

See "Example 3: Analyzing Persistency".

Manual operation: See "Setting the trigger condition"


Configuring the Trigger Output

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring the Trigger Output
Configuring the Trigger Output

The following commands are required to send the trigger signal to one of the variable TRIGGER INPUT/OUTPUT connectors. The tasks for manual operation are described in "Trigger 2/3".

List of Commands
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth


OUTPut:TRIGger<port>:DIRection

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:DIRection <Direction>

This command selects the trigger direction.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Direction>
INPut

Port works as an input.

OUTPut

Port works as an output.

*RST: INPut
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"


OUTPut:TRIGger<port>:LEVel

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:LEVel <Level>

This command defines the level of the signal generated at the trigger output.

This command works only if you have selected a user defined output with OUTPut:​TRIGger<port>:​OTYPe.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Level>
HIGH

TTL signal.

LOW

0 V

*RST: LOW
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"
See "Level"


OUTPut:TRIGger<port>:OTYPe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:OTYPe <OutputType>

This command selects the type of signal generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<OutputType>
DEVice

Sends a trigger signal when the R&S FSW has triggered internally.

TARMed

Sends a trigger signal when the trigger is armed and ready for an external trigger event.

UDEFined

Sends a user defined trigger signal. For more information see OUTPut:​TRIGger<port>:​LEVel.

*RST: DEVice
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Output Type"


OUTPut:TRIGger<port>:PULSe:IMMediate

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:IMMediate

This command generates a pulse at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: Event
Manual operation: See "Send Trigger"


OUTPut:TRIGger<port>:PULSe:LENGth

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:LENGth
OUTPut:TRIGger<port>:PULSe:LENGth <Length>

This command defines the length of the pulse generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Length>

Pulse length in seconds.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Pulse Length"


Configuring Spectrograms and PVT Waterfalls

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Spectrograms and PVT Waterfalls
Configuring Spectrograms and PVT Waterfalls

The remote commands required for the individual settings available for spectrogram and waterfall displays are described here. For color mapping commands, see "Configuring Color Maps".

Note that these commands are applicable for both spectrograms and PVT waterfalls. The suffix <n> for CALCulate determines the window and thus which display the command is applied to.

List of Commands
CALCulate<n>:SGRam|SPECtrogram:CLEar[:IMMediate]
CALCulate<n>:SGRam|SPECtrogram:FRAMe:SELect
CALCulate<n>:SGRam|SPECtrogram:HDEPth
CALCulate<n>:SGRam|SPECtrogram:TSTamp:DATA?
CALCulate<n>:SGRam|SPECtrogram:TSTamp[:STATe]


CALCulate<n>:SGRam|SPECtrogram:CLEar[:IMMediate]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Spectrograms and PVT Waterfalls > CALCulate<n>:SGRam|SPECtrogram:CLEar[:IMMediate]
CALCulate<n>:SGRam|SPECtrogram:CLEar[:IMMediate]

This command resets the spectrogram or PVT waterfall and clears the history buffer.

Note that this command is applicable for both spectrograms and PVT waterfalls. The suffix <n> for CALCulate determines the window and thus which display the command is applied to.

Suffix: |
<n> | 1 to 6 window
Example: | CALC:SGR:CLE Resets the result display and clears the memory.
Example: | See "Example 2: Performing a Basic Realtime Measurement".
Example: | See "Example 3: Analyzing Persistency".
Example: | See "Example 4: Obtaining Time Domain Results in Realtime".
Usage: | Event
Manual operation: | See "Clear Spectrogram" See "Clear Power vs Time Waterfall"


CALCulate<n>:SGRam|SPECtrogram:FRAMe:SELect

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Spectrograms and PVT Waterfalls > CALCulate<n>:SGRam|SPECtrogram:FRAMe:SELect
CALCulate<n>:SGRam|SPECtrogram:FRAMe:SELect <Frame> | <Time>

This command selects a specific frame for further analysis.

The command is available if no measurement is running or after a single sweep has ended.

Note that this command is applicable for both spectrograms and PVT waterfalls. The suffix <n> for CALCulate determines the window and thus which display the command is applied to.

Suffix: |
<n> | 1 to 6 window
Parameters:
<Frame> | Selects a frame directly by the frame number. Valid if the time stamp is off. The range depends on the history depth.
<Time> | Selects a frame via its time stamp. Valid if the time stamp is on. The number is the distance to frame 0 (most recent frame) in seconds. The range depends on the history depth.
Example: | INIT:CONT OFF Stop the continuous sweep. CALC:SGR:FRAM:SEL -25 Selects frame number -25.
Example: | See "Example 4: Obtaining Time Domain Results in Realtime".
Manual operation: | See "Selecting a frame to display"


CALCulate<n>:SGRam|SPECtrogram:HDEPth

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Spectrograms and PVT Waterfalls > CALCulate<n>:SGRam|SPECtrogram:HDEPth
CALCulate<n>:SGRam|SPECtrogram:HDEPth <History>

This command defines the number of frames to be stored in the R&S FSW memory for the spectrogram or PVT waterfall result display.

Note that this command is applicable for both spectrograms and PVT waterfalls. The suffix <n> for CALCulate determines the window and thus which display the command is applied to.

Suffix:
<n>
1 to 6

window

Parameters:
<History>
Range: | 781 to 100000
Increment: | 1
*RST: | 3000
Example: CALC:SGR:SPEC 1500

Sets the history depth to 1500.

Example:

See "Example 2: Performing a Basic Realtime Measurement".

Example:

See "Example 4: Obtaining Time Domain Results in Realtime".

Manual operation: See "History Depth"


CALCulate<n>:SGRam|SPECtrogram:TSTamp:DATA?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Spectrograms and PVT Waterfalls > CALCulate<n>:SGRam|SPECtrogram:TSTamp:DATA?
CALCulate<n>:SGRam|SPECtrogram:TSTamp:DATA? <Frames>

This command queries the starting time of the frames.

The return values consist of four values for each frame. If the Spectrogram is empty, the command returns '0,0,0,0'. The times are given as delta values, which simplifies evaluating relative results; however, you can also calculate the absolute date and time as displayed on the screen.

Note that this command is applicable for both spectrograms and PVT waterfalls. The suffix <n> for CALCulate determines the window and thus which display the command is applied to.

The frame results themselves are returned with TRAC:DATA? SGR

See TRACe<n>[:​DATA]?

Suffix: |
<n> | 1 to 6 window
Query parameters:
<Frames> | CURRent Returns the starting time of the current frame. ALL Returns the starting time for all frames. The results are sorted in descending order, beginning with the current frame.
Return values:
<Seconds> | Number of seconds that have passed since 01.01.1970 till the frame start
<Nanoseconds> | Number of nanoseconds that have passed in addition to the <Seconds> since 01.01.1970 till the frame start.
<Reserved> | The third and fourth value are reserved for future uses.
Example: | CALC:SGR:TST ON Activates the time stamp. CALC:SGR:TST:DATA? ALL Returns the starting times of all frames sorted in a descending order.
Example: | See "Example 2: Performing a Basic Realtime Measurement".
Usage: | Query only
Manual operation: | See "Time Stamp"


CALCulate<n>:SGRam|SPECtrogram:TSTamp[:STATe]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Spectrograms and PVT Waterfalls > CALCulate<n>:SGRam|SPECtrogram:TSTamp[:STATe]
CALCulate<n>:SGRam|SPECtrogram:TSTamp[:STATe] <State>

This command activates and deactivates the time stamp.

If the time stamp is active, some commands do not address frames as numbers, but as (relative) time values:

  • CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​FRAMe
  • CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​FRAMe
  • CALCulate<n>:​SGRam|SPECtrogram:​FRAMe:​SELect

Note that this command is applicable for both spectrograms and PVT waterfalls. The suffix <n> for CALCulate determines the window and thus which display the command is applied to.

Suffix:
<n>
1 to 6

window

Parameters:
<State>
ON | OFF
*RST: ON
Example: CALC:SGR:TST OFF

Deactivates the time stamp.

Example:

See "Example 4: Obtaining Time Domain Results in Realtime".

Manual operation: See "Time Stamp"


Configuring the Persistence Spectrum

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Persistence Spectrum
Configuring the Persistence Spectrum

You can customize the persistence spectrum in several ways. You can change the colors with which the densities are visualized, you can change the persistence of the data and change the style of the displayed results.

Compatibility with R&S FSVR

For compatiblity with the R&S FSVR, the following commands required to configure the persistence spectrum also accept the optional SUBWindow keyword (DISPlay:WINDow[:SUBWindow]...). However, this keyword is ignored and has no effect on remote control.

List of Commands
DISPlay:WINDow:[SUBWindow:]TRACe:MAXHold:RESet
DISPlay:WINDow:[SUBWindow:]TRACe:MAXHold:INTensity
DISPlay:WINDow:[SUBWindow:]TRACe:MAXHold[:STATe]
DISPlay:WINDow:[SUBWindow:]TRACe:PERSistence:DURation
DISPlay:WINDow:[SUBWindow:]TRACe:PERSistence:GRANularity
DISPlay:WINDow:[SUBWindow:]TRACe:PERSistence[:STATe]
DISPlay:WINDow:[SUBWindow:]TRACe:SYMBol


DISPlay:WINDow:[SUBWindow:]TRACe:MAXHold:RESet

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Persistence Spectrum > DISPlay:WINDow:[SUBWindow:]TRACe:MAXHold:RESet
DISPlay:WINDow:[SUBWindow:]TRACe:MAXHold:RESet

This command resets the maxhold trace in the persistence spectrum result display.

Example: | See "Example 3: Analyzing Persistency".
Usage: | Event
Manual operation: | See "Resetting the Maxhold Function"


DISPlay:WINDow:[SUBWindow:]TRACe:MAXHold:INTensity

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Persistence Spectrum > DISPlay:WINDow:[SUBWindow:]TRACe:MAXHold:INTensity
DISPlay:WINDow:[SUBWindow:]TRACe:MAXHold:INTensity <Intensity>

This command defines the color intensity of the maxhold persistence spectrum.

Note: Setting the intensity to 0 has the same effect as deactivating the Maxhold function (see DISPlay:​WINDow:​[SUBWindow:​]TRACe:​MAXHold[:​STATe]).

Parameters:
<Intensity>

Sets the color intensity of the maxhold trace.

Range: | 0 to 254
Increment: | 1
*RST: | 100
Example: DISP:WIND:TRAC:MAXH:INT 120

Sets the color intensity of the maxhold trace to 120.

Example:

See "Example 3: Analyzing Persistency".

Manual operation: See "Intensity"


DISPlay:WINDow:[SUBWindow:]TRACe:MAXHold[:STATe]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Persistence Spectrum > DISPlay:WINDow:[SUBWindow:]TRACe:MAXHold[:STATe]
DISPlay:WINDow:[SUBWindow:]TRACe:MAXHold[:STATe] <State>

This command switches the maxhold trace in the persistence spectrum on and off.

Note: Setting the intensity to 0 has the same effect as deactivating the Maxhold function (see DISPlay:​WINDow:​[SUBWindow:​]TRACe:​MAXHold:​INTensity).

Parameters:
<State>
ON | OFF
*RST: On
Example:

See "Example 3: Analyzing Persistency".

Manual operation: See "Configuring the Maxhold Function"


DISPlay:WINDow:[SUBWindow:]TRACe:PERSistence:DURation

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Persistence Spectrum > DISPlay:WINDow:[SUBWindow:]TRACe:PERSistence:DURation
DISPlay:WINDow:[SUBWindow:]TRACe:PERSistence:DURation <Persistence>

This command sets the duration of the persistence.

Setting the persistence to 0 turns it off and thus has the same effect as the command DISP:WIND:TRAC:PERS OFF (see DISPlay:​WINDow:​[SUBWindow:​]TRACe:​PERSistence[:​STATe]).

Parameters:
<Persistence>

Persistance in seconds.

Range: | 0 to 8
Increment: | 0.001
*RST: | 1 seconds
Default unit: | seconds
Example: DISP:WIND:TRAC:PERS:DUR 4.3

Sets the persistence to 4.3 seconds.

Example:

See "Example 3: Analyzing Persistency".

Manual operation: See "Persistence"


DISPlay:WINDow:[SUBWindow:]TRACe:PERSistence:GRANularity

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Persistence Spectrum > DISPlay:WINDow:[SUBWindow:]TRACe:PERSistence:GRANularity
DISPlay:WINDow:[SUBWindow:]TRACe:PERSistence:GRANularity <Granularity>

Defines the duration that data is captured to build one persistence spectrum.

Parameters:
<Granularity>
duration in seconds
*RST: 0.1s
Example:

See "Example 3: Analyzing Persistency".

Manual operation: See "Granularity"


DISPlay:WINDow:[SUBWindow:]TRACe:PERSistence[:STATe]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Persistence Spectrum > DISPlay:WINDow:[SUBWindow:]TRACe:PERSistence[:STATe]
DISPlay:WINDow:[SUBWindow:]TRACe:PERSistence[:STATe] <State>

This command switches persistence in the persistence spectrum on and off.

Note: Setting the persistence to 0 turns it off and thus has the same effect as this command (see DISPlay:​WINDow:​[SUBWindow:​]TRACe:​PERSistence:​DURation).

Parameters:
<State>
ON | OFF
*RST: On


DISPlay:WINDow:[SUBWindow:]TRACe:SYMBol

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Persistence Spectrum > DISPlay:WINDow:[SUBWindow:]TRACe:SYMBol
DISPlay:WINDow:[SUBWindow:]TRACe:SYMBol <Style>

This command sets the display style of the persistence spectrum.

Parameters:
<Style>
DOTS

Displays the data as dots. The result is a persistence spectrum made up out of dots.

VECTor

Interpolates the measurement points. The result is an uninterrupted persistence spectrum.

*RST: VECTor
Example: DISP:WIND:TRAC:SYMB DOTS

Displays the persistence spectrum as dots.

Example:

See "Example 3: Analyzing Persistency".

Manual operation: See "Diagram Style"


Configuring Color Maps

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Color Maps
Configuring Color Maps

The color display used in spectrograms, persistence spectrums, and PVT waterfall diagrams is highly configurable to adapt the display to your needs.

For details see "Color Maps".

List of Commands
DISPlay:WINDow:PSPectrum:COLor:DEFault
DISPlay:WINDow:PSPectrum:COLor:LOWer
DISPlay:WINDow:PSPectrum:COLor:SHAPe
DISPlay:WINDow:PSPectrum:COLor:TRUNcate
DISPlay:WINDow:PSPectrum:COLor:UPPer
DISPlay:WINDow:PSPectrum:COLor[:STYLe]
CALCulate<n>:SGRam|SPECtrogram:COLor
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor[:STYLe]
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:DEFault
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:LOWer
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:SHAPe
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:UPPer


DISPlay:WINDow:PSPectrum:COLor:DEFault

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Color Maps > DISPlay:WINDow:PSPectrum:COLor:DEFault
DISPlay:WINDow:PSPectrum:COLor:DEFault

This command sets the color settings for the persistence spectrum result display to its default state.

Usage: | Event
Manual operation: | See "Set to Default"


DISPlay:WINDow:PSPectrum:COLor:LOWer

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Color Maps > DISPlay:WINDow:PSPectrum:COLor:LOWer
DISPlay:WINDow:PSPectrum:COLor:LOWer <Percentage>

This command sets the lower percentage boundary of the persistence spectrum.

Parameters:
<Percentage>

Statistical frequency percentage.

Range: | 0 to 65,6
*RST: | 0
Default unit: | %
Example: DISP:WIND:HIST:COL:LOW 10

Sets the start of the color map to 10%.

Example:

See "Example 3: Analyzing Persistency".

Manual operation: See "Start / Stop"


DISPlay:WINDow:PSPectrum:COLor:SHAPe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Color Maps > DISPlay:WINDow:PSPectrum:COLor:SHAPe
DISPlay:WINDow:PSPectrum:COLor:SHAPe <Shape>

This command defines the shape and focus of the color curve for the persistence spectrum result display.

Parameters:
<Shape>

Shape of the color curve.

Range: | -1 to 1
*RST: | 0
Example:

See "Example 3: Analyzing Persistency".

Manual operation: See "Shape"


DISPlay:WINDow:PSPectrum:COLor:TRUNcate

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Color Maps > DISPlay:WINDow:PSPectrum:COLor:TRUNcate
DISPlay:WINDow:PSPectrum:COLor:TRUNcate <State>

This command reduces the range of the color map of the persistence spectrum if there are no hits at the start or end of the value range.

Parameters:
<State>
ON
OFF
*RST: OFF
Example: DISP:WIND:PSP:COL:TRUN ON

Activates truncation of the color map.

Example:

See "Example 3: Analyzing Persistency".

Manual operation: See "Truncate"


DISPlay:WINDow:PSPectrum:COLor:UPPer

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Color Maps > DISPlay:WINDow:PSPectrum:COLor:UPPer
DISPlay:WINDow:PSPectrum:COLor:UPPer <Percentage>

This command sets the upper percentage boundary of the persistence spectrum.

Parameters:
<Percentage>

Statistical frequency percentage.

Range: | 0.01 to 100
*RST: | 100
Default unit: | %
Example: DISP:WIND:HIST:COL:UPP 95

Sets the upper boundary of the color map to 95%.

Example:

See "Example 3: Analyzing Persistency".

Manual operation: See "Start / Stop"


DISPlay:WINDow:PSPectrum:COLor[:STYLe]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Color Maps > DISPlay:WINDow:PSPectrum:COLor[:STYLe]
DISPlay:WINDow:PSPectrum:COLor[:STYLe] <ColorScheme>

This command sets the color scheme for the persistance spectrum.

Parameters:
<ColorScheme>
HOT
COLD
RADar
GRAYscale
*RST: HOT
Example: DISP:WIND:HIST:COL GRAY

Changes the color scheme of the persistance spectrum to black and white.

Example:

See "Example 3: Analyzing Persistency".

Manual operation: See "Hot/Cold/Radar/Grayscale"


CALCulate<n>:SGRam|SPECtrogram:COLor

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Color Maps > CALCulate<n>:SGRam|SPECtrogram:COLor
CALCulate<n>:SGRam|SPECtrogram:COLor <ColorScheme>
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor[:STYLe] <ColorScheme>

This command selects the color scheme.

For details see "Color Maps" .

Suffix:
<n>
1 .. 6

window; spectrograms and PVT waterfall displays can be selected

Parameters:
<ColorScheme>
HOT

Uses a color range from blue to red. Blue colors indicate low levels, red colors indicate high ones.

COLD

Uses a color range from red to blue. Red colors indicate low levels, blue colors indicate high ones.

RADar

Uses a color range from black over green to light turquoise with shades of green in between.

GRAYscale

Shows the results in shades of gray.

*RST: HOT
Example: DISP:WIND:SPEC:COL GRAY

Changes the color scheme of the spectrogram to black and white.

Example:

See "Example 2: Performing a Basic Realtime Measurement".

Example:

See "Example 4: Obtaining Time Domain Results in Realtime"

Manual operation: See "Hot/Cold/Radar/Grayscale"


DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:DEFault

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Color Maps > DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:DEFault
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:DEFault

This command restores the original color map.

Usage: | Event
Manual operation: | See "Set to Default"


DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:LOWer

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Color Maps > DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:LOWer
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:LOWer <Percentage>

This command defines the starting point of the color map.

Parameters:
<Percentage>

Statistical frequency percentage.

Range: | 0 to 66
*RST: | 0
Default unit: | %
Example: DISP:WIND:SGR:COL:LOW 10

Sets the start of the color map to 10%.

Example:

See "Example 2: Performing a Basic Realtime Measurement".

Example:

See "Example 4: Obtaining Time Domain Results in Realtime"

Manual operation: See "Start / Stop"


DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:SHAPe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Color Maps > DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:SHAPe
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:SHAPe <Shape>

This command defines the shape and focus of the color curve for the spectrogram result display.

Parameters:
<Shape>

Shape of the color curve.

Range: | -1 to 1
*RST: | 0
Example:

See "Example 2: Performing a Basic Realtime Measurement".

Example:

See "Example 4: Obtaining Time Domain Results in Realtime"

Manual operation: See "Shape"


DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:UPPer

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring Color Maps > DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:UPPer
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:UPPer <Percentage>

This command defines the end point of the color map.

Parameters:
<Percentage>

Statistical frequency percentage.

Range: | 0 to 66
*RST: | 0
Default unit: | %
Example: DISP:WIND:SGR:COL:UPP 95

Sets the start of the color map to 95%.

Example:

See "Example 2: Performing a Basic Realtime Measurement".

Example:

See "Example 4: Obtaining Time Domain Results in Realtime"

Manual operation: See "Start / Stop"


Adjusting Settings Automatically

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Adjusting Settings Automatically
Adjusting Settings Automatically

The following remote commands are required to adjust settings automatically in a remote environment. In MSRT mode, these commands are only available for the MSRT Master channel. The functions for manual operation are described in "Adjusting Settings Automatically".

List of Commands
[SENSe:]ADJust:ALL
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:FREQuency
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:CONFigure:TRIG
[SENSe:]ADJust:LEVel


[SENSe:]ADJust:ALL

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:ALL
[SENSe:]ADJust:ALL

This command initiates a measurement to determine and set the ideal settings for the current task automatically (only once for the current measurement).

This includes:

  • Center frequency
  • Reference level
Example: | ADJ:ALL
Usage: | Event
Manual operation: | See "Adjusting all Determinable Settings Automatically (Auto All)"


[SENSe:]ADJust:CONFigure:DURation

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation <Duration>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command defines the length of the measurement if [SENSe:​]ADJust:​CONFigure:​DURation:​MODE is set to MANual.

Parameters:
<Duration>
Numeric value in seconds
Range: | 0.001 to 16000.0
*RST: | 0.001
Default unit: | s
Example: ADJ:CONF:DUR:MODE MAN

Selects manual definition of the measurement length.

ADJ:CONF:LEV:DUR 5ms

Length of the measurement is 5 ms.

Manual operation: See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:DURation:MODE

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:DURation:MODE <Mode>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command selects the way the R&S FSW determines the length of the measurement .

Parameters:
<Mode>
AUTO

The R&S FSW determines the measurement length automatically according to the current input data.

MANual

The R&S FSW uses the measurement length defined by [SENSe:​]ADJust:​CONFigure:​DURation.

*RST: AUTO
Manual operation: See "Resetting the Automatic Measurement Time (Meastime Auto)"
See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:FREQuency

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:FREQuency
[SENSe:]ADJust:FREQuency

This command sets the center frequency to the highest signal level in the current frequency range.

Example: | ADJ:FREQ
Usage: | Event
Manual operation: | See "Adjusting the Center Frequency Automatically (Auto Freq)"


[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:LOW 2

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level falls below 18 dBm.

Manual operation: See "Lower Level Hysteresis"


[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:UPP 2
Example:

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level rises above 22 dBm.

Manual operation: See "Upper Level Hysteresis"


[SENSe:]ADJust:CONFigure:TRIG

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:TRIG
[SENSe:]ADJust:CONFigure:TRIG <State>

Defines the behaviour of the measurement when adjusting a setting automatically (using SENS:ADJ:LEV ON, for example).

See "Adjusting settings automatically during triggered measurements"

Parameters:
<State>
ON | 1

The measurement for automatic adjustment waits for the trigger.

OFF | 0

The measurement for automatic adjustment is performed immediately, without waiting for a trigger.

*RST: 1


[SENSe:]ADJust:LEVel

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:LEVel
[SENSe:]ADJust:LEVel

This command initiates a single (internal) measurement that evaluates and sets the ideal reference level for the current input data and measurement settings. This ensures that the settings of the RF attenuation and the reference level are optimally adjusted to the signal level without overloading the R&S FSW or limiting the dynamic range by an S/N ratio that is too small.

Example: | ADJ:LEV
Usage: | Event
Manual operation: | See "Setting the Reference Level Automatically (Auto Level)"


Configuring the Result Display

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Result Display
Configuring the Result Display

The following remote commands are required to configure the screen display in a remote environment. The tasks for manual operation are described in "Realtime Result Displays".

Contents
  • General Window Commands
  • Working with Windows in the Display


General Window Commands

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Result Display > General Window Commands
General Window Commands

The following commands are required to configure general window layout, independent of the application.

List of Commands
DISPlay:FORMat
DISPlay[:WINDow<n>]:SIZE


DISPlay:FORMat

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Result Display > General Window Commands > DISPlay:FORMat
DISPlay:FORMat <Format>

This command determines which tab is displayed.

Parameters:
<Format>
SPLit

Displays the MultiView tab with an overview of all active channels

(See "R&S MultiView" ).

SINGle

Displays the measurement channel that was previously focused.

*RST: SING
Example: DISP:FORM SPL


DISPlay[:WINDow<n>]:SIZE

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Result Display > General Window Commands > DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:SIZE <Size>

This command maximizes the size of the selected result display window temporarily. To change the size of several windows on the screen permanently, use the LAY:SPL command (see LAYout:​SPLitter).

Parameters:
<Size>
LARGe

Maximizes the selected window to full screen.

Other windows are still active in the background.

SMALl

Reduces the size of the selected window to its original size.

If more than one measurement window was displayed originally, these are visible again.

*RST: SMALl
Example: DISP:WIND2:LARG
Example:

See "Example 1: Adding and Arranging Windows" .


Working with Windows in the Display

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Result Display > Working with Windows in the Display
Working with Windows in the Display

The following commands are required to change the evaluation type and rearrange the screen layout for a measurement channel as you do using the SmartGrid in manual operation. Since the available evaluation types depend on the selected application, some parameters for the following commands also depend on the selected measurement channel.

List of Commands
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace


LAYout:ADD[:WINDow]?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:ADD[:WINDow]?
LAYout:ADD[:WINDow]? <WindowName>,<Direction>,<WindowType>

This command adds a window to the display.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

To replace an existing window, use the LAYout:​REPLace[:​WINDow] command.

Parameters:
<WindowName>

String containing the name of the existing window the new window is inserted next to.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<Direction>
LEFT | RIGHt | ABOVe | BELow

Direction the new window is added relative to the existing window.

<WindowType>
text value

Type of result display (evaluation method) you want to add.

See the table below for available parameter values.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:ADD? '1',LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

For a detailed example see "Example 1: Adding and Arranging Windows" and "Example 2: Replacing and Removing Windows" .

Example:

See "Programming Example" .

Usage: Query only
Manual operation: See "Realtime Spectrum"
See "Spectrogram"
See "Persistence Spectrum"
See "Power vs Time"
See "PVT Waterfall"
See "Marker Table"

For a detailed example see "Example 3: Analyzing Persistency" and "Example 4: Obtaining Time Domain Results in Realtime".

<WindowType> parameter values for realtime measurements
Parameter value | Window type
'XFRequency:RFPower[:SPECtrum]' 'XFRequency[:SPECtrum]' | Realtime Spectrum
'XFRequency:RFPower:SGRam' 'XFRequency:SGRam' | Spectrogram
'XFRequency:RFPower:PSPectrum' 'XFRequency:PSPectrum' | Persistence Spectrum
'XTIMe:RFPower[:TDOMain]' 'XTIMe[:TDOMain]' | Power vs Time
'XTIMe:RFPower:SGRam' 'XTIMe:SGRam' | PVT Waterfall
MTABle | Marker table


LAYout:CATalog[:WINDow]?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:CATalog[:WINDow]?
LAYout:CATalog[:WINDow]?

This command queries the name and index of all active windows from top left to bottom right. The result is a comma-separated list of values for each window, with the syntax:

<WindowName_1>,<WindowIndex_1>..<WindowName_n>,<WindowIndex_n>

Return values:
<WindowName>
string

Name of the window.

In the default state, the name of the window is its index.

<WindowIndex>
numeric value

Index of the window.

Example: LAY:CAT?

Result:

'2',2,'1',1

Two windows are displayed, named '2' (at the top or left), and '1' (at the bottom or right).

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:IDENtify[:WINDow]?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:IDENtify[:WINDow]?
LAYout:IDENtify[:WINDow]? <WindowName>

This command queries the index of a particular display window.

Note: to query the name of a particular window, use the LAYout:​WINDow<n>:​IDENtify? query.

Query parameters:
<WindowName> | String containing the name of a window.
Return values:
<WindowIndex> | Index number of the window.
Usage: | Query only


LAYout:REMove[:WINDow]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:REMove[:WINDow]
LAYout:REMove[:WINDow] <WindowName>

This command removes a window from the display.

Parameters:
<WindowName>

String containing the name of the window.

In the default state, the name of the window is its index.

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Event


LAYout:REPLace[:WINDow]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:REPLace[:WINDow]
LAYout:REPLace[:WINDow] <WindowName>,<WindowType>

This command replaces the window type (for example from "Diagram" to "Result Summary") of an already existing window while keeping its position, index and window name.

To add a new window, use the LAYout:​ADD[:​WINDow]? command.

Parameters:
<WindowName>

String containing the name of the existing window.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<WindowType>

Type of result display you want to use in the existing window.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Example: LAY:REPL:WIND '1',MTAB

Replaces the result display in window 1 with a marker table.

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:SPLitter

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:SPLitter
LAYout:SPLitter <Index1>,<Index2>,<Position>

This command changes the position of a splitter and thus controls the size of the windows on each side of the splitter.

As opposed to the DISPlay[:​WINDow<n>]:​SIZE command, the LAYout:SPLitter changes the size of all windows to either side of the splitter permanently, it does not just maximize a single window temporarily.

Note that windows must have a certain minimum size. If the position you define conflicts with the minimum size of any of the affected windows, the command will not work, but does not return an error.

SmartGrid coordinates for remote control of the splitters
Parameters:
<Index1>

The index of one window the splitter controls.

<Index2>

The index of a window on the other side of the splitter.

<Position>

New vertical or horizontal position of the splitter as a fraction of the screen area (without channel and status bar and softkey menu).

The point of origin (x = 0, y = 0) is in the lower left corner of the screen. The end point (x = 100, y = 100) is in the upper right corner of the screen. (See figure "SmartGrid coordinates for remote control of the splitters".)

The direction in which the splitter is moved depends on the screen layout. If the windows are positioned horizontally, the splitter also moves horizontally. If the windows are positioned vertically, the splitter also moves vertically.

Range: 0 to 100
Example: LAY:SPL 1,3,50

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Table') to the center (50%) of the screen, i.e. in the figure above, to the left.

Example: LAY:SPL 1,4,70

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Peak List') towards the top (70%) of the screen.

The following commands have the exact same effect, as any combination of windows above and below the splitter moves the splitter vertically.

LAY:SPL 3,2,70
LAY:SPL 4,1,70
LAY:SPL 2,1,70
Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:WINDow<n>:ADD?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:ADD? <Direction>,<WindowType>

This command adds a measurement window to the display. Note that with this command, the suffix <n> determines the existing window next to which the new window is added, as opposed to LAYout:​ADD[:​WINDow]?, for which the existing window is defined by a parameter.

To replace an existing window, use the LAYout:​WINDow<n>:​REPLace command.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

Parameters:
<Direction>
LEFT | RIGHt | ABOVe | BELow
<WindowType>

Type of measurement window you want to add.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:WIND1:ADD? LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:WINDow<n>:IDENtify?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:IDENtify?

This command queries the name of a particular display window (indicated by the <n> suffix).

Note: to query the index of a particular window, use the LAYout:​IDENtify[:​WINDow]? command.

Return values:
<WindowName> | String containing the name of a window. In the default state, the name of the window is its index.
Usage: | Query only


LAYout:WINDow<n>:REMove

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REMove

This command removes the window specified by the suffix <n> from the display.

The result of this command is identical to the LAYout:​REMove[:​WINDow] command.

Usage: Event


LAYout:WINDow<n>:REPLace

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Configuring Realtime Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:REPLace <WindowType>

This command changes the window type of an existing window (specified by the suffix <n>).

The result of this command is identical to the LAYout:​REPLace[:​WINDow] command.

To add a new window, use the LAYout:​WINDow<n>:​ADD? command.

Parameters:
<WindowType>

Type of measurement window you want to replace another one with.

See LAYout:​ADD[:​WINDow]? for a list of available window types.


Capturing Data and Performing Sweeps

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Capturing Data and Performing Sweeps
Capturing Data and Performing Sweeps

When you activate a Realtime Spectrum measurement channel, a measurement is started immediately with the default settings. However, you can start and stop new measurements at any time.

Capturing data in MSRT mode

The only true measurement in MSRT mode in which data from the input signal is captured and stored is performed by the MSRT Master. This data acquisition is performed as in the Realtime Spectrum application.

As soon as data has been stored to the capture buffer successfully, a status bit (#9) in the STAT:OPER register is set (see "STATus:OPERation Register". Once the bit has been set, the device under test can already be reconfigured while the R&S FSW performs analysis on the captured data. For measurements that require long measurement times and comprehensive analysis tasks, using the "capture finished" information can reduce the overall measurement time significantly.

See also:
  • INITiate:​REFResh
List of Commands
ABORt
INITiate:CONMeas
INITiate:CONTinuous
INITiate[:IMMediate]
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SEQuencer:REFResh[:ALL]
SYSTem:SEQuencer


ABORt

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Capturing Data and Performing Sweeps > ABORt
ABORt

This command aborts a current measurement and resets the trigger system.

To prevent overlapping execution of the subsequent command before the measurement has been aborted successfully, use the *OPC? or *WAI command after ABOR and before the next command.

For details see "Preventing Overlapping Execution" .

To abort a sequence of measurements by the Sequencer, use the INITiate:​SEQuencer:​ABORt command.

Note on blocked remote control programs:

If a sequential command cannot be completed, for example because a triggered sweep never receives a trigger, the remote control program will never finish and the remote channel to the R&S FSW is blocked for further commands. In this case, you must interrupt processing on the remote channel first in order to abort the measurement.

To do so, send a "Device Clear" command from the control instrument to the R&S FSW on a parallel channel to clear all currently active remote channels. Depending on the used interface and protocol, send the following commands:

  • Visa: viClear()
  • GPIB: ibclr()
  • RSIB: RSDLLibclr()

Now you can send the ABORt command on the remote channel performing the measurement.

Example: | ABOR;:INIT:IMM Aborts the current measurement and immediately starts a new one.
Example: | ABOR;*WAI INIT:IMM Aborts the current measurement and starts a new one once abortion has been completed.
Usage: | SCPI confirmed


INITiate:CONMeas

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Capturing Data and Performing Sweeps > INITiate:CONMeas
INITiate:CONMeas

This command restarts a (single) measurement that has been stopped (using INIT:CONT OFF) or finished in single sweep mode.

The measurement is restarted at the beginning, not where the previous measurement was stopped.

As opposed to INITiate[:​IMMediate], this command does not reset traces in maxhold, minhold or average mode. Therefore it can be used to continue measurements using maxhold or averaging functions.


INITiate:CONTinuous

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Capturing Data and Performing Sweeps > INITiate:CONTinuous
INITiate:CONTinuous <State>

This command controls the measurement mode.

Note that in single measurement mode, you can synchronize to the end of the measurement with *OPC, *OPC? or *WAI. In continuous measurement mode, synchronization to the end of the measurement is not possible. Thus, it is not recommended that you use continuous measurement mode in remote control, as results like trace data or markers are only valid after a single measurement end synchronization.

For details on synchronization see "Command Sequence and Synchronization"

If the measurement mode is changed for a measurement channel while the Sequencer is active (see INITiate:​SEQuencer:​IMMediate) the mode is only considered the next time the measurement in that channel is activated by the Sequencer.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Continuous measurement

OFF | 0

Single sweep

*RST: 1
Example: INIT:CONT OFF

Switches the measurement mode to single measurement.

INIT:CONT ON

Switches the measurement mode to continuous measurement.

Manual operation: See "Continuous Sweep/RUN CONT"


INITiate[:IMMediate]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Capturing Data and Performing Sweeps > INITiate[:IMMediate]
INITiate[:IMMediate]

This command starts a (single) new measurement.

You can synchronize to the end of the measurement with *OPC, *OPC? or *WAI.

For details on synchronization see "Command Sequence and Synchronization"

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Single Sweep/ RUN SINGLE"


INITiate:SEQuencer:ABORt

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Capturing Data and Performing Sweeps > INITiate:SEQuencer:ABORt
INITiate:SEQuencer:ABORt

This command stops the currently active sequence of measurements. The Sequencer itself is not deactivated, so you can start a new sequence immediately using INITiate:​SEQuencer:​IMMediate.

To deactivate the Sequencer use SYSTem:​SEQuencer.

Usage: | Event
Manual operation: | See "Sequencer State"


INITiate:SEQuencer:IMMediate

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Capturing Data and Performing Sweeps > INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:IMMediate

This command starts a new sequence of measurements by the Sequencer. Its effect is similar to the INITiate[:​IMMediate] command used for a single measurement.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: Event
Manual operation: See "Sequencer State"


INITiate:SEQuencer:MODE

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Capturing Data and Performing Sweeps > INITiate:SEQuencer:MODE
INITiate:SEQuencer:MODE <Mode>

This command selects the way the R&S FSW application performs measurements sequentially.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Note: In order to synchronize to the end of a sequential measurement using *OPC, *OPC? or *WAI you must use SINGle Sequence mode.

For details on the Sequencer see "The Sequencer Concept" .

For details on synchronization see "Command Sequence and Synchronization"

Parameters:
<Mode>
SINGle

Each measurement is performed once (regardless of the channel's sweep mode), considering each channels' sweep count, until all measurements in all active channels have been performed.

CONTinuous

The measurements in each active channel are performed one after the other, repeatedly (regardless of the channel's sweep mode), in the same order, until the Sequencer is stopped.

CDEFined

First, a single sequence is performed. Then, only those channels in continuous sweep mode (INIT:CONT ON) are repeated.

*RST: CONTinuous
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Manual operation: See "Sequencer Mode"


INITiate:SEQuencer:REFResh[:ALL]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Capturing Data and Performing Sweeps > INITiate:SEQuencer:REFResh[:ALL]
INITiate:SEQuencer:REFResh[:ALL]

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only in MSRA or MSRT mode.

The data in the capture buffer is re-evaluated by all active MSRA/MSRT applications.

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INIT:SEQ:REFR Refreshes the display for all channels.
Usage: | Event
Manual operation: | See "Refresh All"


SYSTem:SEQuencer

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Capturing Data and Performing Sweeps > SYSTem:SEQuencer
SYSTem:SEQuencer <State>

This command turns the Sequencer on and off. The Sequencer must be active before any other Sequencer commands (INIT:SEQ...) are executed, otherwise an error will occur.

For details on the Sequencer see "The Sequencer Concept" .

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The Sequencer is activated and a sequential measurement is started immediately.

OFF | 0

The Sequencer is deactivated. Any running sequential measurements are stopped. Further Sequencer commands (INIT:SEQ...) are not available.

*RST: 0
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single Sequencer mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

SYST:SEQ OFF
Example:

See "Programming Example: Performing a Sequence of Measurements" .

Manual operation: See "Sequencer State"


Retrieving Results

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Retrieving Results
Retrieving Results

The following commands are required to retrieve the results in a remote environment.

Contents
  • Retrieving Marker Results
  • Retrieving Trace Results
  • Exporting Results


Retrieving Marker Results

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Retrieving Results > Retrieving Marker Results
Retrieving Marker Results
Useful commands for retrieving results described elsewhere:
  • CALCulate<n>:​DELTamarker<m>:​X
  • CALCulate<n>:​DELTamarker<m>:​Y?
  • CALCulate<n>:​MARKer<m>:​X
  • CALCulate<n>:​MARKer<m>:​Y?
Remote commands exclusive to retrieving marker results:
List of Commands
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:Z?
CALCulate<n>:MARKer<m>:Z?


CALCulate<n>:DELTamarker<m>:X:RELative?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Retrieving Results > Retrieving Marker Results > CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:X:RELative?

This command queries the relative position of a delta marker on the x-axis.

If necessary, the command activates the delta marker first.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | CALC:DELT3:X:REL? Outputs the frequency of delta marker 3 relative to marker 1 or relative to the reference position.
Usage: | Query only
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


CALCulate<n>:DELTamarker<m>:Z?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Retrieving Results > Retrieving Marker Results > CALCulate<n>:DELTamarker<m>:Z?
CALCulate<n>:DELTamarker<m>:Z?

This command queries the z-axis value of the indicated delta marker in the persistence spectrum result display.

You can select whether to query the results of the persistence trace or the maxhold trace with CALCulate<n>:​DELTamarker<m>:​TRACe.

Return values:
<percentage> | The return value is the percentage of hits on the marker position.
Usage: | Query only
Mode: | RT


CALCulate<n>:MARKer<m>:Z?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Retrieving Results > Retrieving Marker Results > CALCulate<n>:MARKer<m>:Z?
CALCulate<n>:MARKer<m>:Z?

This command queries the z-axis value of the indicated marker in the persistence spectrum result display.

You can select whether to query the results of the persistence trace or the maxhold trace with CALCulate<n>:​DELTamarker<m>:​TRACe.

Return values:
<percentage> | The return value is the percentage of hits on the marker position.
Usage: | Query only


Retrieving Trace Results

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Retrieving Results > Retrieving Trace Results
Retrieving Trace Results

The following remote commands are required to retrieve the trace results in a remote environment.

Useful commands for retrieving results described elsewhere:
  • CALCulate<n>:​SGRam|SPECtrogram:​FRAMe:​SELect
  • CALCulate<n>:​SGRam|SPECtrogram:​TSTamp:​DATA?
Remote commands exclusive to retrieving trace results:
List of Commands
FORMat[:DATA]
TRACe<n>[:DATA]?
TRACe<n>[:DATA]:MEMory?
TRACe<n>[:DATA]:X?


FORMat[:DATA]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Retrieving Results > Retrieving Trace Results > FORMat[:DATA]
FORMat[:DATA] <Format>

This command selects the data format that is used for transmission of trace data from the R&S FSW to the controlling computer.

Note that the command has no effect for data that you send to the R&S FSW. The R&S FSW automatically recognizes the data it receives, regardless of the format.

Parameters:
<Format>
ASCii

ASCii format, separated by commas.

This format is almost always suitable, regardless of the actual data format. However, the data is not as compact as other formats may be.

REAL,32

32-bit IEEE 754 floating-point numbers in the "definite length block format".

In the Spectrum application, the format setting REAL is used for the binary transmission of trace data.

For I/Q data, 8 bytes per sample are returned for this format setting.

*RST: ASCII
Example: FORM REAL,32
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Usage: SCPI confirmed


TRACe<n>[:DATA]?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]?
TRACe<n>[:DATA]?? <ResultType>

This command queries current trace data and measurement results.

The data format depends on FORMat[:​DATA].

Query parameters:
<ResultType>

Selects the type of result to be returned.

TRACE1 | ... | TRACE6

Returns the measured power value for each of the 1001 trace points.

For Spectrogram or PVT Waterfall result displays, only the values for the currently selected frame are returned.

For Persistence Spectrum result displays, only the values for the most recently measured spectrum are returned.

The power level depends on the unit you have currently set.

SPECtrogram | SGRam

Returns the entire results of a Spectrogram or PVT Waterfall result display.

For each frame in the spectrogram/PVT waterfall, starting with the most recent frame, the command returns the 1001 measured power levels. The number of frames depends on the size of the history depth. The power level depends on the unit you have currently set.

PSPectrum

Returns the results of the Persistence Spectrum result display.

The command returns 1001*600 percentages, one for each pixel in the (current) histogram. The values are returned for each frequency for one power at a time, starting with the lowest frequency and highest power value and ending with the highest frequency and lowest power level; that is, from top left to bottom right (see table "Order of trace data results for persistence spectrum and maxhold trace").

HMAXhold

Returns the results of the maxhold trace in the Persistence Spectrum result display.

The command returns 1001*600 percentages, one for each point in the maxhold trace. The values are returned for each frequency for one power at a time, starting with the lowest frequency and highest power value and ending with the highest frequency and lowest power level; that is, from top left to bottom right (see table "Order of trace data results for persistence spectrum and maxhold trace").

Example:

See "Example 2: Performing a Basic Realtime Measurement".

Example:

See "Example 3: Analyzing Persistency".

Example:

See "Example 4: Obtaining Time Domain Results in Realtime".

Usage: SCPI confirmed
Order of trace data results for persistence spectrum and maxhold trace


TRACe<n>[:DATA]:MEMory?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]:MEMory?
TRACe<n>[:DATA]:MEMory? <Trace>,<OffsSwPoint>,<NoOfSwPoints>

This command queries the previously captured trace data for the specified trace from the memory. As an offset and number of sweep points to be retrieved can be specified, the trace data can be retrieved in smaller portions, making the command faster than the TRAC:DATA? command. This is useful if only specific parts of the trace data are of interest.

If no parameters are specified with the command, the entire trace data is retrieved; in this case, the command is identical to TRAC:DATA? TRACE1

For details on the returned values see the TRACe<n>[:​DATA]? command.

Query parameters:
<Trace> | TRACE1 | TRACE2 | TRACE3 | TRACE4 | TRACE5 | TRACE6
<OffsSwPoint> | The offset in sweep points related to the start of the measurement at which data retrieval is to start.
<NoOfSwPoints> | Number of sweep points to be retrieved from the trace.
Example: | TRAC:DATA:MEM? TRACE1,25,100 Retrieves 100 sweep points from trace 1, starting at sweep point 25.
Usage: | Query only


TRACe<n>[:DATA]:X?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]:X?
TRACe<n>[:DATA]:X? <TraceNumber>

This command queries the horizontal trace data for each sweep point in the specified window, for example the frequency in frequency domain or the time in time domain measurements.

Query parameters:
<TraceNumber> | Trace number. TRACE1 | ... | TRACE4
Example: | TRAC3:X? TRACE1 Returns the x-values for trace 1 in window 3.
Usage: | Query only


Exporting Results

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Retrieving Results > Exporting Results
Exporting Results

Trace results can be exported to a file.

For more commands concerning data and results storage see the R&S FSW User Manual.

List of Commands
MMEMory:STORe<n>:PSPectrum
MMEMory:STORe<n>:SGRam
MMEMory:STORe<n>:TRACe
FORMat:DEXPort:DSEParator
FORMat:DEXPort:HEADer
FORMat:DEXPort:TRACes


MMEMory:STORe<n>:PSPectrum

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Retrieving Results > Exporting Results > MMEMory:STORe<n>:PSPectrum
MMEMory:STORe<n>:PSPectrum <FileName>

This command exports persistence spectrum data to an ASCii file.

The file contains the most recently determined percentage value for each pixel in the persistence spectrum, that is, for 1001 frequency and 600 power values, followed by the 1001*600 maxhold percentages.

For details see table "ASCII file format for persistence spectrum trace export".

Note that, due to the large amount of data involved, the process of exporting the data can take a while.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Parameters:
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR:PSP 'C:\PersistentSpectrum' Copies the persistent spectrum data to a file.
Example: | See "Example 3: Analyzing Persistency".


MMEMory:STORe<n>:SGRam

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Retrieving Results > Exporting Results > MMEMory:STORe<n>:SGRam
MMEMory:STORe<n>:SGRam <FileName>

This command exports spectrogram data to an ASCii file.

The file contains the data for every frame in the history buffer. The data corresponding to a particular frame begins with information about the frame number and the time that frame was recorded.

Note that, depending on the size of the history buffer, the process of exporting the data can take a while.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Parameters:
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR:SGR 'Spectrogram' Copies the spectrogram data to a file.
Example: | See "Example 2: Performing a Basic Realtime Measurement".
Example: | See "Example 4: Obtaining Time Domain Results in Realtime"


MMEMory:STORe<n>:TRACe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Retrieving Results > Exporting Results > MMEMory:STORe<n>:TRACe
MMEMory:STORe<n>:TRACe <Trace>, <FileName>

This command exports trace data from the specified window to an ASCII file.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Parameters:
<Trace> | Number of the trace to be stored
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR1:TRAC 3,'C:\TEST.ASC' Stores trace 3 from window 1 in the file TEST.ASC.
Example: | See "Example 4: Obtaining Time Domain Results in Realtime"
Usage: | SCPI confirmed
Manual operation: | See "Export Trace to ASCII File"


FORMat:DEXPort:DSEParator

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Retrieving Results > Exporting Results > FORMat:DEXPort:DSEParator
FORMat:DEXPort:DSEParator <Separator>

This command selects the decimal separator for data exported in ASCII format.

Parameters:
<Separator>
COMMa

Uses a comma as decimal separator, e.g. 4,05.

POINt

Uses a point as decimal separator, e.g. 4.05.

*RST: *RST has no effect on the decimal separator. Default is POINt.
Example: FORM:DEXP:DSEP POIN

Sets the decimal point as separator.

Manual operation: See "Decimal Separator"


FORMat:DEXPort:HEADer

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Retrieving Results > Exporting Results > FORMat:DEXPort:HEADer
FORMat:DEXPort:HEADer <State>

If enabled, additional instrument and measurement settings are included in the header of the export file for result data. If disabled, only the pure result data from the selected traces and tables is exported.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Usage: SCPI confirmed
Manual operation: See "Include Instrument Measurement Settings"


FORMat:DEXPort:TRACes

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Retrieving Results > Exporting Results > FORMat:DEXPort:TRACes
FORMat:DEXPort:TRACes <Selection>

This command selects the data to be included in a data export file (see MMEMory:​STORe<n>:​TRACe).

Parameters:
<Selection>
SINGle

Only a single trace is selected for export, namely the one specified by the MMEMory:​STORe<n>:​TRACe command.

ALL

Selects all active traces and result tables (e.g. Result Summary, marker peak list etc.) in the current application for export to an ASCII file.

The <trace> parameter for the MMEMory:​STORe<n>:​TRACe command is ignored.

*RST: SINGle
Usage: SCPI confirmed
Manual operation: See "Export all Traces and all Table Results"


Analyzing Results

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results
Analyzing Results

The following remote commands are required to configure general result analysis settings concerning the trace, markers, lines etc. in a remote environment.

More details are described for manual operation in "Analysis".

Contents
  • Configuring Traces
  • Using Trace Mathematics
  • Working with Markers Remotely
  • Zooming into the Display


Configuring Traces

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Configuring Traces
Configuring Traces
Useful commands for trace configuration described elsewhere
  • DISPlay[:​WINDow<n>]:​TRACe:​Y:​SPACing
  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]
  • "Exporting Results"
Remote commands exclusive to trace configuration
List of Commands
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
[SENSe:]AVERage:COUNt
[SENSe:]AVERage<n>[:STATe<t>]
[SENSe:][WINDow:]DETector<t>[:FUNCtion]
TRACe<n>:COPY


DISPlay[:WINDow<n>]:TRACe<t>:MODE

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Configuring Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE <Mode>

This command selects the trace mode.

In case of max hold, min hold or average trace mode, you can set the number of single measurements with [SENSe:​]SWEep:​COUNt. Note that synchronization to the end of the measurement is possible only in single sweep mode.

For more information see "Analyzing Several Traces - Trace Mode" .

Parameters:
<Mode>
WRITe

Overwrite mode: the trace is overwritten by each sweep. This is the default setting.

MAXHold

The maximum value is determined over several sweeps and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is greater than the previous one.

MINHold

The minimum value is determined from several measurements and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is lower than the previous one.

BLANk

Hides the selected trace.

*RST: Trace 1: WRITe, Trace 2-6: BLANk
Example: INIT:CONT OFF

Switching to single sweep mode.

SWE:COUN 16

Sets the number of measurements to 16.

DISP:TRAC3:MODE WRIT

Selects clear/write mode for trace 3.

INIT;*WAI

Starts the measurement and waits for the end of the measurement.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Mode"


DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Configuring Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous <State>

This command turns an automatic reset of a trace on and off after a parameter has changed.

The reset works for trace modes min hold, max hold and average.

Note that the command has no effect if critical parameters like the span have been changed to avoid invalid measurement results

Parameters:
<State>
ON

The automatic reset is off.

OFF

The automatic reset is on.

*RST: OFF
Example: DISP:WIND:TRAC3:MODE:HCON ON

Switches off the reset function.

Manual operation: See "Hold"


DISPlay[:WINDow<n>]:TRACe<t>[:STATe]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Configuring Traces > DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:TRACe<t>[:STATe] <State>

This command turns a trace on and off.

The measurement continues in the background.

Example: DISP:TRAC3 ON
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Trace 1/Trace 2/Trace 3/Trace 4"
See "Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)"


[SENSe:]AVERage:COUNt

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Configuring Traces > [SENSe:]AVERage:COUNt
[SENSe:]AVERage:COUNt <AverageCount>

This command defines the number of sweeps that the application uses to average traces.

In case of continuous sweeps, the application calculates the moving average over the average count.

In case of single sweep measurements, the application stops the measurement and calculates the average after the average count has been reached.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Average Count"


[SENSe:]AVERage<n>[:STATe<t>]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Configuring Traces > [SENSe:]AVERage<n>[:STATe<t>]
[SENSe:]AVERage<n>[:STATe<t>] <State>

This command turns averaging for a particular trace in a particular window on and off.

Parameters:
<State>
ON | OFF
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed


[SENSe:][WINDow:]DETector<t>[:FUNCtion]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Configuring Traces > [SENSe:][WINDow:]DETector<t>[:FUNCtion]
[SENSe:][WINDow:]DETector<t>[:FUNCtion] <Detector>

Defines the trace detector to be used for trace analysis.

For details see "Sweep Time and Detector".

Parameters:
<Detector>
NEGative

Negative peak

POSitive

Positive peak

SAMPle

First value detected per trace point

AVERage

Average

*RST: POS
Example: DET POS

Sets the detector to "positive peak".

Manual operation: See "Detector"


TRACe<n>:COPY

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Configuring Traces > TRACe<n>:COPY
TRACe<n>:COPY <TraceNumber>, <TraceNumber>

This command copies data from one trace to another.

Example: TRAC:COPY TRACe1,TRACe2

Copies the data from trace 2 to trace 1.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Copy Trace"


Using Trace Mathematics

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Using Trace Mathematics
Using Trace Mathematics

The following commands control trace mathematics.

List of Commands
CALCulate<n>:MATH[:EXPression][:DEFine]
CALCulate<n>:MATH:MODE
CALCulate<n>:MATH:POSition
CALCulate<n>:MATH:STATe


CALCulate<n>:MATH[:EXPression][:DEFine]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Using Trace Mathematics > CALCulate<n>:MATH[:EXPression][:DEFine]
CALCulate<n>:MATH[:EXPression][:DEFine] <Expression>

This command selects the mathematical expression for trace mathematics.

Before you can use the command, you have to turn trace mathematics on.

Parameters:
<Expression>
(TRACE1-TRACE2)

Subtracts trace 2 from trace 1.

(TRACE1-TRACE3)

Subtracts trace 3 from trace 1.

(TRACE1-TRACE4)

Subtracts trace 4 from trace 1.

Example: CALC:MATH:STAT ON

Turns trace mathematics on.

CALC:MATH:EXPR:DEF (TRACE1-TRACE3)

Subtracts trace 3 from trace 1.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Trace Math Function"


CALCulate<n>:MATH:MODE

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Using Trace Mathematics > CALCulate<n>:MATH:MODE
CALCulate<n>:MATH:MODE <Mode>

This command selects the way the R&S FSW calculates trace mathematics.

Parameters:
<Mode>

For more information on the way each mode works see Trace Math Mode.

LINear

Linear calculation.

LOGarithmic

Logarithmic calculation.

POWer

Linear power calculation.

*RST: LOGarithmic
Example: CALC:MATH:MODE LIN

Selects linear calculation.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trace Math Mode"


CALCulate<n>:MATH:POSition

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Using Trace Mathematics > CALCulate<n>:MATH:POSition
CALCulate<n>:MATH:POSition <Position>

This command defines the position of the trace resulting from the mathematical operation.

Parameters:
<Position>

Vertical position of the trace in % of the height of the diagram area.

100 PCT corresponds to the upper diagram border.

Range: | -100 to 200
*RST: | 50
Default unit: | PCT
Example: CALC:MATH:POS 100

Moves the trace to the top of the diagram area.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trace Math Position"


CALCulate<n>:MATH:STATe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Using Trace Mathematics > CALCulate<n>:MATH:STATe
CALCulate<n>:MATH:STATe <State>

This command turns the trace mathematics on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MATH:STAT ON

Turns on trace mathematics.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Trace Math Function"
See "Trace Math Off"


Working with Markers Remotely

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely
Working with Markers Remotely

In the Realtime Spectrum application, up to 16 markers or delta markers can be activated for each window simultaneously.

For more details see "Markers in the Spectrogram".

Contents
  • Setting Up Individual Markers
  • General Marker Settings
  • Configuring and Performing a Marker Search
  • Positioning the Marker
  • Marker Search (Spectrograms)


Setting Up Individual Markers

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers
Setting Up Individual Markers

The following commands define the position of markers in the diagram.

List of Commands
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:LINK
CALCulate<n>:DELTamarker:MODE
CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:Y?


CALCulate<n>:MARKer<m>:AOFF

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:AOFF

This command turns all markers off.

Example: | CALC:MARK:AOFF Switches off all markers.
Usage: | Event
Manual operation: | See "All Markers Off"


CALCulate<n>:MARKer<m>[:STATe]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>[:STATe] <State>

This command turns markers on and off. If the corresponding marker number is currently active as a deltamarker, it is turned into a normal marker.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK3 ON

Switches on marker 3.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"
See "Marker State"
See "Marker Type"


CALCulate<n>:MARKer<m>:TRACe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:TRACe <Trace>

This command selects the trace the marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> | 1 to 4 Trace number the marker is assigned to. MAXHold Marker is assigned to maxhold trace of persistent spectrum (only available in Persistent Spectrum window) WRITe Marker is assigned to clear/write trace of persistent spectrum (only available in Persistent Spectrum window)
Example: | CALC:MARK3:TRAC 2 Assigns marker 3 to trace 2.
Manual operation: | See "Assigning the Marker to a Trace"


CALCulate<n>:MARKer<m>:X

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:X <Position>

This command moves a marker to a particular coordinate on the x-axis.

If necessary, the command activates the marker.

If the marker has been used as a delta marker, the command turns it into a normal marker.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

Range: The range depends on the current x-axis range.
Example: CALC:MARK2:X 1.7MHz

Positions marker 2 to frequency 1.7 MHz.

Manual operation: See "Marker Table"
See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"
See "Marker Position (X-value)"


CALCulate<n>:MARKer<m>:Y?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>:Y?

This command queries the position of a marker on the y-axis.

If necessary, the command activates the marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result> | Result at the marker position.
Example: | INIT:CONT OFF Switches to single measurement mode. CALC:MARK2 ON Switches marker 2. INIT;*WAI Starts a measurement and waits for the end. CALC:MARK2:Y? Outputs the measured value of marker 2.
Usage: | Query only
Manual operation: | See "Marker Table" See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta" See "Marker Level (Y-value)"


CALCulate<n>:DELTamarker:AOFF

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:AOFF

This command turns all delta markers off.

Example: | CALC:DELT:AOFF Turns all delta markers off.
Usage: | Event


CALCulate<n>:DELTamarker<m>:LINK

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:LINK
CALCulate<n>:DELTamarker<m>:LINK <State>

This command links delta marker <m> to marker 1.

If you change the horizontal position (x-value) of marker 1, delta marker <m> changes its horizontal position to the same value.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2:LINK ON


CALCulate<n>:DELTamarker:MODE

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker:MODE
CALCulate<n>:DELTamarker:MODE <Mode>

This command defines whether the position of a delta marker is provided as an absolute value or relative to a reference marker. Note that when the position of a delta marker is queried, the result is always an absolute value (see CALCulate<n>:​DELTamarker<m>:​X)!

Parameters:
<Mode>
ABSolute

Delta marker position in absolute terms.

RELative

Delta marker position in relation to a reference marker.

*RST: RELative
Example: CALC:DELT:MODE ABS

Absolute delta marker position.


CALCulate<n>:DELTamarker<m>:MREF

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>:MREF <Reference>

This command selects a reference marker for a delta marker other than marker 1.

Parameters:
<Reference> | 1 to 16 Selects markers 1 to 16 as the reference.
Example: | CALC:DELT3:MREF 2 Specifies that the values of delta marker 3 are relative to marker 2.
Manual operation: | See "Reference Marker"


CALCulate<n>:DELTamarker<m>[:STATe]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>[:STATe] <State>

This command turns delta markers on and off.

If necessary, the command activates the delta marker first.

No suffix at DELTamarker turns on delta marker 1.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2 ON

Turns on delta marker 2.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"
See "Marker State"
See "Marker Type"


CALCulate<n>:DELTamarker<m>:TRACe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:TRACe <Trace>

This command selects the trace a delta marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> | Trace number the marker is assigned to.
Example: | CALC:DELT2:TRAC 2 Positions delta marker 2 on trace 2.


CALCulate<n>:DELTamarker<m>:X

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X <Position>

This command moves a delta marker to a particular coordinate on the x-axis.

If necessary, the command activates the delta marker and positions a reference marker to the peak power.

Example: | CALC:DELT:X? Outputs the absolute x-value of delta marker 1.
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta" See "Marker Position (X-value)"


CALCulate<n>:DELTamarker<m>:Y?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>:Y?

This command queries the relative position of a delta marker on the y-axis.

If necessary, the command activates the delta marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

The unit depends on the application of the command.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a sweep and waits for its end. CALC:DELT2 ON Switches on delta marker 2. CALC:DELT2:Y? Outputs measurement value of delta marker 2.
Usage: | Query only
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta" See "Marker Level (Y-value)"


General Marker Settings

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > General Marker Settings
General Marker Settings

The following commands control general marker functionality.

List of Commands
CALCulate:MARKer:X:SSIZe
DISPlay:MTABle


CALCulate:MARKer:X:SSIZe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > General Marker Settings > CALCulate:MARKer:X:SSIZe
CALCulate:MARKer:X:SSIZe <StepSize>

This command selects the marker step size mode.

The step size defines the distance the marker moves when you move it with the rotary knob. It therefore takes effect in manual operation only.

Parameters:
<StepSize>
STANdard

the marker moves from one pixel to the next

POINts

the marker moves from one sweep point to the next

*RST: POINts
Example: CALC:MARK:X:SSIZ STAN

Sets the marker step size to one pixel.

Manual operation: See "Marker Stepsize"


DISPlay:MTABle

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > General Marker Settings > DISPlay:MTABle
DISPlay:MTABle <DisplayMode>

This command turns the marker table on and off.

Parameters:
<DisplayMode>
ON

Turns the marker table on.

OFF

Turns the marker table off.

*RST: AUTO
Example: DISP:MTAB ON

Activates the marker table.

Manual operation: See "Marker Table Display"


Configuring and Performing a Marker Search

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Configuring and Performing a Marker Search
Configuring and Performing a Marker Search

The following commands control the marker search.

List of Commands
CALCulate:MARKer:LOEXclude
CALCulate<n>:MARKer<m>:MAXimum:AUTO
CALCulate<n>:MARKer<m>:MINimum:AUTO
CALCulate<n>:MARKer:PEXCursion
CALCulate:MARKer:X:SLIMits[:STATe]
CALCulate:MARKer:X:SLIMits:LEFT
CALCulate:MARKer:X:SLIMits:RIGHT
CALCulate:MARKer:X:SLIMits:ZOOM[:STATe]
CALCulate:THReshold
CALCulate:THReshold:STATe


CALCulate:MARKer:LOEXclude

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Configuring and Performing a Marker Search > CALCulate:MARKer:LOEXclude
CALCulate:MARKer:LOEXclude <State>

This command turns the suppression of the local oscillator during automatic marker positioning on and off.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: CALC:MARK:LOEX ON
Manual operation: See "Exclude LO"


CALCulate<n>:MARKer<m>:MAXimum:AUTO

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Configuring and Performing a Marker Search > CALCulate<n>:MARKer<m>:MAXimum:AUTO
CALCulate<n>:MARKer<m>:MAXimum:AUTO <State>

This command turns an automatic marker peak search for a trace maximum on and off. The R&S FSW performs the peak search after each sweep.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:MAX:AUTO ON

Activates the automatic peak search function for marker 1 at the end of each particular sweep.

Manual operation: See "Auto Max / Min Peak Search"


CALCulate<n>:MARKer<m>:MINimum:AUTO

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Configuring and Performing a Marker Search > CALCulate<n>:MARKer<m>:MINimum:AUTO
CALCulate<n>:MARKer<m>:MINimum:AUTO <State>

This command turns an automatic marker peak search for a trace minimum on and off. The R&S FSW performs the peak search after each sweep.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:MIN:AUTO ON

Activates the automatic minimum value search function for marker 1 at the end of each particular sweep.

Manual operation: See "Auto Max / Min Peak Search"


CALCulate<n>:MARKer:PEXCursion

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Configuring and Performing a Marker Search > CALCulate<n>:MARKer:PEXCursion
CALCulate<n>:MARKer:PEXCursion <Excursion>

This command defines the peak excursion.

The peak excursion sets the requirements for a peak to be detected during a peak search.

The unit depends on the measurement.

Parameters:
<Excursion>

The excursion is the distance to a trace maximum that must be attained before a new maximum is recognized, or the distance to a trace minimum that must be attained before a new minimum is recognized

*RST: 6.0 dB
Manual operation: See "Peak Excursion"


CALCulate:MARKer:X:SLIMits[:STATe]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Configuring and Performing a Marker Search > CALCulate:MARKer:X:SLIMits[:STATe]
CALCulate:MARKer:X:SLIMits[:STATe] <State>

This command turns marker search limits on and off.

If you perform a measurement in the time domain, this command limits the range of the trace to be analyzed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:X:SLIM ON

Switches on search limitation.

Example:

See "Programming Example: Time Domain Power" .

Manual operation: See "Search Limits (Left / Right)"
See "Deactivating All Search Limits"


CALCulate:MARKer:X:SLIMits:LEFT

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Configuring and Performing a Marker Search > CALCulate:MARKer:X:SLIMits:LEFT
CALCulate:MARKer:X:SLIMits:LEFT <SearchLimit>

This command defines the left limit of the marker search range.

If you perform a measurement in the time domain, this command limits the range of the trace to be analyzed.

Parameters:
<SearchLimit>

The value range depends on the frequency range or measurement time.

The unit is Hz for frequency domain measurements and s for time domain measurements.

*RST: left diagram border
Example: CALC:MARK:X:SLIM ON

Switches the search limit function on.

CALC:MARK:X:SLIM:LEFT 10MHz

Sets the left limit of the search range to 10 MHz.

Example:

See "Programming Example: Time Domain Power" .

Manual operation: See "Search Limits (Left / Right)"


CALCulate:MARKer:X:SLIMits:RIGHT

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Configuring and Performing a Marker Search > CALCulate:MARKer:X:SLIMits:RIGHT
CALCulate:MARKer:X:SLIMits:RIGHT <SearchLimit>

This command defines the right limit of the marker search range.

If you perform a measurement in the time domain, this command limits the range of the trace to be analyzed.

Parameters:
<Limit>

The value range depends on the frequency range or measurement time.

The unit is Hz for frequency domain measurements and s for time domain measurements.

*RST: right diagram border
Example: CALC:MARK:X:SLIM ON

Switches the search limit function on.

CALC:MARK:X:SLIM:RIGH 20MHz

Sets the right limit of the search range to 20 MHz.

Example:

See "Programming Example: Time Domain Power" .

Manual operation: See "Search Limits (Left / Right)"


CALCulate:MARKer:X:SLIMits:ZOOM[:STATe]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Configuring and Performing a Marker Search > CALCulate:MARKer:X:SLIMits:ZOOM[:STATe]
CALCulate:MARKer:X:SLIMits:ZOOM[:STATe] <State>

This command adjusts the marker search range to the zoom area.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:X:SLIM:ZOOM ON

Switches the search limit function on.

CALC:MARK:X:SLIM:RIGH 20MHz

Sets the right limit of the search range to 20 MHz.


CALCulate:THReshold

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Configuring and Performing a Marker Search > CALCulate:THReshold
CALCulate:THReshold <Level>

This command defines a threshold level for the marker peak search.

Parameters:
<Level>
Numeric value. The value range and unit are variable.
*RST: -120 dBm
Example: CALC:THR -82DBM

Sets the threshold value to -82 dBm.

Manual operation: See "Search Threshold"


CALCulate:THReshold:STATe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Configuring and Performing a Marker Search > CALCulate:THReshold:STATe
CALCulate:THReshold:STATe <State>

This command turns a threshold for the marker peak search on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:THR:STAT ON

Switches on the threshold line.

Manual operation: See "Deactivating All Search Limits"


Positioning the Marker

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker
Positioning the Marker

The following remote commands are required to position the marker on a trace.

Contents
  • Positioning Markers
  • Positioning Delta Markers


Positioning Markers

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers
Positioning Markers

The following commands position markers on the trace.

List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:CENTer
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:RIGHt


CALCulate<n>:MARKer<m>:FUNCtion:CENTer

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:FUNCtion:CENTer
CALCulate<n>:MARKer<m>:FUNCtion:CENTer

This command matches the center frequency to the frequency of a marker.

If you use the command in combination with a delta marker, that delta marker is turned into a normal marker.

Example: | CALC:MARK2:FUNC:CENT Sets the center frequency to the frequency of marker 2.
Usage: | Event
Manual operation: | See "Center Frequency = Marker Frequency"


CALCulate<n>:MARKer<m>:MAXimum:LEFT

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:LEFT

This command moves a marker to the next lower peak.

The search includes only measurement values to the left of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in X Direction"


CALCulate<n>:MARKer<m>:MAXimum:NEXT

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:NEXT

This command moves a marker to the next lower peak.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in X Direction" See "Search Next Peak"


CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

This command moves a marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Marker Search Type" See "Peak Search"


CALCulate<n>:MARKer<m>:MAXimum:RIGHt

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum:RIGHt

This command moves a marker to the next lower peak.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in X Direction"


CALCulate<n>:MARKer<m>:MINimum:LEFT

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:LEFT

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in X Direction"


CALCulate<n>:MARKer<m>:MINimum:NEXT

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:NEXT

This command moves a marker to the next minimum value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in X Direction" See "Search Next Minimum"


CALCulate<n>:MARKer<m>:MINimum[:PEAK]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum[:PEAK]

This command moves a marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Marker Search Type" See "Search Minimum"


CALCulate<n>:MARKer<m>:MINimum:RIGHt

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum:RIGHt

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in X Direction"


Positioning Delta Markers

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers
Positioning Delta Markers

The following commands position delta markers on the trace.

List of Commands
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt


CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

This command moves a delta marker to the next higher value.

The search includes only measurement values to the left of the current marker position.

Usage: Event


CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

This command moves a marker to the next higher value.

Usage: | Event
Manual operation: | See "Search Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

This command moves a delta marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Marker Search Type" See "Peak Search"


CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

This command moves a delta marker to the next higher value.

The search includes only measurement values to the right of the current marker position.

Usage: Event


CALCulate<n>:DELTamarker<m>:MINimum:LEFT

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:LEFT

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: Event


CALCulate<n>:DELTamarker<m>:MINimum:NEXT

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT

This command moves a marker to the next higher minimum value.

Usage: | Event
Manual operation: | See "Search Next Minimum"


CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

This command moves a delta marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Marker Search Type" See "Search Minimum"


CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: Event


Marker Search (Spectrograms)

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms)
Marker Search (Spectrograms)

The following commands automatically define the marker and delta marker position in the spectrogram.

The usage of these markers is demonstrated in"Example 2: Performing a Basic Realtime Measurement".

Contents
  • Using Markers
  • Using Delta Markers


Using Markers

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers
Using Markers

The following commands control spectrogram markers.

Useful commands for spectrogram markers described elsewhere

The following commands define the horizontal position of the markers.

  • CALCulate<n>:​MARKer<m>:​MAXimum:​LEFT
  • CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT
  • CALCulate<n>:​MARKer<m>:​MAXimum[:​PEAK]
  • CALCulate<n>:​MARKer<m>:​MAXimum:​RIGHt
  • CALCulate<n>:​MARKer<m>:​MINimum:​LEFT
  • CALCulate<n>:​MARKer<m>:​MINimum:​NEXT
  • CALCulate<n>:​MARKer<m>:​MINimum[:​PEAK]
  • CALCulate<n>:​MARKer<m>:​MINimum:​RIGHt
Remote commands exclusive to spectrogram markers
List of Commands
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:FRAMe
CALCulate<n>:MARKer:SGRam|SPECtrogram:SARea
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:BELow
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:BELow
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:NEXT
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:TRIGger


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:FRAMe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:FRAMe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:FRAMe <Frame> | <Time>

This command positions a marker on a particular frame.

Parameters:
<Frame> | Selects a frame directly by the frame number. Valid if the time stamp is off. The range depends on the history depth.
<Time> | Selects a frame via its time stamp. Valid if the time stamp is on. The number is the (negative) distance to frame 0 in seconds. The range depends on the history depth.
Example: | CALC:MARK:SGR:FRAM -20 Sets the marker on the 20th frame before the present. CALC:MARK2:SGR:FRAM -2s Sets second marker on the frame 2 seconds ago.
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta" See "Frame"


CALCulate<n>:MARKer:SGRam|SPECtrogram:SARea

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer:SGRam|SPECtrogram:SARea
CALCulate<n>:MARKer:SGRam|SPECtrogram:SARea <SearchArea>

This command defines the marker search area for all markers.

Parameters:
<SearchArea>
VISible

Performs a search within the visible frames.

Note that the command does not work if the spectrogram is not visible for any reason (e.g. if the display update is off).

MEMory

Performs a search within all frames in the memory.

*RST: VISible
Manual operation: See "Marker Search Area"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]

This command moves a marker to the highest level of the spectrogram.

Usage: | Event
Manual operation: | See "Marker Search Type"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]

This command moves a marker to the minimum level of the spectrogram.

Usage: | Event
Manual operation: | See "Marker Search Type"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe

This command moves a marker vertically to the next lower peak level for the current frequency.

The search includes only frames above the current marker position. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:BELow

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:BELow
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:BELow

This command moves a marker vertically to the next lower peak level for the current frequency.

The search includes only frames below the current marker position. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT

This command moves a marker vertically to the next lower peak level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]

This command moves a marker vertically to the highest level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

If the marker hasn't been active yet, the command looks for the peak level in the whole spectrogram.

Usage: | Event
Manual operation: | See "Marker Search Type"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe

This command moves a marker vertically to the next higher minimum level for the current frequency.

The search includes only frames above the current marker position. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:BELow

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:BELow
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:BELow

This command moves a marker vertically to the next higher minimum level for the current frequency.

The search includes only frames below the current marker position. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:NEXT

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:NEXT
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:NEXT

This command moves a marker vertically to the next higher minimum level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]

This command moves a marker vertically to the minimum level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

If the marker hasn't been active yet, the command first looks for the peak level for all frequencies and moves the marker vertically to the minimum level.

Usage: | Event
Manual operation: | See "Marker Search Type"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:TRIGger

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:TRIGger
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:TRIGger

This command positions a marker in the spectrogram on the most recent trigger event.

Usage: | Event
Manual operation: | See "Marker to Trigger"


Using Delta Markers

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers
Using Delta Markers

The following commands control spectrogram delta markers.

Useful commands for spectrogram markers described elsewhere

The following commands define the horizontal position of the delta markers.

  • CALCulate<n>:​DELTamarker<m>:​MAXimum:​LEFT
  • CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT
  • CALCulate<n>:​DELTamarker<m>:​MAXimum[:​PEAK]
  • CALCulate<n>:​DELTamarker<m>:​MAXimum:​RIGHt
  • CALCulate<n>:​DELTamarker<m>:​MINimum:​LEFT
  • CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT
  • CALCulate<n>:​DELTamarker<m>:​MINimum[:​PEAK]
  • CALCulate<n>:​DELTamarker<m>:​MINimum:​RIGHt
Remote commands exclusive to spectrogram markers
List of Commands
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:FRAMe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:SARea
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:BELow
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:BELow
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:FRAMe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:FRAMe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:FRAMe <Frame> | <Time>

This command positions a delta marker on a particular frame. The frame is relative to the position of marker 1.

The command is available for the spectrogram.

Parameters:
<Frame> | Selects a frame directly by the frame number. Valid if the time stamp is off. The range depends on the history depth.
<Time> | Selects a frame via its time stamp. Valid if the time stamp is on. The number is the distance to frame 0 in seconds. The range depends on the history depth.
Example: | CALC:DELT4:SGR:FRAM -20 Sets fourth deltamarker 20 frames below marker 1. CALC:DELT4:SGR:FRAM 2 s Sets fourth deltamarker 2 seconds above the position of marker 1.
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:SARea

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:SARea
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:SARea <SearchArea>

This command defines the delta marker search area.

Parameters:
<SearchArea>
VISible

Performs a search within the visible frames.

Note that the command does not work if the spectrogram is not visible for any reason (e.g. if the display update is off).

MEMory

Performs a search within all frames in the memory.

*RST: VISible
Manual operation: See "Marker Search Area"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]

This command moves a marker to the highest level of the spectrogram over all frequencies.

Usage: | Event
Manual operation: | See "Marker Search Type"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]

This command moves a delta marker to the minimum level of the spectrogram over all frequencies.

Usage: | Event
Manual operation: | See "Marker Search Type"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe

This command moves a marker vertically to the next higher level for the current frequency.

The search includes only frames above the current marker position. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:BELow

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:BELow
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:BELow

This command moves a marker vertically to the next higher level for the current frequency.

The search includes only frames below the current marker position. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT

This command moves a delta marker vertically to the next higher level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]

This command moves a delta marker vertically to the highest level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

If the marker hasn't been active yet, the command looks for the peak level in the whole spectrogram.

Usage: | Event
Manual operation: | See "Marker Search Type"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe

This command moves a delta marker vertically to the next minimum level for the current frequency.

The search includes only frames above the current marker position. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:BELow

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:BELow
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:BELow

This command moves a delta marker vertically to the next minimum level for the current frequency.

The search includes only frames below the current marker position. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:NEXT

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:NEXT

This command moves a delta marker vertically to the next minimum level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Working with Markers Remotely > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]

This command moves a delta marker vertically to the minimum level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

If the marker hasn't been active yet, the command first looks for the peak level in the whole spectrogram and moves the marker vertically to the minimum level.

Usage: | Event
Manual operation: | See "Marker Search Type"


Zooming into the Display

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Zooming into the Display
Zooming into the Display
List of Commands
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:STATe


DISPlay[:WINDow<n>]:ZOOM:AREA

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Zooming into the Display > DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT
Manual operation: See "Single Zoom"


DISPlay[:WINDow<n>]:ZOOM:STATe

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Analyzing Results > Zooming into the Display > DISPlay[:WINDow<n>]:ZOOM:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe <State>

This command turns the zoom on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DISP:ZOOM ON

Activates the zoom mode.

Manual operation: See "Single Zoom"
See "Restore Original Display"
See "Deactivating Zoom (Selection mode)"


Querying the Status Registers

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Querying the Status Registers
Querying the Status Registers

The Realtime Spectrum application uses the standard status registers of the R&S FSW, as well as the STATus:QUEStionable:TIME register.

The MSRT operating mode uses an additional bit in the STATus:OPERation register.

This register and the commands required to query its contents are described here.

For details and a description of the common R&S FSW status registers see "Status Reporting System" .

*RST does not influence the status registers.

Contents
  • STATus:OPERation Register
  • STATus:QUEStionable:TIMe Register
  • Commands to Query the STATus:OPERation Register
  • Commands to Query the STATus:QUEStionable:TIME Register


STATus:OPERation Register

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Querying the Status Registers > STATus:OPERation Register
STATus:OPERation Register

The STATus:OPERation register contains information on current activities of the R&S FSW. It also contains information on activities that have been executed since the last read out.

You can read out the register with STATus:​OPERation:​CONDition? or STATus:​OPERation[:​EVENt]?.

Meaning of the bits used in the STATus:OPERation register
Bit No. | Meaning
0 | CALibrating This bit is set as long as the instrument is performing a calibration.
1-2 | Not used
3 | SWEeping Sweep is being performed in base unit (applications are not considered); identical to bit 4 In applications, this bit is not used.
4 | MEASuring Measurement is being performed in base unit (applications are not considered); identical to bit 3 In applications, this bit is not used.
5 | Waiting for TRIgger Instrument is ready to trigger and waiting for trigger signal.
6-7 | Not used
8 | HardCOPy in progress This bit is set while the instrument is printing a hardcopy.
9 | For data acquisition in MSRA/MSRT mode only: Multi-Standard capture finish This bit is set if a data acquisition measurement was completed successfully in MSRA/MSRT operating mode and data is available for evaluation.
10 | Range completed This bit is set when a range in the sweep list has been completed if "Stop after Range" has been activated.
11-14 | Not used
15 | This bit is always 0.


STATus:QUEStionable:TIMe Register

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Querying the Status Registers > STATus:QUEStionable:TIMe Register
STATus:QUEStionable:TIMe Register

The STATus:QUEStionable:TIMe register contains information about possible time errors that may occur during operation of the R&S FSW. A separate time register exists for each active channel.

You can read out the register with STATus:​QUEStionable:​TIMe:​CONDition? or STATus:​QUEStionable:​TIMe[:​EVENt]?

Meaning of the bits used in the STATus:QUEStionable:TIMe register
Bit No. | Meaning
0 | Realtime Data Loss This bit is set if the R&S FSW loses data during the measurement and measurements are no longer possible in realtime. (With Realtime option R&S FSW-K160R only)
1 to 14 | Unused
15 | This bit is always 0.


Commands to Query the STATus:OPERation Register

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Querying the Status Registers > Commands to Query the STATus:OPERation Register
Commands to Query the STATus:OPERation Register

The following commands are required to query the contents of the STATus:OPERation register.

List of Commands
STATus:OPERation:CONDition?
STATus:OPERation:ENABle?
STATus:OPERation:NTRansition?
STATus:OPERation:PTRansition?
STATus:OPERation[:EVENt]?


STATus:OPERation:CONDition?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Querying the Status Registers > Commands to Query the STATus:OPERation Register > STATus:OPERation:CONDition?
STATus:OPERation:CONDition? <ChannelName>

This comand reads out the CONDition section of the status register.

(See "STATus:OPERation Register")

The command does not delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


STATus:OPERation:ENABle?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Querying the Status Registers > Commands to Query the STATus:OPERation Register > STATus:OPERation:ENABle?
STATus:OPERation:ENABle? <SumBit>,<ChannelName>

This command controls the ENABle part of the register.

(See "STATus:OPERation Register")

The ENABle part allows true conditions in the EVENt part of the status register to bereported in the summary bit. If a bit is 1 in the enable register and its associated event bit transitions to true, a positive transition will occur in the summary bit reported to the next higher level.

Parameters:
<SumBit>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Usage: Query only


STATus:OPERation:NTRansition?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Querying the Status Registers > Commands to Query the STATus:OPERation Register > STATus:OPERation:NTRansition?
STATus:OPERation:NTRansition? <SumBit>,<ChannelName>

This command controls the Negative TRansition part of a register.

(See "STATus:OPERation Register")

Setting a bit causes a 1 to 0 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<SumBit>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Usage: Query only


STATus:OPERation:PTRansition?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Querying the Status Registers > Commands to Query the STATus:OPERation Register > STATus:OPERation:PTRansition?
STATus:OPERation:PTRansition? <SumBit>,<ChannelName>

This command controls the Positive TRansition part of the register.

(See "STATus:OPERation Register")

Setting a bit causes a 0 to 1 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<SumBit>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Usage: Query only


STATus:OPERation[:EVENt]?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Querying the Status Registers > Commands to Query the STATus:OPERation Register > STATus:OPERation[:EVENt]?
STATus:OPERation[:EVENt]? <ChannelName>

This command queries the contents of the EVENt section of the status register.

(See "STATus:OPERation Register")

A query deletes the contents of the EVENt section.

Query parameters:
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Return values:
<RegisterContents>
Range: 0 to 32767
Usage: Query only


Commands to Query the STATus:QUEStionable:TIME Register

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Querying the Status Registers > Commands to Query the STATus:QUEStionable:TIME Register
Commands to Query the STATus:QUEStionable:TIME Register

The following commands are required to query the contents of the STATus:QUEStionable:TIME register.

List of Commands
STATus:QUEStionable:TIMe:CONDition?
STATus:QUEStionable:TIMe:ENABle
STATus:QUEStionable:TIMe:NTRansition
STATus:QUEStionable:TIMe:PTRansition
STATus:QUEStionable:TIMe[:EVENt]?


STATus:QUEStionable:TIMe:CONDition?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Querying the Status Registers > Commands to Query the STATus:QUEStionable:TIME Register > STATus:QUEStionable:TIMe:CONDition?
STATus:QUEStionable:TIMe:CONDition?

This command queries the contents of the "CONDition" section of the STATus:QUEStionable:TIMe register (see STATus:​QUEStionable:​TIMe[:​EVENt]?). Readout does not delete the contents of the "CONDition" section.

Example: | STAT:QUES:TIM:COND?
Usage: | Query only


STATus:QUEStionable:TIMe:ENABle

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Querying the Status Registers > Commands to Query the STATus:QUEStionable:TIME Register > STATus:QUEStionable:TIMe:ENABle
STATus:QUEStionable:TIMe:ENABle <BitDefinition>

This command sets the bits of the "ENABle" section of the STATus:QUEStionable:TIMe register. The "ENABle" register selectively enables the individual events of the associated "EVENt" section for the summary bit.

Parameters:
<BitDefinition> | 0 to 65535
Example: | STAT:QUES:POW:ENAB 65535


STATus:QUEStionable:TIMe:NTRansition

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Querying the Status Registers > Commands to Query the STATus:QUEStionable:TIME Register > STATus:QUEStionable:TIMe:NTRansition
STATus:QUEStionable:TIMe:NTRansition <BitDefinition>

This command sets the edge detectors of all bits of the STATus:QUEStionable:TIMe register from 1 to 0 for the transitions of the "CONDition" bit.

Parameters:
<BitDefinition> | 0 to 65535
Example: | STAT:QUE:POWS:NTR 65535


STATus:QUEStionable:TIMe:PTRansition

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Querying the Status Registers > Commands to Query the STATus:QUEStionable:TIME Register > STATus:QUEStionable:TIMe:PTRansition
STATus:QUEStionable:TIMe:PTRansition <BitDefinition>

This command sets the edge detectors of all bits of the STATus:QUEStionable:TIMe register from 0 to 1 for the transitions of the "CONDition" bit.

Parameters:
<BitDefinition> | 0 to 65535
Example: | STAT:QUES:POW:PTR 65535


STATus:QUEStionable:TIMe[:EVENt]?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Querying the Status Registers > Commands to Query the STATus:QUEStionable:TIME Register > STATus:QUEStionable:TIMe[:EVENt]?
STATus:QUEStionable:TIMe[:EVENt]?

This command queries the contents of the "EVENt" section of the STATus:QUEStionable:TIMe register. Readout deletes the contents of the "EVENt" section.

Example: | STAT:QUES:POW?
Usage: | Query only


Commands for Compatibility

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Commands for Compatibility
Commands for Compatibility

Note that these commands are maintained for compatibility with the R&S FSVR only. Use the specified commands for new remote control programs.

DISPlay:WINDow[:SUBWindow] commands

For compatiblity with the R&S FSVR, the commands required to configure the persistence spectrum (see "Configuring the Persistence Spectrum") also accept the optional SUBWindow keyword (DISPlay:WINDow[:SUBWindow]...). However, this keyword is ignored and has no effect on remote control.

List of Commands
CALCulate<n>:FEED


CALCulate<n>:FEED

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Commands for Compatibility > CALCulate<n>:FEED
CALCulate<n>:FEED <ResultDisplay>

This command selects the result display in realtime mode.

Note that this command is maintained for compatibility reasons only. Use the LAYout commands for new remote control programs (see "Working with Windows in the Display").

Parameters:
<ResultDisplay>
'XFRequency:RFPower[:SPECtrum]'
'XFRequency[:SPECtrum]'

Selects the realtime spectrum result display.

'XFRequency:RFPower:SGRam'
'XFRequency:SGRam'

Selects the spectrogram result display.

'XFRequency:RFPower:PSPectrum'
'XFRequency:PSPectrum'

Selects the persistence spectrum result display.

'XTIMe:RFPower[:TDOMain]'
'XTIMe[:TDOMain]'

Selects the power vs time result display.

'XTIMe:RFPower:SGRam'
'XTIMe:SGRam'

Selects the power vs time waterfall diagram.

*RST: SPECtrum
Example: CALC:FEED 'XFR:PSP'

Starts the persistence spectrum result display.


Remote Commands for MSRT Operating Mode

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Remote Commands for MSRT Operating Mode
Remote Commands for MSRT Operating Mode

The following commands are required to perform measurements in the Multi-Standard Realtime (MSRT) operating mode. For details see "Applications and Operating Modes".

Contents
  • Activating Realtime Measurements in MSRT Mode
  • Analyzing Realtime Measurements in MSRT Mode


Activating Realtime Measurements in MSRT Mode

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Remote Commands for MSRT Operating Mode > Activating Realtime Measurements in MSRT Mode
Activating Realtime Measurements in MSRT Mode

Realtime measurements requires a special operating mode on the R&S FSW. A measurement is started immediately with the default settings.

The special MSRT Master measurement channel is of the channel type "RTIM" and is referred to by the channel name "MSRT Master". This channel cannot be replaced, deleted, or renamed.

List of Commands
INSTrument:MODE


INSTrument:MODE

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Remote Commands for MSRT Operating Mode > Activating Realtime Measurements in MSRT Mode > INSTrument:MODE
INSTrument:MODE <OpMode>

The operating mode of the R&S FSW determines which applications are available and active. Whenever you change the operating mode, the currently active measurement channels are stored. The default operating mode is Signal and Spectrum Analyzer mode, however, the presetting can be changed.

For details on operating modes and applications see "Applications and Operating Modes".

Parameters:
<OpMode>
SANalyzer

Signal and Spectrum Analyzer mode

MSRanalyzer

Multi-Standard Radio Analysis (MSRA) mode

RTMStandard

Multi-Standard Realtime (MSRT) mode

Only available if the realtime option (R&S FSW-K160R) is installed.

*RST: SAN
Example: INST:MODE MSR

Switches to MSRA mode.

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: SCPI confirmed


Analyzing Realtime Measurements in MSRT Mode

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Remote Commands for MSRT Operating Mode > Analyzing Realtime Measurements in MSRT Mode
Analyzing Realtime Measurements in MSRT Mode

The data that was captured by the MSRT Master can be analyzed in various different applications.

The analysis settings and functions available in MSRT mode are those described for the individual applications. The MSRT Master is in effect a Realtime Spectrum application and has the same analysis functions and settings.

Configuring an Analysis Interval and Line

In MSRT operating mode, only the MSRT Master actually captures data; the MSRT applications define an extract of the captured data for analysis, referred to as the analysis interval. The analysis line is a common time marker for all MSRT applications.

In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the analysis interval for the Realtime Spectrum measurement.

Remote commands exclusive to MSRT applications

The following commands are only available for MSRT application channels:

List of Commands
CALCulate:RTMS:ALINe:SHOW
CALCulate:RTMS:ALINe[:VALue]
CALCulate:RTMS:WINDow<n>:IVAL?
INITiate:REFResh
[SENSe:]RTMS:CAPTure:OFFSet


CALCulate:RTMS:ALINe:SHOW

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Remote Commands for MSRT Operating Mode > Analyzing Realtime Measurements in MSRT Mode > CALCulate:RTMS:ALINe:SHOW
CALCulate:RTMS:ALINe:SHOW

This command defines whether or not the analysis line is displayed in all time-based windows in all MSRT applications and the MSRT Master.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Parameters:
<State>
ON | OFF
*RST: ON
Manual operation: See "Show Line"


CALCulate:RTMS:ALINe[:VALue]

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Remote Commands for MSRT Operating Mode > Analyzing Realtime Measurements in MSRT Mode > CALCulate:RTMS:ALINe[:VALue]
CALCulate:RTMS:ALINe[:VALue] <Position>

This command defines the position of the analysis line for all time-based windows in all MSRT applications and the MSRT Master.

Parameters:
<Position>

Position of the analysis line in seconds. The position must lie within the measurement time (pretrigger + posttrigger) of the MSRT measurement.

Default unit: s
Manual operation: See "Position"


CALCulate:RTMS:WINDow<n>:IVAL?

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Remote Commands for MSRT Operating Mode > Analyzing Realtime Measurements in MSRT Mode > CALCulate:RTMS:WINDow<n>:IVAL?
CALCulate:RTMS:WINDow<n>:IVAL?

This command queries the analysis interval for the window specified by the index <n>. This command is only available in application measurement channels, not the MSRT View or MSRT Master.

Return values:
<IntStart>

Start value of the analysis interval in seconds

Default unit: s
<IntStop>

Stop value of the analysis interval in seconds

Usage: Query only


INITiate:REFResh

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Remote Commands for MSRT Operating Mode > Analyzing Realtime Measurements in MSRT Mode > INITiate:REFResh
INITiate:REFResh

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only for applications in MSRA/MSRT mode, not the MSRA/MSRT Master.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

The application channel must be selected before this command can be executed (see INSTrument[:​SELect]).

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INST:SEL 'IQ ANALYZER' Selects the IQ Analyzer channel. INIT:REFR Refreshes the display for the I/Q Analyzer channel.
Usage: | Event
Manual operation: | See "Refresh"


[SENSe:]RTMS:CAPTure:OFFSet

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Remote Commands for MSRT Operating Mode > Analyzing Realtime Measurements in MSRT Mode > [SENSe:]RTMS:CAPTure:OFFSet
[SENSe:]RTMS:CAPTure:OFFSet <Offset>

This setting is only available for applications in MSRT mode, not for the MSRT Master. It has a similar effect as the trigger offset in other measurements.

Parameters:
<Offset>

This parameter defines the time offset between the capture buffer start and the start of the extracted application data. The offset must be a positive value, as the application can only analyze data that is contained in the capture buffer.

Range: | - [pretrigger time] to min (posttrigger time; sweep time)
*RST: | 0
Manual operation: See "Capture Offset"


Programming Examples: Performing Realtime Measurements

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Programming Examples: Performing Realtime Measurements
Programming Examples: Performing Realtime Measurements

The following programming examples demonstrate how to perform realtime measurements in a remote environment.

Some commands in the following examples may not be necessary as they reflect the default settings; however, they are included to demonstrate the command usage.

Contents
  • Example 1: Creating a Frequency Mask Trigger
  • Example 2: Performing a Basic Realtime Measurement
  • Example 3: Analyzing Persistency
  • Example 4: Obtaining Time Domain Results in Realtime


Example 1: Creating a Frequency Mask Trigger

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Programming Examples: Performing Realtime Measurements > Example 1: Creating a Frequency Mask Trigger
Example 1: Creating a Frequency Mask Trigger

In this example we will create a frequency mask trigger with an upper and lower mask. This trigger mask can be used in "Example 2: Performing a Basic Realtime Measurement".

//------------ Configuring a frequency mask trigger -----------------
//Store trigger mask as 'C:\R_S\INSTR\freqmask\myFMTS\NewFreqMaskTrigger'
//Note the 'myFMTS' subdirectory must be created under 'C:\R_S\INSTR\freqmask'
//beforehand.
CALC:MASK:CDIR 'myFMTS'
CALC:MASK:NAME 'NewFreqMaskTrigger'
CALC:MASK:COMM 'Upper and lower frequency mask'

//------------ Defining an upper frequency mask automatically ----------------
//Use relative scaling for the level axis
CALC:MASK:MODE REL
//Define a span of 20 MHz
CALC:MASK:SPAN 20000000
//Configure automatic upper mask according to measured spectrum
CALC:MASK:UPP:AUTO
//Query the mask points for the upper mask
CALC:MASK:UPP:DATA?
//Result: comma-separated list of value pairs (Frequency, level);
//one for each data point
//Example:
//-9.990009990E+006,-9.600020599E+001,-9.230769231E+006,-8.738758087E+001,
//-8.831168831E+006,-9.565835571E+001,-7.972027972E+006,-8.494093323E+001,
//...
//+8.171828172E+006,-8.577051544E+001,+8.631368631E+006,-9.534964752E+001,
//+9.530469530E+006,-8.848562622E+001,+9.990009990E+006,-9.600020599E+001

//------------ Configuring the lower frequency mask manually -------------------
//Configure lower mask 20 dB lower than upper mask;
//Use upper mask as basis, then shift all values by 20 dB
CALC:MASK:LOW:STAT ON
CALC:MASK:LOW:DATA -9.990009990E+006,-9.600020599E+001,-9.230769231E+006,-8.738758087E+001,
-8.831168831E+006,-9.565835571E+001,-7.972027972E+006,-8.494093323E+001,
-7.492507493E+006,-9.450020599E+001,-6.793206793E+006,-7.878201294E+001,
-6.693306693E+006,-7.925418091E+001,-6.213786214E+006,-9.578102112E+001,
-5.414585415E+006,-3.991313553E+001,-4.995004995E+006,-3.050031662E+001,
-4.575424575E+006,-3.975288010E+001,-3.776223776E+006,-9.574020386E+001,
-3.296703297E+006,-7.856089020E+001,-2.777222777E+006,-8.525804901E+001,
-2.497502498E+006,-9.450020599E+001,-1.878121878E+006,-8.315855408E+001,
-1.258741259E+006,-9.424127960E+001,-1.238761239E+006,-9.424189758E+001,
-1.058941058E+006,-8.987026215E+001,-4.995004995E+005,-9.452841949E+001,
-3.308057785E-006,-9.450020599E+001,+5.394605395E+005,-8.521303558E+001,
+1.238761239E+006,-9.425141144E+001,+1.258741259E+006,-9.425095367E+001,
+1.858141858E+006,-8.382637787E+001,+2.497502497E+006,-9.450020599E+001,
+2.817182817E+006,-8.492385864E+001,+3.356643357E+006,-8.088692474E+001,
+3.756243756E+006,-9.698367310E+001,+4.535464535E+006,-4.851605225E+001,
+4.995004995E+006,-3.950028992E+001,+5.454545455E+006,-4.873092270E+001,
+6.213786214E+006,-9.597808838E+001,+6.273726274E+006,-9.304232788E+001,
+6.773226773E+006,-8.045437622E+001,+7.492507493E+006,-9.450020599E+001,
+8.171828172E+006,-8.577051544E+001,+8.631368631E+006,-9.534964752E+001,
+9.530469530E+006,-8.848562622E+001,+9.990009990E+006,-9.600020599E+001
CALC:MASK:LOW:SHIFT:Y -20


Example 2: Performing a Basic Realtime Measurement

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Programming Examples: Performing Realtime Measurements > Example 2: Performing a Basic Realtime Measurement
Example 2: Performing a Basic Realtime Measurement

The first measurement example performs a basic realtime measurement in the frequency domain with the default display configuration (Realtime spectrum and spectrogram). It uses a frequency mask trigger stored as C:\R_S\INSTR\freqmask\myFMTS\NewFreqMaskTrigger, as described in "Example 1: Creating a Frequency Mask Trigger".

To perform a basic realtime measurement without a frequency mask trigger, simply remove the section Using a Frequency Mask Trigger in the following example.

//--------------Preparing the instrument -----------
//Reset the instrument
*RST

//---------- Activating a Realtime measurement channel -----------
//Activate a realtime measurement channel named "Realtime"
INST:CRE:NEW RTIM,'Realtime'

//Stop the current measurement
INIT:CONT OFF

//-------------- Configuring the Measurement -----
//Define the center frequency
FREQ:CENT 100MHz
//Set the span to 10 MHz on either side of the center frequency.
FREQ:SPAN 20MHz

//Set the reference level to 0 dBm
DISP:TRAC:Y:SCAL:RLEV 0

//Couple the RBW to the span, with RBW/span = 0.000625 (manual op: span/RBW = 1600)
BAND:RAT 0.000625
//Use a Gaussian FFT window function
SWE:FFT:WIND:TYPE GAUS
//Collect data for 20 ms for each spectrum
SWE:TIME 0.02

//----------- Using a Frequency Mask Trigger ------------------------
//Configure the use of an existing frequency mask (from Example 4) as a trigger
TRIG:SOUR MASK
//Select the mask to use
CALC:MASK:CDIR 'myFMTS'
CALC:MASK:NAME 'NewFreqMaskTrigger'
//Trigger on entering the frequency mask
TRIG:MASK:COND ENT

//Define a pretrigger period of 10 ms, posttrigger = 0.5 s
TRIG:PRET 0.001
TRIG:POST 0.5
//Use rearming trigger mode to perform continuous measurements
TRIG:MODE CONT

//-------------- Configuring the result displays -------------
//Clear the initial spectrogram results
CALC2:SPEC:CLE
//Store up to 1000 spectrogram frames
CALC2:SPEC:HDEP 1000

//-------------- Configuring spectrogram color mapping -----------------
//Use grayscale coloring
DISP:WIND2:SPEC:COL GRAY
//Configure a value range from 0.5% to 95%
DISP:WIND2:SPEC:COL:LOW 0.5
DISP:WIND2:SPEC:COL:UPP 95
//Change the shape of the color mapping function to distribute more colors among
//high values
DISP:WIND2:SPEC:COL:SHAP 0.35

//-------------- Performing the Measurement -----
//Initiate a new measurement
INIT:CONT ON
INIT:IMM
//Wait until some measurements have been performed.
INIT:CONT OFF

//--------------- Retrieving Results -------------
//Query the spectrogram results for the realtime measurement
CALC2:SPEC:TST:DATA? ALL
//Result: 4 values for each of the measured frames indicating the time passed
//since 01.01.1970 till the start of the frame, e.g.:
//1370524679,49559852,0,0,1370524679,18552034,0,0,
//1370524678,987161993,0,0,1370524678,971568114,0,0,
//...
//1370524670,79975615,0,0,1370524670,48813821,0,0
//First frame: 01.01.1970 + 1370524670 seconds
//Most recent frame: 01.01.1970 + 1370524679 seconds
//Measurement duration: 1370524679 s - 1370524670 s = 9 s

//Return the 1001 measured power levels for each of the measured frames
TRAC2:DATA? SPEC

//Store the spectrogram to a file
MMEM:STOR2:SPEC 'C:\temp\spectrogram'

//Query spectrum results for the most recent spectrum
CALC2:SPEC:FRAM:SEL 0
TRAC1:DATA:X? TRACE1
TRAC1:DATA? TRACE1

//Query spectrum results for the previous spectrum
CALC2:SPEC:TST OFF
//Use frame index instead of time stamp
CALC2:SPEC:FRAM:SEL -1
TRAC1:DATA:X? TRACE1
TRAC1:DATA? TRACE1
//Store these spectrum results to a file
MMEM:STOR1:TRAC 1,'C:\temp\FirstSpectrum'

//---------------- Analyzing the results using markers -------------------
//Set marker1 on the peak power in the most recent spectrum and query
//its position
CALC2:SPEC:FRAM:SEL 0
CALC2:MARK1 ON
CALC2:MARK1:X?
CALC2:MARK1:Y?

//Set marker2 on the peak power in frame -1 and query its position
CALC2:MARK2 ON
CALC2:MARK2:SGR:FRAM -1s
CALC2:MARK2:X?
CALC2:MARK2:Y?

//Set marker3 on peak power level in the entire spectrogram in memory and
//query its position
CALC2:MARK3 ON
CALC2:MARK:SPEC:SAR MEM
CALC2:MARK3:SPEC:XY:MAX
CALC2:MARK3:X?
CALC2:MARK3:Y?

//Move marker 3 to the next lower peak level for the same frequency
CALC2:MARK3:SPEC:Y:MAX:NEXT
CALC2:MARK3:X?
CALC2:MARK3:Y?

//Set marker4 on the most recent trigger event in the spectrogram and query
//its position
CALC2:MARK4 ON
CALC2:MARK4:SPEC:Y:TRIG
CALC2:MARK4:X?
CALC2:MARK4:Y?


Example 3: Analyzing Persistency

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Programming Examples: Performing Realtime Measurements > Example 3: Analyzing Persistency
Example 3: Analyzing Persistency

This measurement example performs a basic realtime measurement in the frequency domain with an additional persistence spectrum window. It uses a frequency mask trigger stored as C:\R_S\INSTR\freqmask\myFMTS\NewFreqMaskTrigger, as described in "Example 1: Creating a Frequency Mask Trigger".

To perform a basic realtime measurement without a frequency mask trigger, simply remove the section Using a Frequency Mask Trigger in the following example.

//--------------Preparing the instrument -----------
//Reset the instrument
*RST

//---------- Activating a Realtime measurement channel -----------
//Activate a realtime measurement channel named "Realtime"
INST:CRE:NEW RTIM,'Realtime'

//Stop the current measurement
INIT:CONT OFF

//-------------- Configuring the Measurement -----
//Define the center frequency
FREQ:CENT 100MHz
//Set the span to 10 MHz on either side of the center frequency.
FREQ:SPAN 20MHz

//Set the reference level to 0 dBm
DISP:TRAC:Y:SCAL:RLEV 0

//Couple the RBW to the span, with RBW/span = 0.000625 (manual op: span/RBW = 1600)
BAND:RAT 0.000625
//Use a Gaussian FFT window function
SWE:FFT:WIND:TYPE GAUS
//Collect data for 20 ms for each spectrum
SWE:TIME 0.02

//----------- Using a Frequency Mask Trigger ------------------------
//Configure the use of an existing frequency mask (from Example 4) as a trigger
TRIG:SOUR MASK
//Select the mask to use
CALC:MASK:CDIR 'myFMTS'
CALC:MASK:NAME 'NewFreqMaskTrigger'
//Trigger on entering the frequency mask
TRIG:MASK:COND ENT

//Define a pretrigger period of 10 ms, posttrigger = 0.5 s
TRIG:PRET 0.001
TRIG:POST 0.5
//Use rearming trigger mode to perform continuous measurements
TRIG:MODE CONT

//-------------- Configuring the result displays -------------
//Add a persistence spectrum result display
LAY:ADD? '1',RIGH,'XFRequency:PSPectrum'
//Result: '3'
//Clear the initial spectrogram results
CALC2:SPEC:CLE

//Configure vector-style trace for an uninterrupted (interpolated)
//persistence spectrum
DISP:WIND:TRAC:SYMB VECT

//Define a perstistence duration of 1.2 s
DISP:WIND:TRAC:PERS:DUR 1.2
//Use the data captured in 120 ms for a single frame (perstistence granularity)
DISP:WIND:TRAC:PERS:GRAN 0.12

//Activate the maxhold trace in the persistence spectrum display
DISP:WIND:TRAC:MAXH ON
//Define an intensity of 125 for the maxhold trace
DISP:WIND:TRAC:MAXH:INT 125
//Clear the maxhold trace
DISP:WIND:TRAC:MAXH:RES

//-------------- Configuring persistence color mapping -----------------
//Use greyscale coloring
DISP:WIND:PSP:COL GRAY
//Configure a value range from 0.5% to 95%
DISP:WIND:PSP:COL:LOW 0.5
DISP:WIND:PSP:COL:UPP 95
//Reduce the range of the color map if no hits are found at the value range edges
DISP:WIND:PSP:COL:TRUN ON
//Change the shape of the color mapping function to distribute more colors among
//high values
DISP:WIND:PSP:COL:SHAP 0.35

//-------------- Performing the Measurement -----
//Initiate a new measurement and wait until some measurements have been performed.
INIT:CONT ON
INIT:IMM
INIT:CONT OFF

//--------------- Retrieving Results -------------
//Query the persistence spectrum results
TRAC3:DATA? PSP
//Result: 1001*600 percentages, one for each pixel in the histogram

//Return the 1001 measured power levels for the most recent spectrum
TRAC3:DATA? TRACE1

//Return the 1001*600 maximum probabilities for the maxhold trace
TRAC3:DATA? HMAX

//Store the persistence spectrum to a file
MMEM:STOR3:PSP 'C:\temp\persistence'


Example 4: Obtaining Time Domain Results in Realtime

Realtime Application (R&S FSW-K160R) > Remote Commands to Perform Realtime Measurements > Programming Examples: Performing Realtime Measurements > Example 4: Obtaining Time Domain Results in Realtime
Example 4: Obtaining Time Domain Results in Realtime

This example demonstrates how to obtain results in the time domain in a realtime measurement. It uses a trigger based on power levels measured in the time domain.

//--------------Preparing the instrument -----------
//Reset the instrument
*RST

//---------- Activating a Realtime measurement channel -----------

//Activate a realtime measurement channel named "Realtime"
INST:CRE:NEW RTIM,'Realtime'

//Stop the current measurement
INIT:CONT OFF

//-------------- Selecting a multi-domain measurement -----
CONF:REAL:MEAS MDOM
//Activate a PVT and PVT waterfall result display
LAY:ADD? '1',RIGH,'XTIMe'
//Result: '3'
LAY:ADD? '2',RIGH,'XTIMe:SGRam'
//Result: '4'

//-------------- Configuring the measurement -----
//Define the center frequency
FREQ:CENT 100MHz
//Set the span to the full 100 MHz for multi-domain
FREQ:SPAN:FULL

//Set the reference level to 0 dBm
DISP:TRAC:Y:SCAL:RLEV 0

//Use a rectangular FFT window function
SWE:FFT:WIND:TYPE RECT
//Use a coupling ratio RBW/span = 0.00125 (manual op: span/RBW = 800)
BAND:RAT 0.00125
//Query the resulting RBW (125 kHz)
BAND?
//Result: 125000
//Collect data for 20 ms for each spectrum
SWE:TIME 0.02
//Collect data for 15 ms for each PVT diagram
SENS3:SWE:TIME 0.015

//Configure a power level trigger at -50dBm
TRIG:SOUR TDTR
TRIG:TDTR:LEV -50
//Define a pretrigger period of 10 ms, posttrigger = 0.5 s
TRIG:PRET 0.001
TRIG:POST 0.5
//Use stop on trigger mode to perform only one measurement
TRIG:MODE STOP

//-------------- Configuring the result displays -------------
//Clear the initial spectrogram and PVT waterfall results
CALC2:SPEC:CLE
CALC4:SPEC:CLE
//Store up to 1000 spectrogram or PVT frames
CALC2:SPEC:HDEP 1000
//Use index instead of time stamps to identify individual frames
CALC2:SPEC:TST OFF

//-------------- Configuring waterfall color mapping -----------------
//Use grayscale coloring
DISP:WIND4:SPEC:COL GRAY
//Configure a value range from 0.5% to 95%
DISP:WIND4:SPEC:COL:LOW 0.5
DISP:WIND4:SPEC:COL:UPP 95
//Change the shape of the color mapping function to distribute more colors among
//high values
DISP:WIND4:SPEC:COL:SHAP 0.35

//-------------- Performing the Measurement -----
//Initiate a new measurement and wait until a measurement has been performed
INIT;*WAI

//--------------- Retrieving Results -------------
//Return the 1001 measured power levels for each PVT diagram
TRAC4:DATA? SPEC

//Store the PVT waterfall diagram to a file
MMEM:STOR4:SPEC 'C:\temp\PVTWaterfall'

//Query time and power values for the most recent PVT
CALC2:SPEC:FRAM:SEL 0
TRAC3:DATA:X? TRACE1
TRAC3:DATA? TRACE1
//Store these PVT results to a file
MMEM:STOR3:TRAC 1,'C:\temp\PVT'

//Query time and power values for the previous PVT
CALC2:SPEC:FRAM:SEL -1
TRAC3:DATA:X? TRACE1
TRAC3:DATA? TRACE1


Reference: ASCII File Export Format

Realtime Application (R&S FSW-K160R) > Reference: ASCII File Export Format
Reference: ASCII File Export Format

Trace data (for example realtime spectrum, persistence spectrum, or spectrogram) can be exported to a file in ASCII format for further evaluation in other applications.

The file consists of the header containing important measurement parameters and a data section containing the trace data.

Generally, the format of this ASCII file can be processed by spreadsheet calculation programs, e.g. MS-Excel. Different language versions of evaluation programs may require a different handling of the decimal point. Thus you can define the decimal separator to be used (decimal point or comma, see "Decimal Separator").

The data of the file header consist of three columns, each separated by a semicolon: parameter name; numeric value; basic unit. The data section contains the measured data in two columns, which are also separated by a semicolon.

The file contents vary depending on the result type.

ASCII file format for Spectrum trace export
File contents | Description
Header data
Type;R&S FSW; | Instrument model
Version;1.80; | Firmware version
Date;20.Jul 2013; | Date of data set storage
Mode;REALTIME; | Channel type
Preamplifier;OFF; | Preamplifier state
Transducer;OFF; | Transducer state
Center Freq;1000000000.000000;Hz | Center frequency
Freq Offset;0.000000;Hz | Frequency offset
Start;920000000.000000;Hz | Start frequency
Stop;1080000000.000000;Hz | Stop frequency
Span;160000000.000000;Hz | Measured span
Ref Level;0.000000;dBm | Reference level
Level Offset;0.000000;dB | Reference level offset
Rf Att;10.000000;dB | Input attenuation
El Att;0.000000;dB | Electronic attentuation
RBW;800000.000000;Hz | Resolution bandwidth
SWT;0.030000;s | Sweep time
Sweep Count;0; | Number of sweeps
Window;1;Realtime Spectrum | Window containing the exported results
Ref Position;100.000000; % | Reference level position in percent
Level Range;100.000000;dB | Power level (y-axis) range
x-Axis;LIN; | x-axis scaling mode (linear, log.)
y-Axis;LOG; | y-axis scaling mode (linear, log.)
x-Unit;Hz; | x-axis unit
y-Unit;dBm; | y-axis unit
Data section
Trace;1; | Trace number
Trace Mode;CLR/WRITE; | Trace mode
Detector;MAXPEAK; | Detector used for trace
Values; 1001; | Number of measured frequencies
13170000000;-100.50020599365234; 13170160000;-100.16989898681641; …;…; | Measured values: <frequency>, <power level>
ASCII file format for persistence spectrum trace export
File contents | Description
Header data
Type;R&S FSW; | Instrument model
Version;1.80; | Firmware version
Date;20.Jul 2013; | Date of data set storage
Mode;REALTIME; | Channel type
Preamplifier;OFF; | Preamplifier state
Transducer;OFF; | Transducer state
Center Freq;1000000000.000000;Hz | Center frequency
Freq Offset;0.000000;Hz | Frequency offset
Start;920000000.000000;Hz | Start frequency
Stop;1080000000.000000;Hz | Stop frequency
Span;160000000.000000;Hz | Measured span
Ref Level;0.000000;dBm | Reference level
Level Offset;0.000000;dB | Reference level offset
Rf Att;10.000000;dB | Input attenuation
El Att;0.000000;dB | Electronic attentuation
RBW;800000.000000;Hz | Resolution bandwidth
SWT;0.030000;s | Sweep time
Sweep Count;0; | Number of sweeps
Trace Mode;CLR/WRITE;MAXHOLD; | Display mode of traces: 1. CLR/WRITE; 2.MAXHOLD
Detector;PERSISTENCE; | Detector used for trace (none for persistence)
Data section
Values; 1001;600; | Number of measurement points for x-axis (frequency) and y-axis (power)
920000000;920160000;920320000;920480000; ... 1079520000;1079680000;1079840000;1080000000 | 1001 frequency values used for histogram
-37.5;-37.583472454090149; ... -87.416527545909844;-87.5 | 600 power levels used for histogram
CLR/WRITE | Introduction for persistence spectrum data
0;0;0; .... 0.60534548759460449;0.37962344288825989 | 1000*600 most recently calculated percentage values in histogram from top left to bottom right, that is, starting with the lowest frequency and highest power value and ending with the highest frequency and lowest power level
MAXHOLD | Introduction for MAXHOLD data
0;0;0; .... 0.90801829099655151;0.56943517923355103 | 1000*600 maximum percentage values for MAXHOLD trace from top left to bottom right, that is, starting with the lowest frequency and highest power value and ending with the highest frequency and lowest power level
ASCII file format for spectrogram trace export
File contents | Description
Header data
Type;R&S FSW; | Instrument model
Version;1.80; | Firmware version
Date;20.Jul 2013; | Date of data set storage
Mode;REALTIME; | Channel type
Preamplifier;OFF; | Preamplifier state
Transducer;OFF; | Transducer state
Center Freq;1000000000.000000;Hz | Center frequency
Freq Offset;0.000000;Hz | Frequency offset
Start;920000000.000000;Hz | Start frequency
Stop;1080000000.000000;Hz | Stop frequency
Span;160000000.000000;Hz | Measured span
Ref Level;0.000000;dBm | Reference level
Level Offset;0.000000;dB | Reference level offset
Rf Att;10.000000;dB | Input attenuation
El Att;0.000000;dB | Electronic attentuation
RBW;800000.000000;Hz | Resolution bandwidth
SWT;0.030000;s | Sweep time
Sweep Count;0; | Number of sweeps
Window;1;Realtime Spectrum | Window containing the exported results
Ref Position;100.000000; % | Reference level position in percent
Level Range;100.000000;dB | Power level (y-axis) range
x-Axis;LIN; | x-axis scaling mode (linear, log.)
y-Axis;LOG; | y-axis scaling mode (linear, log.)
x-Unit;Hz; | x-axis unit
y-Unit;dBm; | y-axis unit
Data section
Trace;1; | Trace number
Trace Mode;CLR/WRITE; | Trace mode
Detector;MAXPEAK; | Detector used for trace
Values; 1001; | Number of measured frequencies
Frames;130; | Number of exported frames
Data section for individual frame
Frame;0; | Most recent frame number
Timestamp;29.Jul 13;08:51:19.355 | Timestamp of this frame
10000;-10.3;-15.7 10130;-11.5;-16.9 10360;-12.0;-17.4 ...;...; | Measured values: <frequency>; <power value1>; <power value2>; <power value 2> only for AUTOPEAK detector; contains the minimum of the two measured values for each measurement point
Data section for individual frame
Frame;-1; | Previous frame
Timestamp;29.Jul 13;08:51:19.278 | Timestamp of this frame
... |


List of Remote Commands (Realtime)

Realtime Application (R&S FSW-K160R) > List of Remote Commands (Realtime)
List of Remote Commands (Realtime)
[SENSe:][WINDow:]DETector<t>[:FUNCtion]
[SENSe:]ADJust:ALL
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:CONFigure:TRIG
[SENSe:]ADJust:FREQuency
[SENSe:]ADJust:LEVel
[SENSe:]AVERage:COUNt
[SENSe:]AVERage<n>[:STATe<t>]
[SENSe:]BANDwidth|BWIDth[:RESolution]
[SENSe:]BANDwidth|BWIDth[:RESolution]:RATio
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:LINK
[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor
[SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:SPAN
[SENSe:]FREQuency:SPAN:FULL
[SENSe:]FREQuency:STARt
[SENSe:]FREQuency:STOP
[SENSe:]RTMS:CAPTure:OFFSet
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:FFT:WINDow:TYPE
[SENSe:]SWEep:TIME:AUTO
[SENSe<n>:]SWEep:TIME
ABORt
CALCulate:MARKer:LOEXclude
CALCulate:MARKer:X:SLIMits:LEFT
CALCulate:MARKer:X:SLIMits:RIGHT
CALCulate:MARKer:X:SLIMits:ZOOM[:STATe]
CALCulate:MARKer:X:SLIMits[:STATe]
CALCulate:MARKer:X:SSIZe
CALCulate:RTMS:ALINe:SHOW
CALCulate:RTMS:ALINe[:VALue]
CALCulate:RTMS:WINDow<n>:IVAL?
CALCulate:THReshold
CALCulate:THReshold:STATe
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:MODE
CALCulate<n>:DELTamarker<m>:LINK
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:FRAMe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:SARea
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:BELow
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:BELow
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>:Z?
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:FEED
CALCulate<n>:MARKer:PEXCursion
CALCulate<n>:MARKer:SGRam|SPECtrogram:SARea
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:FUNCtion:CENTer
CALCulate<n>:MARKer<m>:FUNCtion:REFerence
CALCulate<n>:MARKer<m>:MAXimum:AUTO
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:AUTO
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:FRAMe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:BELow
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:BELow
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:NEXT
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:TRIGger
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>:Z?
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MASK:CDIRectory
CALCulate<n>:MASK:COMMent
CALCulate<n>:MASK:DELete
CALCulate<n>:MASK:LOWer:SHIFt:X
CALCulate<n>:MASK:LOWer:SHIFt:Y
CALCulate<n>:MASK:LOWer:STATe
CALCulate<n>:MASK:LOWer[:DATA]
CALCulate<n>:MASK:MODE
CALCulate<n>:MASK:NAME
CALCulate<n>:MASK:SPAN
CALCulate<n>:MASK:UPPer:AUTO
CALCulate<n>:MASK:UPPer:SHIFt:X
CALCulate<n>:MASK:UPPer:SHIFt:Y
CALCulate<n>:MASK:UPPer:STATe
CALCulate<n>:MASK:UPPer[:DATA]
CALCulate<n>:MATH:MODE
CALCulate<n>:MATH:POSition
CALCulate<n>:MATH:STATe
CALCulate<n>:MATH[:EXPression][:DEFine]
CALCulate<n>:SGRam|SPECtrogram:CLEar[:IMMediate]
CALCulate<n>:SGRam|SPECtrogram:COLor
CALCulate<n>:SGRam|SPECtrogram:FRAMe:SELect
CALCulate<n>:SGRam|SPECtrogram:HDEPth
CALCulate<n>:SGRam|SPECtrogram:TSTamp:DATA?
CALCulate<n>:SGRam|SPECtrogram:TSTamp[:STATe]
CONFigure:REALtime:MEASurement
DIAGnostic:SERVice:NSOurce
DISPlay:FORMat
DISPlay:MTABle
DISPlay:WINDow:[SUBWindow:]TRACe:MAXHold:INTensity
DISPlay:WINDow:[SUBWindow:]TRACe:MAXHold:RESet
DISPlay:WINDow:[SUBWindow:]TRACe:MAXHold[:STATe]
DISPlay:WINDow:[SUBWindow:]TRACe:PERSistence:DURation
DISPlay:WINDow:[SUBWindow:]TRACe:PERSistence:GRANularity
DISPlay:WINDow:[SUBWindow:]TRACe:PERSistence[:STATe]
DISPlay:WINDow:[SUBWindow:]TRACe:SYMBol
DISPlay:WINDow:PSPectrum:COLor:DEFault
DISPlay:WINDow:PSPectrum:COLor:LOWer
DISPlay:WINDow:PSPectrum:COLor:SHAPe
DISPlay:WINDow:PSPectrum:COLor:TRUNcate
DISPlay:WINDow:PSPectrum:COLor:UPPer
DISPlay:WINDow:PSPectrum:COLor[:STYLe]
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:DEFault
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:LOWer
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:SHAPe
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:UPPer
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor[:STYLe]
DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:TRACe:Y:SPACing
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:STATe
FORMat:DEXPort:DSEParator
FORMat:DEXPort:HEADer
FORMat:DEXPort:TRACes
FORMat[:DATA]
INITiate:CONMeas
INITiate:CONTinuous
INITiate:REFResh
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SEQuencer:REFResh[:ALL]
INITiate[:IMMediate]
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:ATTenuation:PROTection:RESet
INPut:CONNector
INPut:COUPling
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:GAIN:STATe
INPut:GAIN[:VALue]
INPut:IMPedance
INPut:SELect
INSTrument:CREate:DUPLicate
INSTrument:CREate:REPLace
INSTrument:CREate[:NEW]
INSTrument:DELete
INSTrument:LIST?
INSTrument:MODE
INSTrument:REName
INSTrument[:SELect]
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace
MMEMory:STORe<n>:PSPectrum
MMEMory:STORe<n>:SGRam
MMEMory:STORe<n>:TRACe
OUTPut:IF:IFFRequency
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth
STATus:OPERation:CONDition?
STATus:OPERation:ENABle?
STATus:OPERation:NTRansition?
STATus:OPERation:PTRansition?
STATus:OPERation[:EVENt]?
STATus:QUEStionable:TIMe:CONDition?
STATus:QUEStionable:TIMe:ENABle
STATus:QUEStionable:TIMe:NTRansition
STATus:QUEStionable:TIMe:PTRansition
STATus:QUEStionable:TIMe[:EVENt]?
SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:COMPatible
SYSTem:SEQuencer
TRACe<n>:COPY
TRACe<n>[:DATA]:MEMory?
TRACe<n>[:DATA]:X?
TRACe<n>[:DATA]?
TRIGger:MODE
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:MASK:CONDition
TRIGger[:SEQuence]:POSTtrigger[:TIME]
TRIGger[:SEQuence]:PRETrigger[:TIME]
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:TDTRigger:LEVel


Legal Notice

R&S®FSW-K160R
Realtime Spectrum Application and MSRT Operating Mode

© 2014 Rohde & Schwarz GmbH & Co. KG

Mühldorfstr. 15, 81671 München, Germany

Phone: +49 89 41 29 - 0

Fax: +49 89 41 29 12 164

E-mail: info@rohde-schwarz.com

Internet: www.rohde-schwarz.com

Subject to change – Data without tolerance limits is not binding.

R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.

Trade names are trademarks of the owners.